#opencontainers: 2016-01-20 discussion

Meeting started by wking at 18:02:23 UTC (full logs).

Meeting summary

  1. versioning OCI repos (wking, 18:03:14)
    1. Spec is primary version and other repos should match spec (RobDolinMS, 18:06:59)
    2. ACTION: mrunalp to setup these branches in opencontainers/ocitools (wking, 18:07:07)

  2. JSON Schema for validation (wking, 18:08:13)
    1. https://github.com/opencontainers/specs/pull/313 (wking, 18:08:27)
    2. : Present: on BlueJeans call: Mrunal Patel, Abhijeeth Nuthan, Brandon Philips, Dug, Guest, Jesse Butler, julz, Mike Brown... (RobDolinMS, 18:12:37)

  3. single, unified config file (wking, 18:12:57)
    1. https://github.com/opencontainers/specs/pull/284 (wking, 18:13:01)
    2. : Present on BlueJeans call: ... Tianon, Trevor King, Vincent Boen Batts, Vishnu Kannan (RobDolinMS, 18:13:05)
    3. ACTION: wking to reroll #284 on the current master (wking, 18:13:31)

  4. splitting mknod from device cgroups (wking, 18:13:44)
    1. https://github.com/opencontainers/specs/pull/298 (wking, 18:13:53)
    2. : Now present on call: Jason Bouzane (RobDolinMS, 18:16:15)
    3. https://github.com/opencontainers/specs/pull/298/files#diff-b753d6f046da0a2956b5218efd779b7fR119 (wking, 18:17:33)
    4. : Now present on BlueJeans call: crosbymichael (RobDolinMS, 18:20:39)

  5. prctl vs DisableNewPrivileges (wking, 18:26:40)
    1. https://github.com/opencontainers/specs/milestones/v0.3.0 (vbatts, 18:26:41)
    2. https://github.com/opencontainers/specs/pull/290 (wking, 18:26:44)
    3. ACTION: mrunalp to reroll with the consistent name (wking, 18:28:39)
    4. https://github.com/opencontainers/specs/pull/225 (mrunalp, 18:29:06)

  6. expanded ops definitions (wking, 18:29:11)
    1. https://github.com/opencontainers/specs/pull/225 (wking, 18:29:19)
    2. ACTION: Maintainers should review (RobDolinMS, 18:32:40)

  7. separate source and schema (wking, 18:34:29)
    1. https://github.com/opencontainers/specs/pull/276 (wking, 18:34:36)
    2. https://github.com/opencontainers/runc/pull/465 (duglin, 18:40:27)
    3. Targeting Wed, Feb 3rd for v0.3.0 (RobDolinMS, 18:40:27)

  8. Split of Create and Start (RobDolinMS, 18:40:36)
    1. (wking, 18:40:44)
    2. https://github.com/opencontainers/runc/pull/465 (wking, 18:40:46)
    3. https://github.com/wking/ccon#host (wking, 18:49:57)
    4. ACTION: crosbymichael to continue the discussion in https://github.com/opencontainers/runc/pull/465 (wking, 18:55:55)
    5. ACTION: julz to continue the discussion in https://github.com/opencontainers/runc/pull/465 (wking, 18:56:01)


Meeting ended at 18:56:07 UTC (full logs).

Action items

  1. mrunalp to setup these branches in opencontainers/ocitools
  2. wking to reroll #284 on the current master
  3. mrunalp to reroll with the consistent name
  4. Maintainers should review
  5. crosbymichael to continue the discussion in https://github.com/opencontainers/runc/pull/465
  6. julz to continue the discussion in https://github.com/opencontainers/runc/pull/465


Action items, by person

  1. mrunalp
    1. mrunalp to setup these branches in opencontainers/ocitools
    2. mrunalp to reroll with the consistent name
  2. wking
    1. wking to reroll #284 on the current master
  3. UNASSIGNED
    1. Maintainers should review
    2. crosbymichael to continue the discussion in https://github.com/opencontainers/runc/pull/465
    3. julz to continue the discussion in https://github.com/opencontainers/runc/pull/465


People present (lines said)

  1. wking (77)
  2. RobDolinMS (25)
  3. duglin (7)
  4. collabot` (5)
  5. vbatts (1)
  6. mrunalp (1)
  7. lk4d4 (1)
  8. vbatts|work (0)


Generated by MeetBot 0.1.4.