18:01:15 <vbatts> #startmeeting 2016-03-02 discussion
18:01:15 <collabot`> Meeting started Wed Mar  2 18:01:15 2016 UTC.  The chair is vbatts. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:15 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:15 <collabot`> The meeting name has been set to '2016_03_02_discussion'
18:01:40 <vbatts> #chairs RobDolinMS wking
18:01:45 <vbatts> #chair RobDolinMS wking
18:01:45 <collabot`> Current chairs: RobDolinMS vbatts wking
18:01:59 <anuthan> mrunal: you are not audible
18:02:11 <anuthan> mrunalp ^^
18:02:28 <vbatts> #topic To abstract exec, or not?
18:03:05 * vbatts looks for the link
18:03:53 <mrunalp> https://groups.google.com/a/opencontainers.org/forum/#!topic/dev/COlUEJsOIIc
18:04:29 <RobDolinMS> Three options:
18:04:31 <RobDolinMS> 1) Remove
18:04:35 <RobDolinMS> 2) Let runtime extend
18:05:09 <RobDolinMS> 3) process.json takes precedence over config.json
18:05:52 <vbatts> #link https://groups.google.com/a/opencontainers.org/forum/#!topic/dev/COlUEJsOIIc
18:06:38 <RobDolinMS> Mrunal: Main use case is making exec privileged so you can debug
18:09:11 <RobDolinMS> Mike Brown: could we have an option for the container to override the property?
18:11:44 <RobDolinMS> Mrunal: Go with the most commonly used options and runtimes can potentially go beyond
18:12:17 <RobDolinMS> Vishnu: Do we have a specific proposal?
18:12:44 <RobDolinMS> Crosby: As we're adding runc functionality to Docker, this came-up
18:13:22 <RobDolinMS> Vishnu: Would it be useful to have something tangible to discuss?
18:13:35 <RobDolinMS> Michael C: I could draft something
18:14:01 <RobDolinMS> #ACTION CrosbyMichael to prepare PR
18:14:16 <RobDolinMS> #topic Next Milestone
18:14:40 <vbatts> #link https://github.com/opencontainers/specs/pulls?q=is%3Aopen+is%3Apr+milestone%3Av0.4.0
18:14:54 <mrunalp> https://github.com/opencontainers/specs/pull/276
18:18:14 <RobDolinMS> Vincent: Will target for v0.4 (3/9)
18:19:49 <RobDolinMS> Mrunal: There is also tooling that needs to be updated.
18:20:15 <RobDolinMS> Crosby: It would be nice to get spec repo stable so runc and tools can catch-up
18:20:37 <RobDolinMS> Doug: What is the status of create and start?
18:20:42 <RobDolinMS> Vishnu: I'll get to it this week
18:23:53 <RobDolinMS> #topic Labels
18:24:14 <RobDolinMS> Crosby: What is the difference between annotations and labels?
18:24:34 <RobDolinMS> One use case is distinguishing user container, system container, etc.
18:25:17 <RobDolinMS> Vishnu: If defined, labels; if arbitrary metadata, annotations
18:25:28 <RobDolinMS> Vishnu: Maybe we need a seperate PR to add labels?
18:25:47 <RobDolinMS> Mrunal: I'm OK adding it, but concerned it doesn't get mis-used
18:26:28 <RobDolinMS> Vincent: People need some place to store arbitrary MetaData
18:28:27 <RobDolinMS> Vishnu: Runtimes could use labels for grouping
18:28:49 <RobDolinMS> Vishnu: may need to have some format around this instead of letting them be arbitrary strings
18:29:33 * RobDolinMS Vishh to propose PRs
18:29:41 <RobDolinMS> #ACTION: Vishh to propose PRs
18:31:42 <RobDolinMS> Brandon: Please include examples
18:33:08 <RobDolinMS> Mrunal: Looks like we're done for today
18:33:35 <mrunalp> RobDolinMS, Thanks for the notes, as always :)
18:34:54 <mrunalp> vbatts, endmeeting?
18:35:52 <vbatts> #endmeeting