17:04:30 <vbatts> #startmeeting 2016-04-20
17:04:30 <collabot> Meeting started Wed Apr 20 17:04:30 2016 UTC.  The chair is vbatts. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:30 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:04:30 <collabot> The meeting name has been set to '2016_04_20'
17:06:36 <duglin> FYI will try to look at the split PR comments later today - been traveling a bit so I’m way way behind
17:07:01 <vbatts> #topic issues / PRs
17:07:07 <vbatts> thanks duglin
17:07:19 <vbatts> #link https://github.com/opencontainers/image-spec/issues/23
17:10:35 <vbatts> #link https://groups.google.com/a/opencontainers.org/forum/#!topic/dev/VKpZNs-qYoI
17:14:19 <vbatts> #link https://github.com/opencontainers/image-spec/issues/22
17:18:08 <vbatts> #link https://github.com/opencontainers/image-spec/issues/35
17:18:08 <philips> philips talked about thinking of the on-disk format as something that you point some tool like oci-root-setup file:///path/to/manifest and then adjacent to that manifest you have a blobs directory with all of the cas object necessary for setup
17:18:36 <philips> vbatts said that we should start laying out those thoughts on issue 35
17:18:47 <philips> #help
17:19:47 <philips> #action philips needs to write down his thoughts on issue 35
17:20:52 <philips> philips we need to have the spec of after you transport everything required for an image to disk, what do you do next
17:22:29 <vbatts> #chairs philips
17:23:54 <philips> #action philips to email all of the maintainers of the image-spec to attend the weekly call
17:24:20 <philips> wking asks why don't we just standardize a single tarball that is gpg signed instead of worrying about a CAS
17:25:18 <philips> vbatts the most basic layer of it I want to have a tarball that people can download and pull down that folks can just run from my github
17:25:44 <philips> vbatts the second part of our discussion is what is the translation to a runtime layout
17:27:02 <philips> #action someone needs to build a flow diagram from image to runtime spec fs layout
17:29:04 <philips> #topic code of conduct
17:29:04 <vbatts> #link https://github.com/opencontainers/runtime-spec/pull/375
17:29:10 <vbatts> #link https://github.com/opencontainers/runtime-spec/pull/375
17:30:53 <philips> dolan my thinking is that if there are files that should be exactly the same across all repos we should put them in the tob
17:32:33 <philips> wking one other way to handle this is to have a template repo and pull from that into all N repos
17:32:36 <duglin> even with a template we still have the “edit issue” that Rob mentioned - I’d prefer pointers
17:34:03 <philips> philips LICENSE is special as it has to be audited by everyone
17:34:34 <philips> someone another concern is our signed-off-by language should be shared
17:38:04 <vbatts> #help action
17:38:13 <wking> it's #action stuff
17:38:24 <philips> #action vbatts document when to merge
17:38:41 <wking> #link https://github.com/opencontainers/runc/blob/master/MAINTAINERS_GUIDE.md#how-are-decisions-made
17:38:49 <philips> #action vbatts make bbq
17:38:49 <wking> ^ runC docs around landing PRs
17:39:04 <wking> #link https://github.com/opencontainers/runc/blob/master/MAINTAINERS_GUIDE.md#who-decides-what
17:43:08 <philips> #end
17:43:11 <philips> #endmeeting
17:43:20 <vbatts> ...
17:43:24 <vbatts> #endmeeting