#opencontainers: OCI weekly meeting 5/18

Meeting started by mrunalp at 17:01:23 UTC (full logs).

Meeting summary

  1. create/start split (wking, 17:02:40)
  2. https://github.com/opencontainers/ocitools/issues/66 (mrunalp, 17:06:07)
    1. We will expect some additional PRs re: Windows Containers early next week (RobDolinMS, 17:06:08)
    2. ACTION: Maintainers should take a look at the aforementioned PR and check if MUST/REQUIRED, SHOULD/RECOMMENDED, and MAY/OPTIONAL are accurate (RobDolinMS, 17:07:50)
    3. Mrunal suggests meeting next week and doing this (RobDolinMS, 17:08:48)
    4. https://github.com/opencontainers/runtime-spec/pull/436 (mrunalp, 17:09:28)

  3. remove solaris from full config (wking, 17:09:37)
  4. no mount nesting on Windows (wking, 17:10:21)
    1. https://github.com/opencontainers/runtime-spec/pull/433 (wking, 17:10:41)
    2. https://github.com/opencontainers/runtime-spec/pull/432 (mrunalp, 17:10:43)

  5. fstab-options are Linux-specific (wking, 17:11:08)
    1. https://github.com/opencontainers/runtime-spec/pull/432 (wking, 17:11:13)
    2. ACTION: RobDolinMS to update PR #432 (RobDolinMS, 17:13:24)
    3. https://github.com/opencontainers/runtime-spec/pull/427 (mrunalp, 17:13:25)

  6. optional hooks (wking, 17:13:31)
    1. https://github.com/opencontainers/runtime-spec/pull/427 (wking, 17:13:36)
    2. ACTION: wking will reroll #427 with that wording (wking, 17:19:21)
    3. https://github.com/opencontainers/runtime-spec/pull/423 (mrunalp, 17:19:32)

  7. dropping the "bundle" word (wking, 17:20:59)
    1. https://github.com/opencontainers/runtime-spec/pull/423 (wking, 17:21:05)
    2. https://github.com/opencontainers/runtime-spec/issues/389 (wking, 17:22:34)
    3. ACTION: everyone discuss the PR ;) (wking, 17:29:17)
    4. https://github.com/opencontainers/runtime-spec/pull/418 (mrunalp, 17:29:28)

  8. allow 'start' to not validate the config.json (wking, 17:29:42)
    1. https://github.com/opencontainers/runtime-spec/pull/418 (wking, 17:29:48)
    2. https://github.com/opencontainers/runtime-spec/pull/412 (mrunalp, 17:31:17)

  9. explicit container namespaces for uid (wking, 17:31:23)
    1. https://github.com/opencontainers/runtime-spec/pull/403 (mrunalp, 17:32:27)

  10. capitalize MUST (wking, 17:32:49)
    1. https://github.com/opencontainers/runtime-spec/pull/403 (wking, 17:32:54)
    2. https://github.com/opencontainers/runtime-spec/pull/397/files (mrunalp, 17:33:06)
    3. ACTION: RobDolinMS to reroll #403 to get wording updates (wking, 17:33:10)

  11. cgroup namespaces (wking, 17:33:22)
    1. https://github.com/opencontainers/runtime-spec/pull/397 (wking, 17:33:28)

  12. VM configuration updates (wking, 17:33:52)
    1. https://github.com/opencontainers/runtime-spec/pull/405 (wking, 17:33:59)
    2. ACTION: anush_ to namespace VM-specific settings in #405 (wking, 17:42:18)
    3. ACTION: maintainers to review, LGTM, and/or merge #405 after the reroll (wking, 17:42:40)

  13. repo organization (wking, 17:42:51)
    1. https://github.com/opencontainers/tob/issues/2 (wking, 17:46:00)
    2. https://github.com/opencontainers/tob/issues/11 (wking, 17:46:27)


Meeting ended at 17:48:27 UTC (full logs).

Action items

  1. Maintainers should take a look at the aforementioned PR and check if MUST/REQUIRED, SHOULD/RECOMMENDED, and MAY/OPTIONAL are accurate
  2. RobDolinMS to update PR #432
  3. wking will reroll #427 with that wording
  4. everyone discuss the PR ;)
  5. RobDolinMS to reroll #403 to get wording updates
  6. anush_ to namespace VM-specific settings in #405
  7. maintainers to review, LGTM, and/or merge #405 after the reroll


Action items, by person

  1. anush_
    1. anush_ to namespace VM-specific settings in #405
  2. RobDolinMS
    1. RobDolinMS to update PR #432
    2. RobDolinMS to reroll #403 to get wording updates
  3. wking
    1. wking will reroll #427 with that wording
  4. UNASSIGNED
    1. Maintainers should take a look at the aforementioned PR and check if MUST/REQUIRED, SHOULD/RECOMMENDED, and MAY/OPTIONAL are accurate
    2. everyone discuss the PR ;)
    3. maintainers to review, LGTM, and/or merge #405 after the reroll


People present (lines said)

  1. wking (101)
  2. mrunalp (11)
  3. RobDolinMS (4)
  4. collabot` (4)
  5. anush_ (2)
  6. JakeWarner|Work (1)
  7. julz_ (1)


Generated by MeetBot 0.1.4.