21:03:02 <wking> #startmeeting 2016-09-21 discussion
21:03:02 <collabot> Meeting started Wed Sep 21 21:03:02 2016 UTC.  The chair is wking. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:02 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:02 <collabot> The meeting name has been set to '2016_09_21_discussion'
21:03:15 <wking> #chair mrunalp vbatts_
21:03:15 <collabot> Current chairs: mrunalp vbatts_ wking
21:03:29 <mrunalp> https://github.com/opencontainers/runtime-spec/pull/567
21:03:39 <wking> #topic agressive namespacing
21:04:03 <wking> #link https://github.com/opencontainers/runtime-spec/pull/567
21:04:33 <wking> jhoward there were conflicts as I was adding Windows support, starting around resources
21:05:07 <wking> jhoward: if we take the hit now, the migration is painful now, but we're protecting ourselves from future collisions
21:05:26 <wking> jhoward: the alternative is to have platform files, which has been discussed before
21:05:43 <wking> jhoward: the spec isn't huge now, so I think per-platform files are overly complicated at the moment
21:06:10 <wking> mrunalp: The JSON will look nice because the JSON keys aren't namespaced
21:06:35 <wking> jhoward: the JSON keys aren't namespaced, but the JSON settings are (because a key is in the 'linux' object, etc.)
21:06:46 <wking> mrunalp: everyone please review #567 so we can land it
21:06:58 <wking> vbatts_: I don't have any particular objections
21:07:13 <mrunalp> https://github.com/opencontainers/image-tools/issues/25
21:07:36 <wking> #topic image-spec -> runtime-spec configuration translation
21:07:42 <wking> #link https://github.com/opencontainers/image-tools/issues/25
21:08:13 <wking> the discussion is around "should we be doing this at all" and "how do we handle particular fields if we do"
21:11:48 <wking> vbatts_: there's going to have to be some translation, because the runtime spec isn't portable
21:18:00 <wking> mrunalp: we had a split before, but we had too few fields that were truly portable
21:19:01 <cyphar> before that: [why don't we just embed the subset of portable fields rather that a translation matrix]
21:21:17 <wking> I'd love to see v{major}.{minor} in the media types
21:21:48 <wking> vbatts_: to wrap up this one issue.  The decoupling you're suggesting seems to make things a lot more complicated
21:22:08 <wking> vbatts_: but this is more about being a version mapping, even if there's versioning in the media types...
21:22:22 <wking> vbatts_: you can store exposed ports in an annototation
21:23:17 <wking> vbatts_: the GitHub issue (#25) does not convey this topic concisely
21:23:47 <wking> I can submit a PR to help ground my suggestions
21:24:08 <wking> vbatts_: another problem that folks are struggling with is the conversations get too deep and layered
21:24:38 <wking> A PR will help flatten some of the discussion for folks who aren't interested
21:25:36 <wking> #action wking will file runtime-spec and runtime-tools PRs around the localizer/sanitizer approach
21:25:47 <mrunalp> https://github.com/opencontainers/runtime-spec/pull/573
21:25:56 <wking> #link Windows support in runtime-spec
21:26:03 <wking> #topic Windows support in runtime-spec
21:26:06 <wking> #link https://github.com/opencontainers/runtime-spec/pull/573
21:26:20 <wking> jhoward: this needs more maintainer review
21:26:33 <wking> mrunalp: I gave it a quick look and it looks fine to me.  I'll give it another pass
21:26:41 <wking> mrunalp: other topics?
21:26:49 <wking> #topic console handling in runC
21:26:53 <cyphar> https://github.com/opencontainers/runc/pull/1018
21:26:57 <wking> cyphar: please review^
21:27:14 <wking> dqminh: I'll take a look
21:27:25 <wking> mrunalp: vbatts_, anything else for image-spec?
21:27:38 <wking> #topic image-spec 1.0.0-rc1
21:27:48 <wking> vbatts_: most of the issues are mine, but I'm happy to share
21:28:09 <wking> #link https://github.com/opencontainers/image-spec/milestone/8
21:28:51 <wking> vbatts_: I've been going through image-spec on paper this week, and it's good to see other folks making the changes I want to see without me having to say anything
21:29:33 <wking> vbatts_: the volume has gotten a bit overwhelming recently.  It would be good if things stayed more succinct
21:30:08 <wking> vbatts_: so help is welcome for anyone interested in running 'make docs' and reviewing the output HTML and PDF
21:30:17 <wking> #endmeeting