#opencontainers: 2018-12-18 distribution spec walkthrough

Meeting started by vbatts|work at 17:02:14 UTC (full logs).

Meeting summary

  1. intro and intention (vbatts|work, 17:02:43)
    1. https://github.com/opencontainers/distribution-spec/issues/24 (vbatts|work, 17:02:55)
    2. https://github.com/kinvolk/ocicert/ (vbatts|work, 17:03:25)
    3. https://github.com/docker/distribution/tree/master/registry/handlers (jzelinskie, 17:13:27)
    4. https://github.com/docker/distribution/blob/master/registry/handlers/api_test.go (jzelinskie, 17:13:30)
    5. https://github.com/docker/distribution/blob/master/registry/api/v2/descriptors.go (jzelinskie, 17:15:26)
    6. https://docs.docker.com/engine/security/trust/content_trust/ (sangy, 17:20:57)
    7. https://github.com/docker/docker-credential-helpers (vbatts|work, 17:35:40)
    8. https://medium.com/@calavera/stop-saving-credential-tokens-in-text-files-65e840a237bb (estesp, 17:36:27)
    9. https://github.com/calavera/docker-credential-helpers (vbatts|work, 17:36:39)
    10. https://medium.com/@calavera/stop-saving-credential-tokens-in-text-files-65e840a237bb (vbatts|work, 17:36:45)
    11. ACTION: look to cargo-cult from a basis of github.com/docker/distribution/blob/master/registry/api/v2/descriptors.go github.com/docker/distribution/blob/master/registry/handlers/api_test.go (vbatts|work, 17:42:05)
    12. ACTION: basic helper to use an opaque blob for authentication token to test 'rw-test' with (vbatts|work, 17:43:13)
    13. ACTION: merge the ocicert repo into the distribution-spec/ repo (vbatts|work, 17:44:58)


Meeting ended at 18:02:43 UTC (full logs).

Action items

  1. look to cargo-cult from a basis of github.com/docker/distribution/blob/master/registry/api/v2/descriptors.go github.com/docker/distribution/blob/master/registry/handlers/api_test.go
  2. basic helper to use an opaque blob for authentication token to test 'rw-test' with
  3. merge the ocicert repo into the distribution-spec/ repo


People present (lines said)

  1. vbatts|work (22)
  2. sangy (9)
  3. estesp (6)
  4. jzelinskie (5)
  5. mikebrow (3)
  6. collabot` (3)
  7. dongsu (3)


Generated by MeetBot 0.1.4.