16:01:52 <moizr> #startmeeting “clustering hackers"
16:01:52 <odl_meetbot> Meeting started Tue Nov  4 16:01:52 2014 UTC.  The chair is moizr. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:52 <odl_meetbot> The meeting name has been set to '_clustering_hackers_'
17:05:08 <moizr> #info talked briefly about Helium-2 bugs
17:05:24 <moizr> #info long discussion on reading data from a remote shard
17:05:43 <moizr> #info performance concerns with reading remote data
17:06:48 <moizr> #info rovarga proposes that when reading data we allow creation of transaction against a local shard replica if the local shard replica seems to be up-to-date
17:07:16 <moizr> #info moizr wants to understand if a change in api might be needed
17:08:05 <moizr> #info jmedved/colin talk about somehow co-locating apps and data to ensure high performance
17:08:53 <moizr> #info moizr concerned that colocating apps and data may result in us not being able to achieve scale
17:10:32 <moizr> #info keith brings up the point that maybe there we should be using a different sharding strategy for config/operational data
17:11:02 <moizr> #info rovarga thought this was available in clustered datastore
17:11:57 <moizr> #info moizr says this that sharding strategy is based on module and not datastore but we can change that for Lithium
17:12:58 <moizr> #info moizr proposes that we change or add an transaction creation API which restricts transactions to a single module (shard if possible)
17:14:03 <moizr> #info rovarga says that we could do that but then we could provide a different implementation of the databroker for the clustered data store.
17:15:10 <moizr> #info moizr wants to understand how applications could be written to work with both in-memory and clustered databroker if their APIs were different
17:15:27 <moizr> #info ttkacik wants discussion to move to mailing list
17:15:38 <moizr> #action moizr to initiate discussions
17:16:31 <moizr> #info A lot of other words were said which I haven’t been able to capture in this transcript :)
17:17:02 <moizr> #info Next week : 30 mins of the Agenda will be used in talking about the 2-Node cluster
17:19:02 <moizr> #endmeeting