16:06:28 <moizr> #startmeeting “clusteringhackers”
16:06:28 <odl_meetbot> Meeting started Tue Nov 18 16:06:28 2014 UTC.  The chair is moizr. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:06:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:28 <odl_meetbot> The meeting name has been set to '_clusteringhackers_'
16:06:36 <colindixon> #topic agenda bashing
16:06:45 <tbachman> :)
16:06:47 <moizr> #chair tbachman
16:06:47 <odl_meetbot> Current chairs: moizr tbachman
16:07:01 * tbachman needs to learn to type in the right IRC channel ;)
16:07:04 <colindixon> somebody other than me should #topic it, since I can’t
16:07:10 <tbachman> #topic agenda bashing
16:07:17 <tbachman> #info two node clustering update
16:07:28 <tbachman> #info testing (integration) status
16:07:33 <tbachman> #info other items
16:07:59 <tbachman> #info colindixon asks the status of migrating the existing core applications (e.g. openflowplugin)
16:08:10 <tbachman> #info moizr says there’s no explicit work going on in that area
16:08:29 <tbachman> #info moizr says probably not all the apps are designed to support clustering
16:08:47 <tbachman> #info jmedved says there is work going on in the openflowplugin to help make it clustering aware
16:09:39 <tbachman> #info moizr would like to see guidelines on how projects should change their apps to support clustering
16:10:04 <tbachman> #info colindixon says we have best practices: 1) store everything in the MD-SAL; 2) do app local caching where needed
16:10:57 <tbachman> #topic bugzilla review
16:11:15 <tbachman> #info moizr says we had about 29 last week, now down to 17, most related to performance enhancements
16:11:41 <tbachman> #info all the integration tests for 3-node cluster are now working
16:12:35 <tbachman> #info The link state topology issue was discovered with BGP, where serialization of binary data was a problem
16:14:09 <tbachman> #info The in-progress bugs were suspended while getting the SR1 bugs fixed
16:15:49 <tbachman> #info There only bug in the confirmed status that needs to be addressed is the one where the leader should abandon (Bug ID 2371)
16:17:12 <tbachman> #info pantelis asks about the serialized UID version in some of the RAFT messages to get rid of sonar warnings, and whether these will be backed out (breaks backwards compatibility)
16:18:07 <tbachman> #action pantelis will create a bug to keep track of the serialized UID version in the RAFT messages
16:18:21 <tbachman> #topic two node clustering update
16:18:28 <markmozolewski2> https://git.opendaylight.org/gerrit/#/c/12832/
16:18:44 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/12832/ gerrit review for current two-node work
16:19:16 <tbachman> #info markmozolewski2 says there are some additional changes that will be empty unit tests to cover the use cases that they plan to support
16:19:37 <tbachman> #info markmozolewski2 says they also rely on a network partition detection algorithm that’s separate from this code.
16:19:56 <tbachman> #info markmozolewski2 requests folks to have a look and provide comments on the gerrit
16:20:03 <tbachman> #topic testing (integration) status
16:20:34 <tbachman> #info moizr says we still haven’t had a stable build on the integration branch
16:20:59 <tbachman> #info moizr checked clustering, and says that all the tests on single-node openflow are now passing
16:22:56 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/12831 gerrit for refactoring clustering integration tests
16:23:15 <tbachman> #info moizr would like to see one other person try this out
16:23:39 <tbachman> #info etka says they are 80% of the way of getting the 3-node setup
16:23:55 <tbachman> #info catohornet says she can get to the clustering test by the end of the week
16:24:14 <tbachman> #info moizr says all the VMs need the same username and password for the 3-cluster test
16:26:42 <tbachman> #endmeeting