16:00:55 <tbachman> #startmeeting clustering_hackers
16:00:55 <odl_meetbot> Meeting started Tue Dec  2 16:00:55 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:55 <odl_meetbot> The meeting name has been set to 'clustering_hackers'
16:00:59 <tbachman> #chair moizr
16:00:59 <odl_meetbot> Current chairs: moizr tbachman
16:01:08 <tbachman> #topic agenda bashing and action items
16:01:14 <tbachman> #link https://meetings.opendaylight.org/opendaylight-clustering/2014/clustering_hackers/opendaylight-clustering-clustering_hackers.2014-11-25-16.02.html Minutes from last week’s meeting
16:02:33 <moizr> ty tbachman
16:02:39 <tbachman> moizr: np!
16:06:06 <tbachman> #info topic: bug-review
16:06:11 <tbachman> #info topic: two-node clustering
16:06:15 <tbachman> #info topic: open issues
16:06:22 <tbachman> #topic bug review
16:06:43 <tbachman> #info The unit tests that were failing in jenkins have been addressed
16:07:12 <tbachman> #info There was one issue brought up on the mailing list where the controller runs out of memory when connected to mininet. This bug should be fixed
16:08:13 <tbachman> #info moizr says the only bug out for review is a fix for a test, which as been merged to master but not yet stable/helium
16:08:39 <tbachman> #info There is a bug where ODL startup occasionally fails — this may be related to jolokia, so we may not be able to worry about it
16:08:50 <tbachman> #info The bug where there’s a log exception hasn’t been reproduced
16:09:18 <tbachman> #info moizr says there’s a bug where a remote RPC isn’t being invoked. This needs to be investigated (bug 2449)
16:09:37 <tbachman> #action harman to look at bug 2449
16:10:42 <tbachman> #info The stable/helium release date is soon (1/12?), so there’s not much time to address additional things
16:11:12 <tbachman> #info moizr is going to move all the performance improvements to lithium release (i.e. not stable/helium)
16:11:49 <tbachman> multiblaster :)
16:12:11 <tbachman> #info pantelis asks if these are integration, and are available to all
16:12:20 <tbachman> #info jmedved says that everything he runs has been committed
16:12:30 <tbachman> #topic two-node clustering
16:12:47 <tbachman> #info mark says a new 2-node strategy was committed last week
16:13:06 <tbachman> #info half of the commit is comments explaining rationale, and a test case file laying out all the situations that will likely need testing
16:13:48 <tbachman> #info mark is working on a wiki page for 2-node based on the code, and will hold a meeting this thursday for those interested in the two-node design; interested parties should contact mark directly
16:14:01 <tbachman> #topic open issues
16:14:30 <tbachman> #info jmedved says there’s still a memory leak somewhere. When he runs a lot of transactions, the oldgen still keeps growing and doesn’t get freed up
16:14:48 <tbachman> #action jmedved to collect more information on the memory leak issue
16:15:01 <tbachman> #info moizr says there was a similar issue discovered by mirantis on the mailing list4
16:15:28 <tbachman> #info moizr says it’s not just a memory leak, but there’s also just a lot of data in memory
16:15:44 <tbachman> #info jmedved says he sees the memory issues even after disconnecting mininet
16:16:41 <tbachman> #endmeeting