#opendaylight-clustering: clustering hackers

Meeting started by colindixon at 15:05:54 UTC (full logs).

Meeting summary

  1. keepalive actor (colindixon, 15:06:01)
    1. TomP says that he's been working on a separate KeepAlive timer to try to reduce spurious claims that nodes are down (colindixon, 15:06:27)
    2. I think the theory is that the actor will be scheduled better than the normal actors which might suffer from the other things going through them (colindixon, 15:07:18)
    3. TomP is trying to use a separate dispatcher for the keep alives, so that they shouldn't wind up behind anything else (colindixon, 15:07:56)
    4. this will help spurious timeouts because actors are busy (colindixon, 15:11:58)
    5. this won't help spurious timeouts because of garbage collection pauses (colindixon, 15:12:16)
    6. TomP says it would help a lot if Muthu could look at and test the patches (colindixon, 15:15:59)
    7. jan asks if TomP is coordinating with Robert on the changes here (colindixon, 15:26:14)
    8. TomP says that the stuff he's doing is orthogonal from what Robert is doing (colindixon, 15:27:31)

  2. changing global RPC behavior (colindixon, 15:29:17)
    1. Jan says that his view is that global RPC deliver is wrong, it should be delivered remotely if there's a registered handler (colindixon, 15:29:42)
    2. Jan says that his view is that global RPC delivery is wrong, it should be delivered remotely if there's a registered handler (colindixon, 15:30:43)
    3. right now it is delivered locally to the given node only (colindixon, 15:31:15)
    4. colindixon says there's a bigger problem where we have 5 different kinds of "events" (routed RPCs, global RPCs, Data Change Notifiactions, YANG Notifications, Clustered Data Change notifications) and they each have different delivery disciplines (colindixon, 15:32:20)
    5. colindixon says we really need to have deliver disciplines and events and be able to pick-and-choose the delivery discipline for each event as you like (colindixon, 15:33:00)
    6. Jan wants to make sure that we at least fix the things we hit as we do instead of blocking progress on making everything perfect (colindixon, 15:34:53)
    7. ACTION: Jan to open a bug against global RPCs (colindixon, 15:35:02)
    8. ACTION: colindixon to open a topic for the DDF (colindixon, 15:35:17)
    9. colindixon and jan agree that singleton apps in the cluster are likely to be the most-common because they're simple and you only need more performance (colindixon, 15:39:03)
    10. colindixon points out that in addition to normal event delivery discipline issues with where they're delivered, there is also the reliability, e.g., at most once vs. at least once vs. exactly once vs. zero or more times (colindixon, 15:40:06)

  3. refactoring clustering (colindixon, 15:41:32)
    1. Robert says that he has a refactor patch that he needs to be able to fix bug 5280 (colindixon, 15:41:54)
    2. it will be there sometime tomorrow for TomP to review, it's about 1000 lines so far, but doesn't compile yet (colindixon, 15:42:13)
    3. TomP says he also has a lot of patches out there, which he'd love to have Robert review as well (colindixon, 15:44:33)

  4. serialization optimization (colindixon, 15:49:46)
    1. TomP says that he has better ways to do serialization as patches (colindixon, 15:50:04)
    2. robert will review the patches (colindixon, 15:54:57)
    3. muthu notes that (on another topic) that when you configure Akka with fsync() off it improves performance a lot (about 2x) (colindixon, 15:55:43)
    4. robert points out that disabling fsync() is giving up on some data durability, balancing that is hard (colindixon, 16:02:33)


Meeting ended at 16:03:35 UTC (full logs).

Action items

  1. Jan to open a bug against global RPCs
  2. colindixon to open a topic for the DDF


Action items, by person

  1. colindixon
    1. colindixon to open a topic for the DDF


People present (lines said)

  1. colindixon (31)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.