15:21:18 <Guest51984> #startmeeting CoeWeekly-08/08/2018
15:21:18 <odl_meetbot> Meeting started Wed Aug  8 15:21:18 2018 UTC.  The chair is Guest51984. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:21:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:21:18 <odl_meetbot> The meeting name has been set to 'coeweekly_08_08_2018'
15:21:23 <Guest51984> #chair fkautz
15:21:23 <odl_meetbot> Current chairs: Guest51984 fkautz
15:21:41 <faseelak> #chair faseelak
15:21:48 <faseelak> #endmeeting
15:22:19 <faseelak> fkautz, can u make me chair? :P i didnot realize that i was not properly logged in
15:24:06 <fkautz> #chair faseelak
15:24:06 <odl_meetbot> Current chairs: Guest51984 faseelak fkautz
15:24:11 <faseelak> fkautz, thanks!
15:24:18 <faseelak> #topic ONS COE demo
15:24:48 <faseelak> #info fkautz and faseelak are working on getting the kubernetes servcices work with kube-proxy model
15:24:59 <faseelak> #info aadam shares the coe kanban board
15:25:23 <faseelak> #link https://jira.opendaylight.org/secure/RapidBoard.jspa?rapidView=64&view=detail&selectedIssue=COE-1
15:26:21 <faseelak> #info mohamed asks about the expectations for the ONS demo
15:26:44 <faseelak> #info fkautz explains we will keep a simple demo for ONS, and then expand it for Kubecon Seattle
15:27:29 <faseelak> #info an edge usecase is proposed, where multiple k8s clusters will be there, with openstack kuryr in the core, and the edge will run baremetal k8s clusters operated by ODL COE
15:27:37 <faseelak> #chair aadam
15:27:37 <odl_meetbot> Current chairs: Guest51984 aadam faseelak fkautz
15:32:12 <faseelak> #link https://docs.google.com/presentation/d/1R7qR8qiQ6uUgRPhE5bMZkagIFd2cE0OS8tfM8EYpPYk/edit?usp=sharing
15:32:41 <faseelak> #info when we are cross-connecting DCs, we can have either an l2 or l3 vpn
15:33:08 <faseelak> #info we prefer l3 for the demo, as l3 is less problematic
15:51:29 <faseelak> #action fkautz to add a diagram to the presentation to describe the components of the demo
15:51:45 <faseelak> #action faseelak to send the POC subtasks to aadam
15:51:59 <faseelak> #action mohamed to send the tasks for odlKubeProxy to aadam
15:52:15 <faseelak> #action faseelak to check the deadline for kubecon demo
15:53:22 <faseelak> #action aadam to talk to kubernetes folks in redhat to see how the kubecon demo can be submitted
15:53:49 <faseelak> #topic Patches for KubeProxy service implementation
15:53:59 <faseelak> #info mohamed asks why default namespace is hardcoded
15:54:21 <faseelak> #info fkautz explains there are a number of kubernetes systems that are spun up in a separate namespace
15:54:36 <faseelak> #info this makes it difficult for the communication for the current model
15:54:53 <faseelak> #info hence fkautz decided to flatten the namespaces to get the iptables mode working
15:55:51 <faseelak> #info mohamed asks why can't we use kubesystem namespace in all the pod yamls
15:56:09 <faseelak> #info so that things work till the ONS demo, and then we can fix it properly later
15:56:30 <faseelak> #info fkautz says he is a little bit concerened of reusing kubesystem namespace
15:57:05 <faseelak> #info hardcoding of default namespace looks a bit dangerous
16:06:59 <faseelak> #endmeeting