20:44:52 <devinavery> #startmeeting Break apart the controller part 2
20:44:52 <odl_meetbot> Meeting started Tue Sep 30 20:44:52 2014 UTC.  The chair is devinavery. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:44:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:44:52 <odl_meetbot> The meeting name has been set to 'break_apart_the_controller_part_2'
20:45:11 <devinavery> #info Attendance is light.... but we will go on with some proposals
20:45:42 <devinavery> #info Use the karaf features as a dividing point - break out each feature to its own project
20:46:38 <devinavery> ##info break the flow model out and put into open flow plugin
20:46:48 <devinavery> #info break the flow model out and put into open flow plugin
20:47:34 <devinavery> #info move stats manage, LLDP, etc to open flow plugin -- LLDP perhaps as a different bundle /feature but not part of open flow
20:49:35 <devinavery> #info move the topology discovery and LLDP out to possible new project
20:55:11 <devinavery> #info We need to identify who owns what and who is going to maintain this stuff going forward?
20:57:48 <devinavery> #info Suggestion - use git commit history as a first line to see who might be a good committer
20:59:53 <rovarga> #info just an example of a component map: https://wiki.opendaylight.org/view/BGP_LS_PCEP:Component_Map
21:27:48 <devinavery> #info Starting with:  Step 1
21:27:49 <devinavery> #move the MD-SAL openflow components (models etc) out
21:27:49 <devinavery> #Remove the sample code that is dead
21:27:49 <devinavery> #remove the "old" osgi distribution ( and dependencies in other projects)
21:28:03 <devinavery> #info move the MD-SAL openflow components (models etc) out
21:28:11 <devinavery> #info Remove the sample code that is dead
21:28:17 <devinavery> #info remove the "old" osgi distribution ( and dependencies in other projects)
21:28:39 <devinavery> #action Step 1: move the MD-SAL openflow components (models etc) out to open flow
21:28:51 <devinavery> #action Step 2: Remove the sample code that is dead
21:29:05 <devinavery> #action Step 3: remove the "old" osgi distribution ( and dependencies in other projects)
21:29:47 <devinavery> #action start discussions on: A) remove the third party SSH, B)Start discussions on moving AD-SAL openflow to the AD-SAL plugin?, C) Start discussion on if we want to move samples to other projects?, D) Start discussion on Remove the openflowj 1.0 plugin from controller in TWS call
21:29:50 <devinavery> #end meeting
21:29:54 <devinavery> #endmeeting