17:59:12 <dbainbri> #startmeeting weekly discovery status
17:59:12 <odl_meetbot> Meeting started Tue Feb  3 17:59:12 2015 UTC.  The chair is dbainbri. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:59:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:12 <odl_meetbot> The meeting name has been set to 'weekly_discovery_status'
17:59:23 <dbainbri> #info dbainbri
18:02:15 <nateharmon> #info nateharmon
18:07:29 <dbainbri> #action make sure audio conference number is changed
18:07:58 <dbainbri> #topic transition to a single project
18:09:31 <dbainbri> #info M2 milestone due thursday
18:10:33 <dbainbri> #info wiki set up
18:10:42 <dbainbri> #info will use this time slot for weekly meeint
18:10:50 <dbainbri> #action dbainbri update weekly meeting invite
18:11:03 <dbainbri> #info have bugzilla account
18:12:02 <dbainbri> #acton steve publish M2 milestone
18:13:38 <dbainbri> #agreed use trello for stories, enhancements, tasks. bugzilla for defects
18:14:28 <dbainbri> #agreed use ODL email list and IRC channel for communication
18:16:22 <dbainbri> #info Nathan used Ed Warnicke's MD-SAL archetype to check in initial structure of code
18:21:45 <dbainbri> #info Nate will look to push his changes in the archetype back to Ed
18:22:37 <dbainbri> #info Nate has been working on the identification module and node augmentation
18:24:07 <dbainbri> #info need to start thinking about requirements for integration tests
18:26:38 <dbainbri> #info will be using latest snapshot version in the master branch
18:27:39 <dbainbri> #action dbainbri invite all committers to the the trello board
18:30:21 <dbainbri> #info need to work through use cases where OF flow modes and how drivers are invoked
18:32:25 <dbainbri> (please #info your attendance if you haven't already)
18:33:18 <dbainbri> #action dbainbri to take a look at the didm directory structure and get feedback back to uchau to more intent project to that same structure
18:33:27 <uchau> #info uchau
18:41:47 <dbainbri> #agreed identification flow, new node added trapped by single identity module, if flow capable node that magic happens, if not, SNMP identification attempted, if identified type set and magic happens, if fails, type set to UNKNOWN and other plugins can trigger off that and if they can identify they set the type and magic happens, else it stays as UNKNOWN.
18:42:55 <dbainbri> #agreed that augmentation for device type is inventory under operational tree.
18:43:10 <dbainbri> #info may want to also populate type to config for persistence as well
18:45:17 <dbainbri> #idea is augmentation in the same shared as inventory or do augmentations use a different sharding strategy
18:46:01 <dbainbri> #action uchau checking with clustering team on sharding of augmentations
18:46:21 <dbainbri> #endmeeting