#opendaylight-docs: docs

Meeting started by colindixon at 16:13:06 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:13:12)
    1. future webex/meeting venues (colindixon, 16:13:23)
    2. https://git.opendaylight.org/gerrit/#/q/status:open+project:docs incoming patches for us to review (colindixon, 16:13:38)
    3. https://cisco.webex.com/ciscosales/j.php?MTID=mc3e15ff840fe00b786ee56675541955b (colindixon, 16:15:46)
    4. the state of the documentation info for projects (colindixon, 16:16:33)

  2. future meetings for WebEX (colindixon, 16:17:33)
    1. ACTION: colindixon to reach out to phrobb and get the LF webex to use for this meeting and update the invite and meeting info (colindixon, 16:17:58)

  3. state of docs info and walkthorughs for projects (colindixon, 16:18:18)
    1. https://wiki.opendaylight.org/view/CrossProject:Documentation_Group:Lithium_Project_Documentation_Requirements#Step-by-step_Guide this is the steb-by-step process for submitting docs (and specificially outlines) that we sent out (colindixon, 16:20:06)
    2. if anyone wants to review these steps or the templates, please do (colindixon, 16:21:01)
    3. you can find the templates if you clone the docs repo and look in the manuals/readme/src/main/asciidoc folder (also listed in the step-by-step) (colindixon, 16:21:49)
    4. manny asks if we’re copying the helium docs over (colindixon, 16:23:12)
    5. colindixon says not in a file-by-file but we will likely encourage projects to copy content over (colindixon, 16:23:29)

  4. incoming docs to review (colindixon, 16:24:13)
    1. https://git.opendaylight.org/gerrit/#/q/status:open+project:docs we already have 4 incoming patches to review (colindixon, 16:24:30)
    2. we should expect ~20 total in the next 36 hours (colindixon, 16:25:03)
    3. Moi asks when when we need to finish reviewing docs (colindixon, 16:26:03)
    4. colindixon says there’s no real deadline, next week would be a good target to get them reviewed and as many as possible merged (colindixon, 16:26:38)
    5. manny asks what we should be looking for as we review things, colindixon says that we should be looking for basic grammar and formatting issues as well as if the overall structure makes sense (which it should because they’re copying templates) (colindixon, 16:30:22)
    6. dneary asks about gerrit workflow if there’s any point to add comments to something that already has a -1, colindixon says yes (colindixon, 16:32:54)
    7. dneary aks gerrit workflow and if there’s a way to see the diffs between patch sets, colindixon says there is, you click on the patch set numbers at the top of the files in the diff view (colindixon, 16:35:03)
    8. ACTION: colindixon to add to the process that when you push a new patch addressing feedback to add a +0 comment saying what you’ve addressed (colindixon, 16:42:57)

  5. Helium-SR2 docs (colindixon, 16:43:39)
    1. Helium-SR2 was release a while ago, there were some changes to VTN docs in the user guide and developer guide (colindixon, 16:44:07)
    2. we didn’t post them to the downloads page (colindixon, 16:44:16)
    3. ACTION: colindixon to make sure we get those posted (colindixon, 16:44:27)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Helium-SR2_Combined_Release_Notes Helium-SR2 combined release notes (colindixon, 16:45:06)
    5. https://git.opendaylight.org/gerrit/gitweb?p=docs.git;a=blob;f=manuals/install-guide/src/main/asciidoc/core-release-notes.adoc;h=0769a391f7dd69baa7001719eee20feeaaddf250;hb=refs/heads/stable/helium here’s an example of what I did for Helium-SR1 (colindixon, 16:47:17)
    6. if anyone has time to do that, it would be great (colindixon, 16:47:27)

  6. docs action items (colindixon, 16:48:13)
    1. https://docs.google.com/spreadsheets/d/1yAsfKJitnKM82D8s-2aHtoUaFQszD23zFqKWA9fuKro/edit?pli=1#gid=0 spreadsheet for tracking action items (colindixon, 16:48:34)
    2. ACTION: colindixon to link the action items spreadsheet into the docs group main page (colindixon, 16:48:52)
    3. everyone reviews and updates the action items (colindixon, 16:58:46)
    4. ACTION: dneary to move the openstack guide to asciidoc if that makes sense (colindixon, 17:03:36)
    5. ACTION: dneary to start a thread on the documentation mailing list about why/if we should be using AsciiDoc in git and tools that might make it easier (colindixon, 17:04:06)
    6. colindixon notes that the two reasons he’s aware of to use it are: (colindixon, 17:05:03)
    7. (1) to get useable versions of documentation for specific releases that can also be updated, e.g., to have a stable/helium branch (colindixon, 17:05:04)
    8. (2) so that we can produce PDFs for docs that really should be downloads with the software, e.g., the quckstart/install guide (colindixon, 17:05:41)


Meeting ended at 17:05:44 UTC (full logs).

Action items

  1. colindixon to reach out to phrobb and get the LF webex to use for this meeting and update the invite and meeting info
  2. colindixon to add to the process that when you push a new patch addressing feedback to add a +0 comment saying what you’ve addressed
  3. colindixon to make sure we get those posted
  4. colindixon to link the action items spreadsheet into the docs group main page
  5. dneary to move the openstack guide to asciidoc if that makes sense
  6. dneary to start a thread on the documentation mailing list about why/if we should be using AsciiDoc in git and tools that might make it easier


Action items, by person

  1. colindixon
    1. colindixon to reach out to phrobb and get the LF webex to use for this meeting and update the invite and meeting info
    2. colindixon to add to the process that when you push a new patch addressing feedback to add a +0 comment saying what you’ve addressed
    3. colindixon to make sure we get those posted
    4. colindixon to link the action items spreadsheet into the docs group main page
  2. dneary
    1. dneary to move the openstack guide to asciidoc if that makes sense
    2. dneary to start a thread on the documentation mailing list about why/if we should be using AsciiDoc in git and tools that might make it easier


People present (lines said)

  1. colindixon (43)
  2. dneary (7)
  3. odl_meetbot (3)
  4. Moi (2)


Generated by MeetBot 0.1.4.