19:01:38 <colindixon> #startmeeting docs
19:01:38 <odl_meetbot> Meeting started Tue Mar 29 19:01:38 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:01:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:38 <odl_meetbot> The meeting name has been set to 'docs'
19:01:42 <colindixon> #topic agenda
19:01:53 <colindixon> #info zxiiro to talk about using read the docs
19:03:18 <colindixon> #action colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list #action https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
19:03:24 <colindixon> #undo
19:03:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2560c10>
19:03:30 <colindixon> #action colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
19:03:34 <colindixon> #action https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
19:04:19 <colindixon> #action colindixon and zxiiro to follow up with trying to get auto-generated RESTCONF API documentation for Boron
19:05:39 <colindixon> #topic zxiiro's progess on readthedocs
19:06:39 <colindixon> #info zxiiro ported the getting started guide from the downloads page to readthedocs using both markdown and restructuredtext
19:07:25 <colindixon> #info zxiiro points out restructuredtext supports things like NOTE blocks and Import blocks
19:07:50 <colindixon> #info zxiiro says that for the most part markdown and restructuredtext use the same syntax, but restructuredtext is more powerful
19:09:13 <colindixon> #info colindixon asks if there's a way to get one big HTML document? zxiiro says no, but you can get epub and PDF to download for free
19:10:04 <colindixon> #Info colindixon asks how things are broken up into pages, zxiiro says later he'll show code, but roughly new file => new new html page
19:10:14 <colindixon> #info zxiiro also shows what it looks like with markdown
19:10:31 <colindixon> #info image syntax in markdown is different and zxiiro couldn't figure it out
19:11:16 <colindixon> #info zxiiro shows toctree in restructured text with table of contents and then a list of files
19:15:30 <colindixon> #info beau asks about the nature of this discussion, colindixon says we're looking at moving away from AsciiDoc toward readthedocs/sphinx
19:16:52 <colindixon> #info beau asks about why word docs wouldn't work, colindixon says that getting things working with word in git is painful, and we really want to version our docs with the code
19:19:43 <colindixon> #info colindixon asks how things are split up into html pages with restructured text and things
19:20:11 <colindixon> #info zxiiro says it's sphinx that does that, not restructuredtext
19:22:11 <colindixon> #info zxiiro says that it seems like there are more and more easy tools for breaking up HTML pages at the granularity you'd like
19:23:02 <colindixon> #link http://docutils.sourceforge.net/rst.html restructured text syntax description
19:24:37 <colindixon> #inof zxiiro says that there's additional sphinx commands beyond that
19:25:13 <zxiiro> #link http://www.sphinx-doc.org/en/stable/rest.html sphinx-restructuredtext
19:29:22 <colindixon> #info zxiiro's link above to sphinx is much better for restructuredtext than the actual rst.html in the docutils project above
19:29:40 <colindixon> #topic getting started guide
19:30:04 <colindixon> #info gbeauw points out that his take is that the getting started guide is really just an installation guide
19:31:07 <colindixon> #info gbeauw points out that really, you probably need to have what's next after installing beyond feature:install <feature-name>
19:31:30 <colindixon> #Info gbeauw thinks what you need next is really how do you connect to devices, verify it works, etc.
19:36:15 <colindixon> #info CaseyODL says that we're working on trying to do example scenarios with Vagrantfiles to back it and stuff to download and play around
19:36:50 <colindixon> #info gbeauw says that it's beyond what he actually wants, first he doesn't really feel like he needs Vagrantfiles and they're likely going to not be appopriately tuned to his environment
19:37:41 <colindixon> #info colindixon notes that he is pretty sure that the kinds of things gbeauw may find the content in the per-project user guide, it might the wrong place for it and it might be a bit out of date, but it's probably there
19:46:59 <colindixon> #info gbeauw notes that what's there wasn't possible to make things work with thoe documentation that was there, mounting a netconf devices was nowhere in our docs
19:47:20 <colindixon> #Info colindixon confirms that our documentation does seem to be utterly missing how to mount a netconf device, which is a huge oversight he'll look into
19:47:46 <colindixon> #Info gbeauw notes he's not just trying to bitch, but also offering to help, which is hugely appreciated
19:48:13 <colindixon> #info colindixon agrees that figuring out what comes after feature:install, is what needs to get into the getting started guide next, including OpenFlow and netconf seem like great starts
19:49:47 <colindixon> #action colindixon to work with gbeauw to get a list of what he thinks should go at the end of the getting started guide
19:49:55 <colindixon> #chair zxiiro CaseyODL
19:49:55 <odl_meetbot> Current chairs: CaseyODL colindixon zxiiro
19:50:04 <colindixon> zxiiro, CaseyODL one of you can do the #endmeeting
19:53:58 <zxiiro> #endmeeting