19:00:22 <colindixon> #startmeeting docs
19:00:22 <odl_meetbot> Meeting started Tue Apr  5 19:00:22 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:00:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:22 <odl_meetbot> The meeting name has been set to 'docs'
19:00:28 <colindixon> #topic agenda bashing
19:01:19 <colindixon> #info a few demos w.r.t. to read the docs from zxiiro
19:03:48 <colindixon> #action colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
19:03:48 <colindixon> #action https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
19:03:49 <colindixon> #action colindixon and zxiiro to follow up with trying to get auto-generated RESTCONF API documentation for Boron
19:03:50 <colindixon> #action colindixon to work with gbeauw to get a list of what he thinks should go at the end of the getting started guide
19:05:41 <colindixon> #topic read the docs demo
19:06:48 <colindixon> #info zxiiro shows the readthedocs admin page
19:07:18 <colindixon> #info you can see the versions that are available (they're git tags and branches)
19:07:36 <colindixon> #info you can also force builds, but it should automatically be built whenever there are changes
19:07:56 <colindixon> #info you can set versions to be active or inactive
19:09:46 <colindixon> #Info by default, old versions get big red flags at the top by default
19:10:25 <colindixon> #Info at the bottom-rigth, you can get links to to other version, PDF, HTML, Epub, link to github (which presumably be to our gerrit, but we're not sure)
19:11:01 <colindixon> https://docs.djangoproject.com/en/1.9/intro/install/
19:12:34 <colindixon> #info colindixon shows that there must be a way to get older (but suppoted version) to not throw up big red warnings and to get the development version to show a yellow warning
19:13:05 <colindixon> #info colindixon says he takes zxiiro at his word that we can make it work with jenkins
19:14:42 <colindixon> #info zxiiro notes that readthedocs has no notion of diferent docs, so we would either need to have mutiple readthedocs URLs or we'd need to have one big doc with first level headings being what our current manuals are
19:15:25 <colindixon> #info zxiiro corrects colindixon to say that we have one doc per git repository, so we'd need to have more than one docs repo if we wanted that
19:17:07 <colindixon> #action zxiiro to createa a readthedocs topic branch in docs and set things up so that we can push to readthedocs from our actual docs repo
19:21:57 <colindixon> http://events.linuxfoundation.org/events/open-networking-summit/program/slides
19:29:42 <colindixon> #endmeeting