19:03:27 <colindixon> #startmeeting docs
19:03:27 <odl_meetbot> Meeting started Tue Jul 19 19:03:27 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:03:27 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:27 <odl_meetbot> The meeting name has been set to 'docs'
19:03:34 <colindixon> #topic agenda bashing
19:03:48 <colindixon> #link https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-07-12-19.04.html last week's meeting minutes
19:03:54 <colindixon> #action colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches
19:04:56 <colindixon> #action xinghao__ to extend the pandoc conversion script to split things on section/chapter/whatever so we get one file per project (or some approximation of that)
19:05:48 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/41786/ script xinghao__ wrote to do conversion of a full guide to a single reST file
19:06:01 <colindixon> #action colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
19:06:21 <zxiiro> xinghao__: don't be afraid to push incomplete code. it allows us to iterate more quickly. Think of Gerrit as a save button for your work.
19:06:45 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=6197 colindixon posted a bug about the top bar being too big on narrow windows
19:06:49 <xinghao__> I see. Will do that asap
19:07:39 <colindixon> #action colindixon and/or zxiiro to fix the favicon
19:07:48 <colindixon> #action phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
19:08:01 <colindixon> #action colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:09:47 <colindixon> #link https://wiki.opendaylight.org/view/Documentation/Tools/reStructuredText is the wiki page comparing and contrasting reST and AsciiDoc
19:10:22 <zxiiro> I have nothing for this week
19:10:56 <colindixon> #topic migrating the user guide and developer guide to reST in boron
19:11:30 <colindixon> #info colindixon thinks this is blocking on xinghao__'s script to automatically migrate the two guides with reasonable splits into reST files
19:12:39 <colindixon> #info xinghao__ says he thinks he can have this done by the end of this week
19:12:44 <colindixon> #topic docs reviewing backlog
19:13:10 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 documentation patch backlog
19:19:37 <colindixon> #topic when to migrate from AsciiDoc to reST again
19:20:43 <colindixon> #info davidmichaelkarr notes that doing the conversion after the documentation production during a lull makes the most sense, maybe the beginning of the next release
19:20:56 <colindixon> #info anipbu says maybe in between release reviews and the release (which would get it for us in boron)
19:21:03 <colindixon> #info colindixon sasy that makes a lot of sense
19:21:25 <colindixon> #info anipbu asks if we should get permission before then so we can just do it
19:21:51 <colindixon> #info colindixon says he thinks that's a really good idea, but he wants to make sure that we can actually do automatic migration before we go looking for permission
19:22:01 <colindixon> #info hopefully that will be late this week or early next week
19:22:03 <colindixon> #endmeeting