#opendaylight-docs: docs

Meeting started by colindixon at 18:01:18 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 18:01:23)
    1. per-project patch status (colindixon, 19:00:58)
    2. xinghao's asciidoc => docbook => reST => split reST converter (colindixon, 19:01:26)
    3. plans for migration in boron (colindixon, 19:02:01)
    4. ACTION: colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work) (colindixon, 19:02:21)
    5. ACTION: colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version (colindixon, 19:02:29)
    6. ACTION: colindixon and/or zxiiro to fix the favicon (colindixon, 19:02:34)
    7. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:02:40)
    8. ACTION: phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon, 19:02:49)
    9. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 anipbu went through the documentation tracker and marked patches with "no change" if the project said there was no change (colindixon, 19:03:37)
    10. ACTION: colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update (colindixon, 19:03:50)
    11. ACTION: colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many) (colindixon, 19:04:15)
    12. ACTION: colindixon to abandon the seemingly abandoned patches and send e-mails to the relevant projects (colindixon, 19:08:56)
    13. ACTION: colindixon and xinghao to make sure content above chapters works (colindixon, 19:09:10)

  2. per-project patch status (colindixon, 19:10:03)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 (colindixon, 19:10:22)
    2. 2 patches waiting for review (colindixon, 19:10:30)
    3. 23 patchces waiting for input/approval from the project (colindixon, 19:10:46)
    4. 18 projects which have no new documentation in Boron and haven't said that's intentional (colindixon, 19:11:03)

  3. xinghao's patch to do automatic migration (colindixon, 19:11:58)
    1. https://git.opendaylight.org/gerrit/#/c/42104/ (colindixon, 19:12:39)
    2. xinghao says that cross-project links don't always work in HTML, some sanity checking will be required (colindixon, 19:12:56)
    3. that means we'd likely want projects to at least read through their documentation post-conversions once (colindixon, 19:13:16)

  4. our plan for migration (colindixon, 19:15:01)
    1. additional topcis: (i) TWS on Monday, (ii) enabling edit on github (colindixon, 19:15:38)
    2. options: (1) migrate the dev and user guides in Carbon, (2) migrate everyging with an option to opt-out, (3) migrate everything with project's having to opt-in (colindixon, 19:16:26)
    3. consequencnes: (a) we have migrate open patches to reST for people, (b) we might have two different places docs lifeā€”at least we could link from the reST to the PDF in the relvant places (maybe backwards as well) (colindixon, 19:17:22)
    4. also, when? (colindixon, 19:17:28)
    5. anipbu notes that if wait for carbon, that forces us to keep AsciiDoc alive for longer and that means you can't easily cherry-pick from carbon to boron (colindixon, 19:19:28)
    6. anipbu also notes that patches after the branch cutting really need 3 possible branch targets: stable/beryllium, stable/boron, and master (carbon) (colindixon, 19:20:05)
    7. colindixon says his intution is to make it opt-out, and do the full migration as soon as we can manage after the TWS and get the open patches down as much as possible (colindixon, 19:21:15)
    8. it sounds like we have conensus on that and we'll try for it based on community feedback, we might have to wait for TSC approval on next Thursday (colindixon, 19:22:19)

  5. TWS on monday (colindixon, 19:22:26)
    1. colindixon was planning to show off what we currently have, show it building, show the reST wiki page, show xinghao_'s script, and then present the above migration plan (colindixon, 19:23:04)
    2. it would be cool to show javadoc generation in sphinx as well (colindixon, 19:23:33)
    3. note that projects can use whatever format they want for docs in theier repo (colindixon, 19:25:38)

  6. enabing edit on github or something similar (colindixon, 19:25:52)
    1. making the edit on github link work from our docs seems hard, but would be awesome (colindixon, 19:30:58)
    2. in particular submodules, kind of make things hard, since we'd need to resolve to multiple git repositories (colindixon, 19:31:29)
    3. https://gerrit.googlesource.com/plugins/github/+/master/README.md the github gerrit plugin might give us a way to translate pull requests to gerrit patches automatically, which makes it possible, if annoying (colindixon, 19:32:13)


Meeting ended at 19:34:20 UTC (full logs).

Action items

  1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
  2. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
  3. colindixon and/or zxiiro to fix the favicon
  4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  5. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
  6. colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
  7. colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many)
  8. colindixon to abandon the seemingly abandoned patches and send e-mails to the relevant projects
  9. colindixon and xinghao to make sure content above chapters works


Action items, by person

  1. anipbu
    1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
  2. colindixon
    1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
    2. colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
    3. colindixon and/or zxiiro to fix the favicon
    4. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
    5. colindixon to e-mail projects with no docs and no e-mail saying there won't be any after anipbu does his update
    6. colindixon and xinghao to check for cross-project links in the guides, to make sure they still work (colindixon is pretty sure they won't, but there aren't very many)
    7. colindixon to abandon the seemingly abandoned patches and send e-mails to the relevant projects
    8. colindixon and xinghao to make sure content above chapters works
  3. zxiiro
    1. colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
    2. colindixon and/or zxiiro to fix the favicon
    3. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money


People present (lines said)

  1. colindixon (46)
  2. odl_meetbot (3)
  3. zxiiro (1)
  4. anipbu (1)


Generated by MeetBot 0.1.4.