19:01:42 <colindixon> #startmeeting docs
19:01:42 <odl_meetbot> Meeting started Tue Aug  9 19:01:42 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:01:42 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:42 <odl_meetbot> The meeting name has been set to 'docs'
19:01:46 <colindixon> #topic agenda bashing
19:08:15 <colindixon> #topic the rest of xinghao_'s internship
19:08:23 <colindixon> #info here are some ideas
19:08:51 <colindixon> #info 1.) seeing if we could improve the theme so that there is an outline of the curren section on the left (or right)
19:10:37 <colindixon> #info this might not be very important, since you can get it from the page dropdown at the top
19:11:03 <colindixon> #link http://docs.opendaylight.org/en/latest/submodules/releng/builder/docs/jenkins.html a different exmaple of how to handle is to manually draw a table of contents
19:11:35 <colindixon> #info in particular it would be really cool to get your position in the full tree of content
19:12:31 <colindixon> #info for exmaple, above knowing that jenkins was under the infrasturcutre guide, which was under the root
19:13:01 <colindixon> #info 2.) right now, every rst file is an html page, which kind of sucks because some of them are very small
19:13:31 <colindixon> #info could we make it so that we aggregated some rst files into one html page (or even producted one big html document for everything?)
19:14:03 <colindixon> #link http://docs.opendaylight.org/en/latest/getting-started-guide/who_should_use.html for exmaple, this shouldn't be it's own page
19:15:10 <colindixon> #link http://docs.opendaylight.org/en/latest/getting-started-guide/index.html as slightly different idea, this page has no contnet, it would be nice if you could tell reST to combine all the toctree things here
19:15:53 <colindixon> #info 3.) probably lowest priroity, figure out if there's a way to produce one PDF per top-level section, e.g., user guide PDF, getting started guide PDF, etc. rather than just one big one
19:17:58 <colindixon> #info 4.) this is a stretch, but figuring out how to provide a way to give feedback, file a bug, or even edit the file in gerrit (which I don't think is possible), would be really cool
19:19:57 <colindixon> #topic per-project documentaiton
19:20:07 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 we continue to make progress
19:24:08 <colindixon> #info down to 21 projcts with no new docs in boron
19:24:31 <colindixon> #info down to 22 outstanding patches, only 3 f which are blocking on the documentation
19:24:46 <colindixon> #topic migrating User Guide/Developer Guide to reST in boron
19:24:54 <colindixon> #info we had a TWS on this on Monday
19:25:15 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2016/tws/opendaylight-meeting-tws.2016-08-08-17.01.html really, really sparse notes
19:25:23 <colindixon> #info it was recorded
19:25:56 <colindixon> #info it will be posted here https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings
19:25:58 <colindixon> #undo
19:25:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2437250>
19:26:12 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings the recording will be posted here
19:26:38 <phrobb> #link https://meetings.webex.com/collabs/url/2xCvZ-TWMBC_aEljHv55GW1tBGCg76qT5kd5RGrXwCa00000 <-- link to TWS meeting on Documentation
19:27:01 <colindixon> #info the most important thing that dropped out is that there are differnet projects that want to take different approaches for how and when to migrate their docs
19:28:59 <colindixon> #info some projects want to migrate already, others probably want to wait until after Boron to start producing reST
19:29:19 <colindixon> #info the result is that we might want to do partial migrations, e.g., ignore migrating some content
19:29:52 <colindixon> #info maybe by seeing if the section starts "This content has been migrated to:.." or something like that
19:30:05 <colindixon> #info 5.) this would be another thing which maybe xinghao_ could work on
19:33:13 <colindixon> #info the current plan of record, colindixon thinks should be to propose patches migrating everyone's content and ask them to opt-out or approve, if no interaction for some period of time, e.g., 2 weeks, we merge it anwyay
19:34:19 <colindixon> #info we need to deal with in flight patches, which could be a pain, but we're down to ~20 of those across 18 projects, so we could migrate ~30-35 without problems at all, which would still be a huge win
19:35:39 <colindixon> #action  colindixon to e-mail projects with no docs and no e-mail saying there won't be any
19:35:49 <colindixon> #action colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
19:36:52 <colindixon> #action colindixon to follow up with projects that generated the openstack content to let them know it was migrated and that we're plannig to delete the older version
19:36:58 <colindixon> #actoin colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:37:02 <colindixon> #action colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:37:09 <colindixon> #action phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money
19:38:11 <colindixon> #undo
19:38:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2639f10>
19:38:34 <colindixon> #action phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)
19:39:33 <colindixon> #action colindixon to add fixing cross-projet links (and notes) as things to check for after automatic conversion
19:40:32 <colindixon> #Info colindixon did e-mail people with seemingly abandoned patches and then formally abandoned them
19:41:06 <colindixon> #action colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week
19:41:44 <colindixon> #info the key parts of creating one patch per project would be:
19:42:28 <colindixon> a.) add the new reST in the right place, e.g., probably not in doc_autotranslated, probably it makese sense to put it in docs/user-guide/<section-tite>.rst or something
19:42:45 <colindixon> b.) remove the content from asciidoc and replace it with somethign like "This content has been migrated to: <url>"
19:43:11 <colindixon> that will be useful for users that might be looking at the PDF and also could could be used as a key to not migrate it in our scripts if we wanted
19:43:31 <colindixon> c.) give a quick scan to make sure it formats reasonable in HTML, but ~30 seconds or less
19:44:13 <colindixon> d.) probably a script would do this pretty quickly, but maybe not because of issues with how to map things back to asciidoc
19:44:55 <colindixon> #endmeeting