19:09:18 <colindixon> #startmeeting docs
19:09:18 <odl_meetbot> Meeting started Tue Aug 16 19:09:18 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:09:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:09:18 <odl_meetbot> The meeting name has been set to 'docs'
19:09:24 <colindixon> #topic agenda
19:09:42 <colindixon> #Info migration of user and developer guide from asciidoc to rst
19:10:04 <colindixon> #info project-specific docs patches
19:10:07 <colindixon> #topic migration to reST
19:10:28 <colindixon> #info we had the TWS not yesterday, but a week ago yesterday, nobody seemed to really object
19:10:41 <colindixon> #info colindixon has started pushing patches that migrate each project one by one
19:11:10 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/topic:adoc2rst all patches have the topic adoc2rst in gerrit
19:12:37 <colindixon> #topic project-specific docs patches
19:13:10 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 we're staying at something like 8-10 patches inflight—mostly because projects are slow to update things
19:13:57 <colindixon> #info we have 5 "abandoned?" patches, that colindixon is going to really abandon at the end of the day, we had about 4-5 patcehs that were "abandoned?" that projects rescued
19:14:35 <colindixon> #info colindixon is trying to convert adoc to rst only on projects without in-flight patches at least for now
19:16:07 <colindixon> #action colindixon to e-mail projects with no docs and no e-mail saying there won't be any
19:16:07 <colindixon> #action colindixon to work with zxiiro to post instructions on how to use https to push gerrit patches (the naive thing doesn't work)
19:16:09 <colindixon> #action colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:16:10 <colindixon> #action phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it might take >15 minutes to buidl all our docs without javadoc)
19:16:11 <colindixon> #action colindixon to add fixing cross-project links (and notes) as things to check for after automatic conversion
19:16:12 <colindixon> #action colindixon, zxiiro or xinghao_ to do the conversion (soon) and create one patch per project to get approval or not, probably we should do this (at least for projects without in-flight ptaches) later this week
19:18:16 <phrobb> #info phrobb will jump on the call as soon as he is able.  He has made contact with one of the leaders of RTD who seems very interested in helping us to bump up our limits
19:18:30 <colindixon> phrobb: cool!
19:18:35 <colindixon> we're about to break
19:21:47 <phrobb> OK, I might not make the meeting then
19:21:54 <colindixon> how long?
19:22:02 <colindixon> we're waiting for you and just working on mute
19:22:08 <colindixon> but we can just jump too
19:25:51 <phrobb> I'll probably be tied up for another 10 minutes
19:35:31 <colindixon> phrobb: we're hanging out
19:36:41 <colindixon> #topic read the docs support
19:36:57 <colindixon> #info phrobb heard back from RTD people saying that they'd be happy to up our resource limits
19:37:43 <colindixon> #info we're waiting on taking next steps
19:40:32 <colindixon> #info phrobb asks how much time we'd need, right now 30-60 minutes will probably do us, if we try to do all javadoc for all classes, maybe 3-5 hours, we're not quite sure
19:41:26 <colindixon> #endmeeting