#opendaylight-docs: docs

Meeting started by colindixon at 19:05:36 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 19:05:44)
    1. https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-08-16-19.09.html last week's minutes (colindixon, 19:06:04)
    2. ACTION: colindixon to e-mail projects with no docs and no e-mail saying there won't be any (colindixon, 19:06:58)
    3. http://docs.opendaylight.org/en/latest/gerrit.html#using-https-to-push-to-gerrit this is push via https to gerrit instructions (colindixon, 19:07:40)
    4. ACTION: colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior (colindixon, 19:07:48)
    5. ACTION: phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it is taking 243 seconds with most stuff migrated, it's unlikely to hit the 15 minute limit without javadoc) (colindixon, 19:09:46)

  2. migration to rst (colindixon, 19:10:22)
    1. https://git.opendaylight.org/gerrit/#/q/(topic:adoc2rst+OR+topic:adoc2rst-user)+status:open open patches for migration (colindixon, 19:10:43)
    2. we're down to ~8 projects (colindixon, 19:11:01)
    3. colindixon is planning on merging all the other patches without in flight conflicting patches on Thursday night (colindixon, 19:11:55)
    4. https://lists.opendaylight.org/pipermail/release/2016-August/008041.html (colindixon, 19:11:57)
    5. https://lists.opendaylight.org/pipermail/release/2016-August/008042.html (colindixon, 19:12:03)
    6. after that, we need to basically fix sphinx warnings and try to clean things that look wrong up (colindixon, 19:12:25)
    7. ACTION: colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version (colindixon, 19:12:53)
    8. http://docs.opendaylight.org/en/stable-boron/search.html?q=yang+ide&check_keywords=yes&area=default (colindixon, 19:13:48)
    9. http://docs.opendaylight.org/en/stable-boron/getting-started-guide/project-specific-guides/yangide.html (colindixon, 19:14:01)
    10. http://docs.opendaylight.org/en/stable-boron/user-guide/yang-ide-user-guide.html (colindixon, 19:14:09)
    11. http://docs.opendaylight.org/en/stable-boron/search.html?q=ide (colindixon, 19:14:15)
    12. ACTION: colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc (colindixon, 19:15:42)
    13. colindixon notes that this search doesn't work despite their being Yang IDE documentation http://docs.opendaylight.org/en/stable-boron/search.html?q=yang+ide&check_keywords=yes&area=default (colindixon, 19:19:21)
    14. http://docs.opendaylight.org/en/stable-boron/ (colindixon, 19:19:31)

  3. project-specific documentation (colindixon, 19:20:50)
    1. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 (colindixon, 19:20:59)
    2. we have 7 patches waiting for docs reviews after colindixon was out for a week (colindixon, 19:21:16)
    3. colindixon is updating projects listed as missing during release reviews, some of them colindixon thinks are still out of date, but i guess that's the prerogative (colindixon, 19:22:09)

  4. openstack documentation (colindixon, 19:22:31)
    1. this hasn't changed much in boron (colindixon, 19:22:41)
    2. https://lists.opendaylight.org/pipermail/documentation/2016-August/000897.html (colindixon, 19:23:02)
    3. ACTION: colindixon to help lisa caywood hunt people down and get the openstack docs updated (colindixon, 19:24:08)
    4. ACTION: anipbu to revise the list of blocking bugs here: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046 (colindixon, 19:34:45)
    5. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&query_format=advanced&resolution=--- (colindixon, 19:35:51)
    6. ACTION: colindixon, phrobb, and anipbu to look through this: https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&order=changeddate%2Cbug_status%2Cpriority%2Cbug_severity&query_based_on=&query_format=advanced&resolution=--- (colindixon, 19:37:10)


Meeting ended at 19:41:22 UTC (full logs).

Action items

  1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any
  2. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
  3. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it is taking 243 seconds with most stuff migrated, it's unlikely to hit the 15 minute limit without javadoc)
  4. colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version
  5. colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc
  6. colindixon to help lisa caywood hunt people down and get the openstack docs updated
  7. anipbu to revise the list of blocking bugs here: https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046
  8. colindixon, phrobb, and anipbu to look through this: https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&order=changeddate%2Cbug_status%2Cpriority%2Cbug_severity&query_based_on=&query_format=advanced&resolution=---


Action items, by person

  1. colindixon
    1. colindixon to e-mail projects with no docs and no e-mail saying there won't be any
    2. colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
    3. phrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it is taking 243 seconds with most stuff migrated, it's unlikely to hit the 15 minute limit without javadoc)
    4. colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version
    5. colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc
    6. colindixon to help lisa caywood hunt people down and get the openstack docs updated
    7. colindixon, phrobb, and anipbu to look through this: https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&order=changeddate%2Cbug_status%2Cpriority%2Cbug_severity&query_based_on=&query_format=advanced&resolution=---


People present (lines said)

  1. colindixon (35)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.