19:02:20 <colindixon> #startmeeting docs
19:02:20 <odl_meetbot> Meeting started Tue Sep  6 19:02:20 2016 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:02:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:20 <odl_meetbot> The meeting name has been set to 'docs'
19:02:26 <colindixon> #topic agenda bashing
19:03:04 <colindixon> #link https://meetings.opendaylight.org/opendaylight-docs/2016/docs/opendaylight-docs-docs.2016-08-30-19.05.html last week's meeting minutes
19:03:34 <colindixon> #info colindixon is in the process of e-mail projects which have no or no new documentation
19:03:54 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863 logging that in the patch coments section of "MISSING" patches here
19:04:15 <colindixon> #action colindixon to note in the docs that read the docs doesn't clean the build environment between runs, which can cause really weird behavior
19:04:26 <colindixon> #actionphrobb and zxiiro to reach out to read the docs to see if we can solve this problem with a modest amount of money (colindixon notes that it is taking 243 seconds with most stuff migrated, it's unlikely to hit the 15 minute limit without javadoc)
19:04:32 <colindixon> #action colindixon to find an externminate bad words from the docs, e.g., references to beryllium and lithium as though they are this version
19:04:50 <colindixon> #action colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc
19:04:59 <colindixon> #undo
19:04:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2496410>
19:05:07 <colindixon> #action colindixon and/or zxiiro to look into why searching for ide returns nothing, colindixon notes that searches for 3 characters or less seem to only return javadoc
19:05:21 <colindixon> if you search for NetIDE: http://docs.opendaylight.org/en/stable-boron/search.html?q=netide&check_keywords=yes&area=default
19:05:35 <colindixon> you find the developer guide, but not the user guide
19:06:34 <colindixon> but this exists: http://docs.opendaylight.org/en/stable-boron/user-guide/netide-user-guide.html
19:07:34 <colindixon> it also turns out that not all three-letter seraches are bad, e.g., VPN: http://docs.opendaylight.org/en/stable-boron/search.html?q=vpn
19:07:45 <colindixon> #info search in sphinx appears to be somewhat broken
19:09:35 <colindixon> #action colindixon to help lisa caywood hunt people down and get the openstack docs updated
19:10:43 <colindixon> #topic longer readthedocs times
19:11:20 <colindixon> #info how long do we expect readthedocs runs to take with sphinx javadoc enabled? do we want other domains?
19:11:50 <colindixon> #info zxiiro says that it would take hours, he'd recommend figuring something else out?
19:13:38 <colindixon> #Info phrobb says they seem to be accommodating, colindixon and zxiiro say it will take autorelease style times, so 5-6 horus and maybe longer
19:14:15 <colindixon> #info colindixon notes that we're still at 4-5 minutes with pretty much everything migrated
19:15:19 <colindixon> #info three options: (1) do nothing, (2) ask them to run things that take many, many hours, (3) pre-builld javadoc on our side
19:18:06 <colindixon> #info zxiiro says that he's leaning toward (3), even if only because it will ensure less lag between patches being merged and showing up
19:19:47 <colindixon> #topic Beau on the "beginner's guide"
19:20:01 <colindixon> #Info this is as compared to getting started, which basically gets it installed, and runnig, but doing nothing
19:20:24 <colindixon> #info this would be the "how do you actually do something useful with your network and OpenDaylight"
19:21:01 <colindixon> #info Beau would like to lean on more knowledgeably OpenDaylight people to help him understand and document them
19:23:33 <colindixon> #info colindixon says that the best way to do that, would be to pick one scenario at a time and then finding the right people
19:23:46 <colindixon> #info beau says that NETCONF device management would be the first thing he'd like to do
19:26:15 <colindixon> #info CaseyODL was trying to gather scenarios like this at some point as well
19:26:59 <colindixon> #action CaseyODL, colindixon, and beau to compare notes on what tutorials we're looking for and what we have
19:33:33 <colindixon> #topic boron docs status
19:33:34 <colindixon> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=22029863
19:34:14 <colindixon> #info we have some projects (~12) with no or no new documentation
19:34:26 <colindixon> #info we have 4 patches, 2 waiting for a +1 and 2 waiting for updates
19:34:42 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/(topic:adoc2rst+OR+topic:adoc2rst-user)+status:open migration to rst
19:34:58 <colindixon> #info waiting for +1s from SNBI and OpenFlow plugin
19:35:10 <colindixon> #info SDNi is blcoked on an in-flight asciidoc patch (see above)
19:38:56 <colindixon> #topic missing features in reST
19:39:19 <colindixon> #link cross-refernecing in reST: http://www.sphinx-doc.org/en/stable/rest.html#internal-links
19:39:54 <colindixon> #link http://www.sphinx-doc.org/en/stable/markup/inline.html#ref-role
19:42:01 <colindixon> #link https://sourceforge.net/p/numfig/wiki/Home/ this would allow for figure numbers
19:43:34 <colindixon> #info inline markup can't be nested, this is just true
19:43:35 <colindixon> #link http://www.sphinx-doc.org/en/stable/rest.html#inline-markup see here
19:44:43 <colindixon> #action colindixon and/or zxiiro to file a bug and/or look into nested directives
19:49:49 <colindixon> #action colindixon and/or zxiiro to look into a YANG pygment
19:53:56 <colindixon> #endmeeting