20:02:06 <colindixon> #startmeeting docs
20:02:06 <odl_meetbot> Meeting started Tue Jan 24 20:02:06 2017 UTC. The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:02:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:06 <odl_meetbot> The meeting name has been set to 'docs'
20:02:44 <colindixon> #topic agenda bashing
20:03:16 <colindixon> #link https://meetings.opendaylight.org/opendaylight-docs/2017/docs/opendaylight-docs-docs.2017-01-17-20.11.html last week's meeting minutes
20:03:31 <colindixon> zxiiro: are you here or still enroute to SJC
20:05:37 <colindixon> #action colindixon to help lisa caywood hunt people down and get the openstack docs updated
20:05:38 <colindixon> #action CaseyODL, colindixon, Lisa and beau to compare notes on what tutorials we're looking for and what we have
20:05:40 <colindixon> #action colindixon to work with anipbu to figure out how to provide new or updated information for new projects and/or new features
20:05:41 <colindixon> #action colindixon to add a section to the release notes script to at least put in a TBD for security advisories
20:05:42 <colindixon> #action colindixon to get notes on how to run the release notes generator and automate it
20:07:04 <colindixon> #info CaseyODL says that we need to include all publicly known security issues in our relase notes to get the core infrastructure LF security badge thing
20:07:34 <colindixon> #undo
20:07:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1961f90>
20:07:48 <colindixon> #info CaseyODL says that we need to include all publicly known security issues that are fixed in each release in the relase notes to get the core infrastructure LF security badge thing
20:08:36 <colindixon> #topic OPNFV docs overview from ShuhamRathi
20:09:24 <colindixon> #link https://opnfv.readthedocs.io/en/latest/ first migration is done
20:09:47 <colindixon> #Info there's a non-blocking bug where RTD shows a build failure when the build is actually updating
20:11:02 <zxiiro> maybe i'll just type
20:11:07 <colindixon> that's probably better
20:12:50 <zxiiro> Yes, OPNFV infra team will take care of that part. you don't have to worry about it in your own job
20:13:45 <zxiiro> yes that's right
20:13:54 <zxiiro> If we're looking at the publishers section that is taken care of by CI infra team. The only "code" that matters for the docs team the single bash script in the builders section
20:15:50 <colindixon> I think it's post-build scripts.
20:15:57 <zxiiro> yes post-build == publishers
20:18:19 <colindixon> #link http://www.sphinx-doc.org/en/stable/markup/inline.html#ref-role how to handle hyperlinks
20:19:05 <colindixon> #link http://docs.opendaylight.org/en/latest/documentation.html#referencing-sections the ODL-specific stuff
20:20:47 <zxiiro> I do not know
20:20:51 <zxiiro> i think it sends a warning
20:20:54 <zxiiro> we can probably grep that
20:21:02 <colindixon> #action zxiiro and colindixon to look into breaking the build when we have broken :ref: links
20:24:05 <zxiiro> i don't recall merging that, might still be pending
20:24:38 <zxiiro> a little off-topic but we are now building all projects on merge. (or should be)
20:24:47 <zxiiro> i mena branches
20:25:28 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/49783/ documentation on how to create submodules
20:27:05 <zxiiro> curl -X POST --data "version_slug=$RTD_BUILD_VERSION" https://readthedocs.org/build/opendaylight
20:27:25 <zxiiro> you can pass version_slug to specify branch in rtd
20:27:52 <zxiiro> but it's not branch, it's what rtd refers to the branch, so like stable-boron instead of stable/boron
20:28:54 <colindixon> #info zxiiro says that we now build right the batch on merge jobs by doing curl -X POST --data "version_slug=$RTD_BUILD_VERSION" https://readthedocs.org/build/opendaylight
20:29:13 <colindixon> #info in reality because master => latest and stable/boron to stable-boron, I think we just build them all on every merge
20:29:48 <zxiiro> yes i'm there all week
20:35:02 <zxiiro> you need the CNAME as well as to get LF staff to create a DNS record in that CNAME
20:38:18 <colindixon> #info see other commentary from zxiiro in the full logs
20:42:20 <zxiiro> We can definitely come up with a framework to share the same docs in both projects from the same repo.
20:43:06 <colindixon> #action colindixon to migrate the common docs tasks off the wiki to documentation https://wiki.opendaylight.org/view/Documentation/Tools#Common_Doc_Tasks
20:43:50 <colindixon> http://wiki.c2.com/?LazinessImpatienceHubris
20:44:49 <zxiiro> thanks, i'm dropping too
20:44:53 <colindixon> cheers
20:44:57 <colindixon> #endmeeting