14:05:37 <vorburger> #startmeeting genius
14:05:37 <odl_meetbot> Meeting started Thu Apr 13 14:05:37 2017 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:05:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:37 <odl_meetbot> The meeting name has been set to 'genius'
14:05:49 <vorburger> #topic rollcall
14:05:52 <vorburger> #info vorburger
14:06:27 <afredette> #info Andre Fredette
14:06:38 <vorburger> #info faseelak
14:06:43 <faseelak> #info faseelak
14:06:47 <vorburger> #topic pending Reviews
14:07:04 <vorburger> #info due to broken overall build, we're not merging anything today
14:07:18 <vorburger> #topic bug scrub
14:07:27 <vorburger> #link https://bugs.opendaylight.org/buglist.cgi?bug_status=__open__&list_id=77005&product=genius
14:08:14 <vorburger> #info we have 20 open bugs right now (last week we had 30 something)
14:11:56 <faseelak> #link https://bugs.opendaylight.org/show_bug.cgi?id=7451
14:13:13 <shague> #info shague
14:13:46 <vorburger> #action vorburger to raise helpdesk to get "ODL SR Target Milestone" everywhere, as e.g. https://bugs.opendaylight.org/show_bug.cgi?id=8224 does not have it
14:14:17 <vorburger> #action vorburger to also raise that we want 2 fields, one for Target/Fixed In and Found In
14:15:48 <shague> #info there is a Version field where you can add the version. It is a manual process for committers to add the version choices
14:16:20 <vorburger> #info all open bugs have assigned owners working on them
14:16:33 <vorburger> shague: I'll ping you after oflfine to figure this out
14:16:41 <vorburger> #topic JUnits status
14:17:36 <vorburger> #info faseelak working on interface manager test coverage, uses vorburger component test infrastructure infrastructure
14:18:11 <vorburger> #action faseelak to check if https://git.opendaylight.org/gerrit/#/c/54811/ fixes the problem discussed on email
14:18:13 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/54811/
14:18:41 <vorburger> #info faseelak 80% on lockmanager
14:19:00 <vorburger> #info overall genius is still at only 40% as of today
14:19:50 <faseelak> #link https://sonar.opendaylight.org/
14:20:05 <vorburger> #info fcapsmanager has no tests, but may be removed, so we don't want to work on this
14:20:28 <vorburger> #info resourcemanager is the one most needed tests and coverage
14:20:42 <vorburger> #action vorburger to put in basic test skeleton into resourcemanager
14:21:01 <vorburger> #action faseelak (or David?) to then extend resourcemanager with tests
14:21:24 <vorburger> #topic Carbon Workflow
14:22:56 <vorburger> #info see shague's email
14:27:09 <vorburger> #info vorburger questions why a branch was cut if we back patch cherry-pick everything from master to stable/carbon
14:27:39 <vorburger> #info vorburger is warming up to the idea to, eventually, let projects release when they see fit, and have decoupled releases
14:29:30 <vorburger> #topic broken build
14:29:45 <vorburger> #info faseelak raises that build has broken for too long
14:29:55 <vorburger> #info eman is broken
14:31:09 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/54860/
14:32:33 <vorburger> #action vorburger afredette will jump on email thread to TSC started by faseelak
14:34:20 <shague> #link https://git.opendaylight.org/gerrit/#/c/54425/7
14:34:43 <shague> #link https://logs.opendaylight.org/releng/jenkins092/genius-verify-nitrogen-mvn33-openjdk8/27/console.log.gz
14:38:52 <vorburger> #link https://logs.opendaylight.org/releng/jenkins092/genius-verify-nitrogen-mvn33-openjdk8/27/archives/interfacemanager/interfacemanager-impl/target/surefire-reports/org.opendaylight.genius.interfacemanager.test.InterfaceManagerConfigurationTest-output.txt.gz
14:39:29 <shague> #link https://git.opendaylight.org/gerrit/#/c/54890/
14:41:43 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/topic:FlowEntity-immutable
14:42:54 <vorburger> #action shague to merge both the genius and netvirt together next week, once current build instability is over and more pressing bug fixes have been merged
14:43:26 <vorburger> #endmeeting