14:13:16 <vorburger> #startmeeting genius
14:13:16 <odl_meetbot> Meeting started Thu May 11 14:13:16 2017 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:13:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:13:16 <odl_meetbot> The meeting name has been set to 'genius'
14:13:27 <vorburger> #topic info in please
14:13:40 <faseelak> #info faseelak
14:13:42 <vorburger> #info vorburger
14:13:45 <skitt> #info skitt
14:13:48 <edavsua> #info edavsua
14:14:00 <vorburger> #topic Gerrit Reviews
14:14:13 <vorburger> #chair edavsua faseelak skitt
14:14:13 <odl_meetbot> Current chairs: edavsua faseelak skitt vorburger
14:14:36 <faseelak> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:15:06 <vorburger> #action Peri to review https://git.opendaylight.org/gerrit/#/c/55860/
14:15:28 <vorburger> #action faseelak will review https://git.opendaylight.org/gerrit/#/c/56760/
14:15:59 <vorburger> #info https://git.opendaylight.org/gerrit/#/c/56570/ is ready for merge to stable/carbon, once it re-opens
14:16:18 <vorburger> #action vorburger to re-review https://git.opendaylight.org/gerrit/#/c/53544/
14:19:49 <vorburger> #info https://git.opendaylight.org/gerrit/#/c/56031/ to be considered in 2 weeks after DDF (master)
14:20:03 <vorburger> #action edavsua wil review https://git.opendaylight.org/gerrit/#/c/56031/
14:22:09 <vorburger> #action faseelak vorburger will write a spec documenting proposal in https://git.opendaylight.org/gerrit/#/c/56031/
14:25:03 <vorburger> #topic Test Code Coverage
14:25:32 <vorburger> #info according to faseelak it's now at 42% up from 30%
14:25:56 <vorburger> #info biggest gaps are in mdsalutil, alivenessmonitor and fcaps-application
14:26:45 <faseelak> #link https://sonar.opendaylight.org/
14:29:40 <vorburger> #info mdsalutil has a lot of @Deprecated. If we just cleaned up and got rid of all of that, the coverage would already look better
14:31:37 <vorburger> #action vivek to table work at DDF for nitrogen to get rid of all @Deprecated code in genius mdsalutil
14:34:14 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open,25
14:34:41 <vorburger> #topic Reviewing very old stuck Gerrits, abandon?
14:35:57 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/52334/
14:36:39 <vorburger> #info that's waiting for openflow plugin merge https://git.opendaylight.org/gerrit/#/c/51498/
14:38:08 <vorburger> #action Hema_ will ping people having very old pending changes stuck with Merge Conflict
14:38:27 <vorburger> #action Michael to rebase / review / merge https://git.opendaylight.org/gerrit/#/c/50192/
14:40:36 <vorburger> #endmeeting