14:06:49 <edavsua> #startmeeting Genius Weekly
14:06:49 <odl_meetbot> Meeting started Thu Mar 23 14:06:49 2017 UTC.  The chair is edavsua. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:06:49 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:49 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:07:00 <vorburger> #topic rollcall
14:07:07 <edavsua> #info edavsua
14:07:11 <viveks> #info viveks
14:07:13 <afredette> #info Andre Fredette
14:07:15 <vorburger> #info vorburger
14:07:27 <vorburger> edavsua: can you #chair vorburger viveks afredette
14:07:58 <edavsua> #chair vorburger
14:07:58 <odl_meetbot> Current chairs: edavsua vorburger
14:08:11 <edavsua> #chair viveks
14:08:11 <odl_meetbot> Current chairs: edavsua viveks vorburger
14:08:13 <vorburger> #topic idmanager improvement (Sai)
14:08:30 <edavsua> #chair afredette
14:08:30 <odl_meetbot> Current chairs: afredette edavsua viveks vorburger
14:12:57 <edavsua> #info Shai is proposing to use the Id Manager to lease IPs in a DHCP use case
14:13:39 <edavsua> #info We'd need to add expiration times for the ids provided by the IdManager
14:14:10 <edavsua> #info this modification would be for Nitrogen release
14:15:37 <vorburger> #topic Abstract DCN cleanup
14:18:47 <edavsua> #info SFC is not using Genius' DCN
14:18:58 <vorburger> shague: post #link to what you're discussing?
14:20:14 <edavsua> #topic Boron SR3 blocker bugs
14:23:25 <shague> #link https://git.opendaylight.org/gerrit/#/c/53472/ - this is the bug to include in the boron sr3 list
14:23:55 <shague> #link https://git.opendaylight.org/gerrit/#/c/53463/ already in list
14:24:10 <shague> #link https://git.opendaylight.org/gerrit/#/c/53686/ already in list
14:25:08 <vorburger> #topic Unit Test Code Coverage
14:26:43 <edavsua> #info we need to analyze what code is not used anymore
14:26:46 <vorburger> #info alivenessmonitor and fcapsmanager may be removed
14:26:52 <faseelak> #info faseelak
14:27:37 <vorburger> #info resourcemanager may also be removed (because everyone is directly using the idmanager)
14:34:54 <ebrjohn> #info Brady Johnson (IRC only)
14:35:31 <edavsua> https://bluejeans.com/440027857/
14:35:41 <edavsua> Use this link to connect to BlueJeans
14:38:42 <vorburger> #topic Multiple VxLAN uplinks pending review
14:38:52 <vorburger> #undo
14:38:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x19718d0>
14:39:45 <vorburger> #action vorburger to share TestIMdsalApiManager discussion on private email thread with genius-dev public list
14:39:53 <vorburger> #topic Multiple VxLAN uplinks pending review
14:41:23 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/52871/11
14:43:16 <vorburger> #action vorburger to review https://git.opendaylight.org/gerrit/#/c/52871/ if any concerns re. circular dependency
14:45:02 <vorburger> #topic FlowEntity immutability
14:45:11 <vorburger> #link https://lists.opendaylight.org/pipermail/genius-dev/2017-March/001075.html
14:46:34 <ebrjohn> Doesnt he mean they should be immutable?
14:46:48 <edavsua> Yes
14:46:55 <ebrjohn> mutable means they can change, we want immutable
14:47:13 <edavsua> Yes, we want them immutable
14:48:12 <ebrjohn> +1 to this change
14:48:54 <edavsua> #action vorburger will create a proposal for that
14:49:27 <vorburger> #topic Review of pending Gerrit ready for merge
14:49:34 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:49:44 <ebrjohn> Can we review this very simple change of mine: https://git.opendaylight.org/gerrit/#/c/53710/
14:51:09 <vorburger> ebrjohn: it's not on the list because no +1 from jenkins because it's just building, but let's bring it up once we're through the list
14:51:34 <edavsua> Yes, I think we could bring it first, since he is just for that :P
14:51:49 <ebrjohn> vorburger: ok thanks
14:51:49 <vorburger> I also have one I'd like people to review (that's just building) : https://git.opendaylight.org/gerrit/#/c/52970/
14:52:15 <ebrjohn> vorburger: its a race who's patch finishes first ;)
14:52:18 <edavsua> Brady's has my +1, but it was removed by the current rebase
14:53:21 <vorburger> #action vorburger to re-review https://git.opendaylight.org/gerrit/#/c/50371/ re. ITM test
15:17:34 <vorburger> #endmeeting