14:03:24 <vorburger> #startmeeting genius weekly
14:03:24 <odl_meetbot> Meeting started Thu Aug 17 14:03:24 2017 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:03:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:24 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:03:34 <vorburger> #topic info in
14:03:45 <vthapar> #info Vishal
14:03:46 <skitt> #info skitt
14:04:05 <faseelak_> #info faseelak_
14:04:12 <viveks> #info viveks
14:04:37 <vorburger> #link https://lists.opendaylight.org/pipermail/genius-dev/2017-August/001797.html
14:05:41 <vorburger> #info netvirt already uses "Rebase if Necessary"
14:06:55 <vorburger> #info infrautils used to start with "Fast Forward only", but then changed it to "Rebase if Necessary"
14:09:22 <vorburger> #startvote Shall the genius project change its Gerrit Submit Strategy from Merge if neccessary to Rebase if neccessary?
14:09:22 <odl_meetbot> Begin voting on: Shall the genius project change its Gerrit Submit Strategy from Merge if neccessary to Rebase if neccessary? Valid vote options are Yes, No.
14:09:22 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
14:09:32 <vthapar> #vote Yes
14:09:38 <faseelak_> #vote Yes
14:09:38 <edavsua> #info edavsua
14:09:39 <viveks> #vote Yes
14:09:41 <vorburger> #vote Yes
14:09:42 <edavsua> #vote yes
14:09:50 <vorburger> #endvote
14:09:50 <odl_meetbot> Voted on "Shall the genius project change its Gerrit Submit Strategy from Merge if neccessary to Rebase if neccessary?" Results are
14:11:14 <vorburger> #action vorburger will raise LF ticket for Gerrit submit change
14:11:22 <vorburger> #topic idmanager Daexim integration OK?
14:11:26 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/61769/
14:11:44 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/61769/4/idmanager/idmanager-impl/src/main/java/org/opendaylight/genius/idmanager/IdManager.java
14:13:51 <vorburger> #action Faseela to prompt Muthu to review it as well
14:14:02 <vorburger> #info nobody seem to have any objections
14:14:28 <vorburger> #topic https://git.opendaylight.org/gerrit/#/c/60265/
14:15:58 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/60265/ was the only use of this method in netvirt, which has been changed
14:17:44 <vorburger> #action Faseela to +2 and merge when build passed
14:18:29 <vorburger> #topic Next steps re. deprecating AsyncDataTreeChangeListener?
14:18:40 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/59177/
14:19:38 <vorburger> edavsua: we can't hear you very well, do you want to chat here?
14:20:31 <vorburger> #info there was the idea to add clustered version as well, but that could come into a follow up change also
14:21:28 <vorburger> #action vorburger to re-review it and +1 as David has taken his feedback into account
14:22:31 <vorburger> #action Vishal to re-review and +2 and merge it if no other objections
14:23:09 <edavsua> ok
14:23:27 <edavsua> Sorry, the connection fails a lot
14:25:41 <vorburger> #action Vishal to see with David if he or him will do the follow-up to add the async part
14:26:10 <vorburger> #topic FYI mdsal ordering problem
14:26:19 <edavsua> The async part is already finished
14:26:22 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/60313/
14:28:25 <vorburger> #action vorburger cherry pick to Nitrogen
14:29:16 <skitt> vorburger, I’ve already cherry-picked it to Nitrogen
14:30:53 <vorburger> #info This (c/60313) is the patch to look at how to work around case of weird arbitrary looking comparison failures between actual YANG DataObject read from DS and expected objects from Xtend
14:30:54 <edavsua> I am sorry Zoom keeps kicking me out
14:31:12 <vorburger> #topic review changes
14:31:19 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:41:14 <vorburger> #link FYI https://wiki.opendaylight.org/view/BestPractices/Coding_Guidelines#Utility_classes_with_only_static_methods
14:55:01 <viveks> #endmeeting
14:55:11 <vorburger> #endmeeting