14:05:23 <vorburger> #startmeeting genius-weekly
14:05:23 <odl_meetbot> Meeting started Thu Sep 21 14:05:23 2017 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:05:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:23 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:05:30 <vorburger> #topic info in?
14:05:31 <vthapar> #info Vishal
14:05:34 <vorburger> #chair vthapar
14:05:34 <odl_meetbot> Current chairs: vorburger vthapar
14:05:44 <edavsua> #info edavsua
14:06:13 <viveks> #info viveks
14:06:18 <vorburger> #chair viveks
14:06:18 <odl_meetbot> Current chairs: viveks vorburger vthapar
14:06:39 <faseelak> #info faseelak
14:06:49 <vorburger> #chair faseelak
14:06:49 <odl_meetbot> Current chairs: faseelak viveks vorburger vthapar
14:06:58 <vorburger> #topic Agenda
14:07:00 <vorburger> #link https://trello.com/c/AFS8LqP6/35-meeting-agenda-2017-09-21
14:07:13 <vorburger> #topic Deprecation/Removal of any unused projects?
14:08:18 <vorburger> #info viveks explains that arputil used to be used only by alivenessmonitor, but shague_ clarified on list it's now used by netvirt, so can't remove
14:08:53 <shague_> #info shague
14:09:11 <vorburger> #info fcapsmanager, fcapsapplication, alivenessmonitor, resourcemanager are all not actively used currently
14:09:51 <vorburger> #info there is no "burning problem" to remove them, it's more just a general dont-keep-unused-code
14:12:20 <vorburger> #info fcapsmanager / fcapsapplication may be remove once statusdiag by faseelak in infrautils works
14:12:44 <vorburger> #topic https://git.opendaylight.org/gerrit/#/q/topic:genius.DJC-to-infra.JC finally hopefully ready
14:16:09 <vorburger> #action vorburger will request CSIT on genius and netvirt once https://git.opendaylight.org/gerrit/#/c/60303/
14:16:27 <vorburger> #topic Better share the load of reviewing "trivial" clean up changes
14:17:57 <vorburger> #info edavsua says that due to the rule to get x2 +1 to merge, it's sometimes difficult to get for simpler clean up changes
14:20:21 <vorburger> #action viveks vthapar Hema will help to review the low risk "mechanical" changes often proposed by skitt and edavsua
14:22:34 <vorburger> #action ALL use "Mechanical:" commit message prefix for changes which are clean up type changes done automatically by IDE like tools
14:23:20 <vorburger> #action skitt edavsua vorburger ALL to include Hema as Reviewer on more changes
14:26:15 <vorburger> #topic ready changes
14:26:22 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:26:42 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0+branch:master
14:28:03 <vorburger> #action faseelak https://git.opendaylight.org/gerrit/#/c/61931/
14:29:01 <vorburger> #action viveks faseelak https://git.opendaylight.org/gerrit/#/c/63121/
14:30:37 <vorburger> #action vthapar https://git.opendaylight.org/gerrit/#/c/59177/ +1 and merge
14:31:06 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63381/
14:32:43 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63372/5
14:32:56 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/topic:transaction-helper
14:34:42 <vorburger> #action vorburger skitt to further discuss https://git.opendaylight.org/gerrit/#/q/topic:transaction-helper
14:35:50 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63120/
14:37:44 <vorburger> #action faseelak edavsua review https://git.opendaylight.org/gerrit/#/c/63120/
14:38:01 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/53998/
14:42:57 <vorburger> #action vorburger add vthapar to upcoming change generalizing the idea from https://git.opendaylight.org/gerrit/#/c/53998/
14:50:10 <vorburger> #topic Sonar Coverage
14:51:03 <vorburger> #action vorburger maybe together with skitt to look at re-enabling InterfaceManagerConfigurationTest
14:51:35 <vorburger> #action ALL look for projects that can be removed, because that will help to drive coverage up ;-)
14:51:42 <vorburger> #topic Cookies
14:51:52 <vorburger> #info No cookies today, only samosas
14:51:54 <vorburger> #endmeeting