14:07:27 <vorburger> #startmeeting genius-weekly
14:07:27 <odl_meetbot> Meeting started Thu Oct  5 14:07:27 2017 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:07:27 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:07:27 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:07:32 <vorburger> #topic /info in
14:07:36 <edavsua> #info edavsua
14:07:42 <viveks> #info viveks
14:07:46 <vorburger> #chair faseelak edavsua skitt viveks
14:07:46 <odl_meetbot> Current chairs: edavsua faseelak skitt viveks vorburger
14:09:03 <faseelak> #info faseelak
14:11:11 <edavsua> #topic Transactions framework
14:13:34 <vorburger> #topic topic Transaction Utility
14:13:35 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63372/
14:14:00 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63372/8/itm/itm-impl/src/main/java/org/opendaylight/genius/itm/confighelpers/ItmTunnelAggregationHelper.java
14:16:12 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63372/8/mdsalutil/mdsalutil-api/src/main/java/org/opendaylight/genius/infra/ManagedNewTransactionRunnerImpl.java
14:20:48 <vorburger> #info viveks raises idea to launch concerted effort to migrate genius to this
14:22:00 <vorburger> #info session at the DDF next week for more discussion about this, and future plans (incl https://git.opendaylight.org/gerrit/#/c/63471/)
14:22:42 <vorburger> #info this utility prevents transaction leaks by automatically submit(), cancel() and close() Txs
14:23:12 <vorburger> #topic FutureRpcResults
14:23:25 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63413/
14:24:06 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63413/9/interfacemanager/interfacemanager-impl/src/main/java/org/opendaylight/genius/interfacemanager/rpcservice/InterfaceManagerRpcService.java
14:28:12 <edavsua> I have to leave
14:28:14 <edavsua> See you
14:28:18 <edavsua> thanks
14:30:07 <vorburger> #info viveks proposes to have a slide about this in the genius oxygen plan side deck
14:30:49 <vorburger> #topic DataBrokerFailures
14:31:29 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63120/
14:31:51 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63121/5
14:32:11 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63121/5/lockmanager/lockmanager-impl/src/test/java/org/opendaylight/genius/lockmanager/tests/LockManagerTest.java
14:35:06 <vorburger> #topic Pending changes ready for merge
14:35:14 <faseelak> link pls
14:35:15 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:35:23 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63323/
14:35:40 <vorburger> #info Hema asks us to wait on this
14:35:59 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63787/
14:37:46 <viveks> https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:40:24 <vorburger> #action viveks to ask Vishal & Muthu to review https://git.opendaylight.org/gerrit/#/c/63787/
14:41:43 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63505/
14:41:57 <vorburger> #action Hema to review https://git.opendaylight.org/gerrit/#/c/63505/
14:42:32 <vorburger> #action faseelak to review https://git.opendaylight.org/gerrit/#/c/63787/
14:42:41 <vorburger> #undo
14:42:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x14d5250>
14:42:59 <vorburger> #action faseelak to review https://git.opendaylight.org/gerrit/#/c/63505/
14:43:11 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63950/
14:43:21 <vorburger> #action Hema to review and just merge https://git.opendaylight.org/gerrit/#/c/63950/
14:43:59 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63481/
14:44:10 <vorburger> #info this one is in carbon, and only in carbon, why?
14:47:13 <vorburger> #action viveks to follow-up on https://git.opendaylight.org/gerrit/#/c/63481/ with reporter (incl. why on carbon only, not nitrogen and master)
14:51:22 <vorburger> #topic David new listener Executor
14:57:18 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/63799/
15:01:39 <vorburger> #topic Documentation for genius
15:02:50 <vorburger> #action EVERYONE let's revive the genius developer guide documentation!
15:11:14 <vorburger> #topic genius master branch state
15:11:45 <vorburger> #info earlier today we broke master, it's fixed now, you need to rebase if you have strange build compliation failures
15:11:48 <vorburger> #endmeeting