14:00:46 <vthapar> #startmeeting Genius Weekly 2017-08-03
14:00:46 <odl_meetbot> Meeting started Thu Aug  3 14:00:46 2017 UTC.  The chair is vthapar. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:00:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:46 <odl_meetbot> The meeting name has been set to 'genius_weekly_2017_08_03'
14:01:37 <vthapar> #topic rollcall and agenda bashing
14:02:42 <vthapar> #info Vishal
14:04:49 <vthapar> #link https://trello.com/c/MJiDOxBz/30-meeting-agenda-2017-08-03 Agenda for today
14:05:32 <edavsua> #info edavsua
14:06:22 <faseelak> #info faseelak
14:07:28 <vthapar> #topic Service Recovery Spec
14:07:38 <vthapar> #link https://git.opendaylight.org/gerrit/58693
14:08:40 <vthapar> #info review commens from faseelak and shague addressed
14:08:53 <vthapar> #info would like this to get merge so code can start coming in
14:09:56 <vthapar> #topic Status Reporting in interfacemanager and ITM
14:10:21 <vthapar> #info way status is reported post blueprint migration is not consistent
14:10:45 <vthapar> #info earlier single provider was managing all listeners so could report overall status
14:11:16 <vthapar> #info with BP each listener is independent so provider doesn't know if it actually came up or not
14:11:47 <vthapar> #info so providers can wrongly post status as Operational to SnD even though listeners are still in progress
14:12:43 <vthapar> #topic patches
14:13:20 <vthapar> #link https://git.opendaylight.org/gerrit/59177 Listener framework
14:15:36 <vthapar> #info some util classes in mdsal are using old controller version of cluster apis, should move to new MDSAL versions
14:15:41 <vthapar> #action edavsua will work on this
14:15:46 <vthapar> #undo
14:15:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2e37b90>
14:15:57 <vthapar> #action edavsua will work on cleanup
14:16:43 <vthapar> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 patches ready for review
14:18:51 <vthapar> #link https://git.opendaylight.org/gerrit/#/c/54426/
14:21:03 <vthapar> #link status:open project:genius branch:master topic:cleanup
14:21:16 <vthapar> #undo
14:21:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2e381d0>
14:21:32 <vthapar> #link https://git.opendaylight.org/gerrit/#/q/status:open+project:genius+branch:master+topic:cleanup
14:21:48 <vthapar> #info cleanup patches to be reviewed and merged, small changes
14:22:15 <vthapar> #link https://git.opendaylight.org/gerrit/#/c/60131/
14:25:59 <vthapar> #link https://git.opendaylight.org/gerrit/#/c/51445/ Basic service binding framework
14:27:31 <vthapar> #action faseelak to set topic branch correctly for service binding framework patches
14:27:37 <vthapar> #topic announcements
14:27:53 <vthapar> #info next week is our code freeze
14:28:01 <vthapar> #topic cookies
14:28:08 <vthapar> #endmeeting