15:09:56 <vorburger> #startmeeting genius-weekly
15:09:56 <odl_meetbot> Meeting started Thu Mar  1 15:09:56 2018 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:09:56 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:09:56 <odl_meetbot> The meeting name has been set to 'genius_weekly'
15:10:07 <vorburger> #topic Roll Call, everyone #info in please
15:10:13 <faseelak> #info faseelak
15:10:15 <vorburger> #info vorburger
15:10:16 <Hema> #info Hema
15:10:25 <vpickard> #info vpickard
15:10:35 <shague> #info shague
15:10:39 <vthapar> #info vthapar
15:11:35 <vorburger> #topic Agenda today?
15:11:41 <vorburger> #info Release Blockers status
15:11:53 <shague> #link https://jira.opendaylight.org/issues/?filter=10206
15:11:58 <vorburger> #info ConcurrentHashMap, Genius' use of infrautils.caches
15:12:04 <vorburger> #info Gerrit reviews
15:12:22 <vorburger> #topic Release Blockers status
15:12:43 <vorburger> #link https://jira.opendaylight.org/issues/?filter=10206
15:13:06 <vthapar> #info GENSIUS-116 fix is ready, need to merge and cherry pick to oxygen
15:13:09 <vorburger> #link https://jira.opendaylight.org/browse/GENIUS-116
15:13:27 <vthapar> #link https://jira.opendaylight.org/browse/GENIUS-116
15:13:42 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68794/ ready for merge to
15:13:42 <vorburger> stable/oxygen
15:13:46 <vorburger> #undo
15:13:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x29ca290>
15:14:02 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68794/ ready for merge to stable/oxygen
15:14:50 <vorburger> #info vorburger has added comment "[~klou] https://git.opendaylight.org/gerrit/#/c/68794/ is cherry-picked and +2 ready for merge to Oxygen..."
15:15:02 <vorburger> #action shague will reach out to Kit Lou to get that merged
15:15:17 <vorburger> #link https://jira.opendaylight.org/browse/GENIUS-115
15:17:54 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68797/
15:18:07 <vorburger> #action Hema will email Josh to confirm that patch is the one to go in
15:21:34 <shague> #link https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=592032762 oxygen tracking sheet
15:22:34 <shague> #info add blockers bugs to the sheet and update the status. klou will approve the gerrits for merge and then the releng team will merge
15:28:20 <vorburger> #topic Concurrent delete and write
15:28:44 <vorburger> #info long discussion re. transactional questions
15:29:17 <vorburger> #topic Tom's HWTEP cache
15:29:50 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/66789/
15:33:27 <vorburger> #action tpantelis to rebase https://git.opendaylight.org/gerrit/#/c/66789/
15:33:37 <vorburger> #action vorburger to re-review and hopefully merge https://git.opendaylight.org/gerrit/#/c/66789/
15:36:26 <vorburger> #topic Edwin's immutables for performance enhancements
15:36:32 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68524/
15:36:51 <vorburger> #link http://immutables.github.io
15:37:50 <vorburger> #action vorburger to pull that change and try to help Edwin
15:38:08 <vorburger> #topic Gerrit reviews
15:38:14 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
15:38:51 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68170/
15:39:56 <vorburger> #info faseela suspects this rename of RPC would break netvirt
15:40:14 <vorburger> #action Hema to review and +1 or -1 https://git.opendaylight.org/gerrit/#/c/68170/
15:41:41 <vorburger> #topic Victor's 3 auto TZ related changes for carbon
15:42:11 <vorburger> #action faseela will reach out to vpickard to sync with Vivek if this is OK for carbon
15:43:17 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68947/
15:43:22 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/68952/
15:44:48 <vorburger> #topic ConcurrentHashMap, Genius' use of infrautils.caches
15:45:08 <vorburger> #info Vishal is asking what the recommendation re. static ConcurrentHashMap is now
15:45:30 <vorburger> #info vorburger is clarifying that we don't want "static" fields anywhere for anything, not just ConcurrentHashMap
15:45:58 <vorburger> #info you can use the infrautils.caches instead of ConcurrentHashMap if you want monitoring and evicition, ottherwise a (non-static) ConcurrentHashMap is fine
15:46:51 <vorburger> #action vishal interested in contributing a fix in infrautils to remove the current default hard-coded cache size, and instead introduce a mandatory cache size set by code (may be in 2 stages); vorburger is all for that
15:46:55 <vorburger> #endmeeting