14:02:11 <vorburger> #startmeeting genius-weekly
14:02:11 <odl_meetbot> Meeting started Thu Jun 14 14:02:11 2018 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:02:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:11 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:02:29 <vorburger> #topic Who's here?
14:02:34 <vthapar_> #info Vishal
14:02:35 <vorburger> #info vorburger
14:02:36 <jhershbe> oh, vthapar_, one more thing....
14:02:42 <vorburger> #info Hema
14:02:46 <vorburger> #info edwin
14:02:54 <vorburger> #topic Gerrit reviews
14:03:02 <Hema> vorburger ,I do not have anything specific to discuss
14:03:05 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:03:23 <jhershbe> vthapar_, I want to add scripts that will make it easy to run ofproto/trace with "one touch" commands for arps and pings.
14:03:27 <vorburger> Hema: can you hear me talking on the Zoom?
14:03:34 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/70724/
14:03:36 <vthapar_> vorburger, I can. even hear you type.
14:04:13 <vorburger> Hema: vthapar_ will you review https://git.opendaylight.org/gerrit/#/c/70724/ ?
14:04:43 <vorburger> #action Hema review https://git.opendaylight.org/gerrit/#/c/70724/
14:04:44 <vthapar_> vorburger, sure, this should be easy as is based on a spec.
14:04:51 <vorburger> #action vthapar_ review https://git.opendaylight.org/gerrit/#/c/70724/
14:05:13 <vorburger> vthapar_: based on the earlier chat here on IRC, is https://git.opendaylight.org/gerrit/#/c/72993/ OK with you? +1 or even +2 and merge it?
14:05:25 <Hema> I wasnt added, so having a look at it now
14:05:38 <vorburger> Hema: thanks!
14:06:00 <vorburger> #action vthapar_ to review https://git.opendaylight.org/gerrit/#/c/72993/ (Faseela already +1)
14:06:09 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/72712/
14:06:25 <vthapar_> #done
14:06:41 <vorburger> what do you guys want to do about this c/72712 Genius-130: Test plan for OF-Tunnels; what's the next step here?
14:06:42 <Hema> vthapar ,should we also get some netvirt guys to review 70724 ?
14:07:37 <vthapar_> Hema, I think 70724 is just based off spec which is already reviewed. as long as change conforms to spec, we can merge, else get netvirt reviewers who gave +1/+2 on spec
14:08:44 <vorburger> #info vorburger loves these quiet meetings where nobody talks on Zoom and we just chat on IRC ;-)
14:08:50 <Hema> vthapar, since I haven't looked at the spec, so cant say much...just from the code is fine...but netvirt guys are the best to comment
14:09:05 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/72972/
14:09:33 <vorburger> #action faseela to update after ongoing review in master is concluded (thanks pantelis_)
14:09:44 <Hema> vorburger, yes...+1 for quite meetings
14:09:44 <vorburger> #info pantelis_ also in meeting now
14:10:04 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/72702/
14:10:42 <vorburger> pantelis_: Hema: skitt: could I suggest you review this one (https://git.opendaylight.org/gerrit/#/c/72702/) as well?
14:11:26 <Hema> vorburger ,need sometime for 72712 -- Test spec
14:11:31 <vorburger> I think we are done with gerrit reviews, does anyone have anything else'
14:11:53 <vorburger> Hema: OK, sure; just trying to make sure we don't forget
14:12:07 <vorburger> #topic Any other business than Gerrit reviews?
14:12:36 <vthapar_> #info jhershbe sent a mail on running ODL in cluster in dev environment
14:13:10 <vorburger> #link https://lists.opendaylight.org/pipermail/genius-dev/2018-June/003046.html
14:13:10 <vthapar_> currently it doesn't support Genius, am working on changes to make it work for Genius too. aim is devs will use it when developing newer features to make sure they work in cluster setup.
14:13:23 <vorburger> #link https://github.com/jhershberg/netvirt-ha-docker
14:13:33 <vorburger> #info it's #great #stuff
14:13:36 <vorburger> vthapar_: cool, thanks
14:13:40 <vthapar_> so far we've seen things work great in single node, 3 node is where real issues show up. no customer is going to use 1node, so might as well focus on 3node from start.
14:14:32 <Hema> vorburger, done with 72702 ...looks fine
14:14:39 <pantelis_> has anyone been able to test https://git.opendaylight.org/gerrit/#/c/72874/ with genius?
14:14:53 <vorburger> Hema: thanks
14:15:11 <edw7n> vthapar_/michael: is there a document or a go through procedure to install netvirt csit on a plain ol' server ?
14:15:48 <vorburger> pantelis_:  not that I know, no - would you like to get a genius CSIT running with that? There is a keyword...
14:16:41 <vorburger> edw7n: as about that on the netvirt-dev list or weekly meeting? ;-) I know we documentation, somewhere (from Faseela) about how to run the genius CSIT locally, but you are asking for netvirt
14:16:41 <edw7n> michael: we want to try running downstream distribution against the same CSIT, for local testing per se
14:17:10 <edw7n> vorburger: touche
14:17:22 <vorburger> edw7n: that seems like a great idea!
14:17:54 <vorburger> edw7n: shague and Jamo could probably help how to get netvirt CSIT running locally
14:18:54 <edw7n> cool, thanks. Will email them for the same :)
14:19:05 <edw7n> Michael ^
14:19:31 <vorburger> #info vorburger looking over https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10406, and putting JIRAs which actually having proposed Gerrits to In Progress
14:19:44 <vthapar_> edw7n, janki wrote a blog and sent mail on netvirt-dev on how to run netvirt csit locally on a server.
14:20:27 <vthapar_> edw7n, https://simplyexplainedblog.wordpress.com/2017/04/11/running-odl-csit-locally/
14:20:37 <vorburger> pantelis_: re. https://git.opendaylight.org/gerrit/#/c/72874/ would you like to get a genius CSIT running with that?
14:20:47 <edw7n> vthapar: thanks, will revert if I get stuck.
14:21:04 <vorburger> guys any other business? Meeting done?
14:21:22 <pantelis_> that's it for me
14:21:23 <Hema> vorburger, nothing from my end
14:21:33 <vthapar_> nothing from me.
14:21:57 <vorburger> pantelis_: is https://git.opendaylight.org/gerrit/#/c/72874/ the fix for https://jira.opendaylight.org/browse/GENIUS-166 ? I haven't followed much, just trying to link
14:22:06 <vorburger> OK then we'll wrap this up...
14:22:55 <vorburger> #endmeeting