14:01:32 <vorburger> #startmeeting genius-weekly
14:01:32 <odl_meetbot> Meeting started Thu Aug 30 14:01:32 2018 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:32 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:01:59 <vorburger> HemaG: vthapar: let's wait 2-3 minutes to see if more are going to join?
14:02:17 <vthapar> vorburger, ack
14:02:23 <HemaG> vorburger, ok
14:02:28 <HemaG> #info Hema
14:02:32 <vthapar> #info Vishal
14:03:32 <HemaG> vorburger, shall we start?
14:06:26 <vorburger> HemaG: let's do it
14:06:46 <vorburger> can you hear me on Zoom?
14:06:55 <HemaG> vorburger, yes
14:07:49 <vorburger> #topic Josh's Add dp-id to ARP notifications
14:07:54 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/75248/
14:08:48 <vorburger> #action HemaG if this change c/75248 is OK for you, will you +1 it
14:09:00 <skitt> vorburger, we can hear you but you appear not to hear anyone
14:09:03 <HemaG> vorburger, can you hear us
14:09:15 <vorburger> no
14:09:15 <HemaG> vorburer, we all can hear each other
14:09:28 <vthapar> vorburger, looks like you're only one not able to hear anyone
14:10:29 <vorburger> #topic GENIUS-207 UpgradeUtils OptimisticLockFailedException c/75535
14:11:08 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/75535/
14:14:23 <HemaG> #action vorburger to update
14:14:31 <vorburger> #action vorburger will update this change based on TomP's feedback, and HemaG and vthapar will review it
14:14:50 <vorburger> #topic ManagedNewTransactionRunner improvements from Stephen
14:15:00 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/75348/
14:15:05 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/75543/
14:16:56 <vorburger> #info skitt gives an overview and explanation of these enhancements
14:31:01 <vorburger> #action HemaG vthapar to review these as well, vorburger and skitt want to get them merged in soon-ish
14:34:15 <vorburger> #info where to capture the kind of best practices that came up in this discussion? MD SAL developer guide in docs/
14:36:31 <vorburger> #action vorburger to try to make a contribution to "MD SAL Developer guide" (if that even exists..) re. TomP's feedback about clustered listeners, and create at a least new Wiki if hard to contribute to docs
14:37:32 <vorburger> #topic HemaG asking for thoughts on observation in CSIT re. DataObjectCache
14:37:55 <vorburger> #info DTCL fired before Cache?
14:40:11 <vorburger> #action HemaG to post to genius-dev with more details about these listeners
14:44:34 <vorburger> #topic Pending Gerrit reviews
14:44:38 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:44:52 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/74909/
14:45:46 <vorburger> #action HemaG to either run CSIT and merge or merge right away
14:46:06 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/75272/
14:47:23 <vorburger> #info HemaG is actively working on this, it's WIP. Discussion if -1 prevents CSIT, but should not.
14:47:34 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/74842/
14:48:44 <vorburger> #action HemaG to add more reviewers before merging it
14:48:58 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/74843/
14:50:00 <vorburger> #action HemaG to see if that was just a temporary test that needs to be -1 or merged
14:50:33 <vorburger> #topic Very old Gerrits
14:50:36 <vorburger> #link #link https://wiki.opendaylight.org/view/Genius:Main
14:50:41 <vorburger> #link https://git.opendaylight.org/gerrit/#/dashboard/?title=Genius+abandonment+review&Send+email+warning+due+to+3+weeks+inaction=project:genius+status:open+age:21d+-age:31d&Close+due+to+4+weeks+inaction=project:genius+status:open+age:31d
14:52:19 <vorburger> #action vorburger to send an email to genius-dev
14:52:49 <vorburger> #endmeeting