14:05:57 <vorburger> #startmeeting genius-weekly
14:05:57 <odl_meetbot> Meeting started Thu Oct 11 14:05:57 2018 UTC.  The chair is vorburger. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:05:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:57 <odl_meetbot> The meeting name has been set to 'genius_weekly'
14:06:06 <vorburger> #topic Info in
14:06:26 <vorburger> #info low attendance today, Hema sent her apologies by email, vthapar sick
14:07:07 <vorburger> #info Karthika
14:07:13 <vorburger> #info Nidhi
14:07:43 <shague> #info shague
14:07:48 <vorburger> #topic Pending Gerrits review
14:07:57 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:08:35 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/72462/
14:10:21 <vorburger> #action Hema see, or check with Faseela if needed, re the -2 on https://git.opendaylight.org/gerrit/#/c/72063/ which still has a test failure
14:11:32 <vorburger> #info Hi Nishchya, before we consider merging this to Oxygen, could you get https://git.opendaylight.org/gerrit/#/c/72462/ on master to pass (it still has a test failure) and get Faseela to remove her -2 there?  Then we can look at this for Oxygen.  It will also need a cherry-pick to Fluorine.
14:11:43 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/76727/
14:12:23 <vorburger> #info this is fluorine back patch of something which shague has merged into master 3 days ago
14:12:49 <vorburger> #action shague will handle this one
14:12:57 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/76729/
14:13:41 <vorburger> #info this goes together with the previous one, shague will merge when ready with netvirt
14:14:19 <vorburger> #topic OpenDaylight-SIMPLE
14:14:38 <vorburger> #link https://github.com/vorburger/opendaylight-simple
14:19:34 <vorburger> #info vorburger is about to have restconf working (hopefully), FYI skitt
14:19:51 <skitt> vorburger, cool, I'm working on SSH
14:20:01 <vorburger> #info shague and vorburger discuss next steps, and agree we'll need to go: ovsdb -> openflowplugin -> genius -> netvirt
14:20:38 <vorburger> skitt: if you want to have a go at reading ovsdb BP XML and writing some *Wiring for that in opendaylight-simple while I'm on PTO next 2 weeks, shague volunteers to CSIT ovsdb with simple ;-)
14:23:07 <vorburger> #link https://github.com/vorburger/opendaylight-simple/issues/33
14:25:23 <vorburger> #link https://github.com/vorburger/opendaylight-simple/issues/46
14:29:28 <vorburger> #link https://github.com/vorburger/opendaylight-simple/issues/47
14:32:24 <vthapar> vorburger, just reading through, we'll also want neutron at some point between ovsdb and netvirt.
14:36:26 <vorburger> #info vthapar points out that we would do: ovsdb -> neutron -> openflowplugin -> genius -> netvirt
14:38:34 <vorburger> #info discussion about how vthapar shague and others could help skitt and vorburger more actively on opendaylight-simple
14:38:56 <vorburger> #link https://wiki.opendaylight.org/view/BestPractices/DI_Guidelines
14:39:15 <vorburger> #info blueprint-maven-plugin
14:40:58 <vorburger> #info has this already been done for osdb? no see this linkK
14:41:02 <vorburger> #link https://github.com/opendaylight/ovsdb/search?q=%40Singleton&unscoped_q=%40Singleton
14:42:03 <vorburger> #info please use topic "simple-dist" for any work related to this
14:45:36 <vorburger> #topic odltools
14:45:45 <vorburger> #info vthapar and shague discussing improvements
14:46:10 <vorburger> vthapar: shague: can you minute anything you can to be part of the genius weekly minutes of your discussion? I'm not following odltools much.
14:50:53 <vorburger> #endmeeting