#opendaylight-genius: genius-weekly

Meeting started by vorburger at 15:00:59 UTC (full logs).

Meeting summary

  1. Attendees info in (vorburger, 15:01:05)
    1. vthapar vorburger Hema Edwin Faseela Karthika (vorburger, 15:03:30)

  2. Build status (vorburger, 15:03:45)
    1. build situation is worrying people (vorburger, 15:04:02)
    2. faseelak (faseelak, 15:04:34)
    3. https://jira.linuxfoundation.org/browse/RELENG-1215 (vorburger, 15:04:38)

  3. Gerrit reviews (vorburger, 15:04:59)
    1. https://git.opendaylight.org/gerrit/#/c/77605/ (vorburger, 15:05:44)
    2. ACTION: vthapar to review this spec, requested by Hema (vorburger, 15:05:59)
    3. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/genius-rtd-verify-neon/12/html/specs/itm-yang-cleanup.html (vthapar, 15:06:07)
    4. ACTION: Chintan, call out in the spec - impact of Yang clean up on CSIT, ODL Tools (Hema, 15:09:42)
    5. a TSC JIRA for the weather item has to be created (faseelak, 15:10:27)
    6. SFC may be impacted by this, someone will have to handle this ... code changes and CSIT (vorburger, 15:10:41)
    7. impacts to sfc also has to be identified (faseelak, 15:10:42)
    8. the changes which will be made based on the spec from c/77605 will have to run through "full" (incl. CSIT) multipatch to ensure we don't break autorelease (vorburger, 15:12:12)
    9. Hema is looking into the failures for Karthika's CSIT run (faseelak, 15:14:01)
    10. Shankar is working on auto-tunels CSIT suite (faseelak, 15:14:14)
    11. Hema and Tarun to help on the failures faced (faseelak, 15:14:32)

  4. Gerrit reviews (vorburger, 15:16:48)
    1. https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0 (vorburger, 15:16:59)
    2. https://git.opendaylight.org/gerrit/#/c/77584/ is merge (vorburger, 15:17:29)
    3. https://git.opendaylight.org/gerrit/#/c/77369/ (vorburger, 15:17:43)
    4. ACTION: vorburger to have a closer look, but seems curious to just suppress a ReadFailedException (will may be ask Tom for input as well) (vorburger, 15:20:28)
    5. https://git.opendaylight.org/gerrit/#/c/76982/ (vorburger, 15:20:39)
    6. ACTION: edwin to self -1 his https://git.opendaylight.org/gerrit/#/c/76982/ due to WIP (vorburger, 15:22:00)
    7. https://git.opendaylight.org/gerrit/#/c/77668/ (vorburger, 15:22:13)
    8. https://git.opendaylight.org/gerrit/#/q/topic:ipv6_mtu_support+(status:open+OR+status:merged) (vorburger, 15:23:32)
    9. ACTION: vorburger to reach out to Sridhar to understand if these 3 need a "simu merge" or can go in separately (vorburger, 15:24:05)
    10. ACTION: faseelak to talk to Kiran and other people at E// who were involved in IPv6 to ask them to review ASAP (vorburger, 15:25:56)
    11. ACTION: vthapar to run a multipatch on topic ipv6_mtu_support (vorburger, 15:28:25)
    12. https://git.opendaylight.org/gerrit/#/c/72837/ (vorburger, 15:28:57)
    13. https://git.opendaylight.org/gerrit/#/c/77953/ (vorburger, 15:29:39)
    14. ACTION: faseelak has added Ankit as a reviewer and will ask him to have a look (vorburger, 15:31:02)
    15. https://git.opendaylight.org/gerrit/#/c/77956/ (vorburger, 15:31:22)
    16. ACTION: vorburger to review https://git.opendaylight.org/gerrit/#/c/77956/ and merge (vorburger, 15:32:20)
    17. https://git.opendaylight.org/gerrit/#/c/77774/ (vorburger, 15:32:32)
    18. https://git.opendaylight.org/gerrit/#/c/77774/ merged (vorburger, 15:33:08)
    19. https://git.opendaylight.org/gerrit/#/c/77954/ (vorburger, 15:33:32)
    20. ACTION: faseelak has added Ankit as a reviewer and will ask him to have a look at both /c/77954/ and c/77953/ (vorburger, 15:34:19)
    21. https://git.opendaylight.org/gerrit/#/c/77912/ (vorburger, 15:35:47)
    22. we would like to see a passing netvirt CSIT on c/77912 before merging it, based on Tom's +1 (we don't have to wait for Dhiman to +1) (vorburger, 15:38:19)
    23. ACTION: vthapar to run make sure CSIT runs on https://git.opendaylight.org/gerrit/#/c/77912/ (vorburger, 15:38:47)
    24. ACTION: 77912 has just 2 failures, which are known and on going ones (vthapar, 15:40:57)
    25. merged https://git.opendaylight.org/gerrit/#/c/77912/ (vorburger, 15:41:52)
    26. https://git.opendaylight.org/gerrit/#/c/77955/ (vorburger, 15:42:09)
    27. vthapar reports 77955 also has just 2 failures, which are known and on going ones, just like 77912 (vorburger, 15:43:20)


Meeting ended at 15:46:52 UTC (full logs).

Action items

  1. vthapar to review this spec, requested by Hema
  2. Chintan, call out in the spec - impact of Yang clean up on CSIT, ODL Tools
  3. vorburger to have a closer look, but seems curious to just suppress a ReadFailedException (will may be ask Tom for input as well)
  4. edwin to self -1 his https://git.opendaylight.org/gerrit/#/c/76982/ due to WIP
  5. vorburger to reach out to Sridhar to understand if these 3 need a "simu merge" or can go in separately
  6. faseelak to talk to Kiran and other people at E// who were involved in IPv6 to ask them to review ASAP
  7. vthapar to run a multipatch on topic ipv6_mtu_support
  8. faseelak has added Ankit as a reviewer and will ask him to have a look
  9. vorburger to review https://git.opendaylight.org/gerrit/#/c/77956/ and merge
  10. faseelak has added Ankit as a reviewer and will ask him to have a look at both /c/77954/ and c/77953/
  11. vthapar to run make sure CSIT runs on https://git.opendaylight.org/gerrit/#/c/77912/
  12. 77912 has just 2 failures, which are known and on going ones


Action items, by person

  1. faseelak
    1. faseelak to talk to Kiran and other people at E// who were involved in IPv6 to ask them to review ASAP
    2. faseelak has added Ankit as a reviewer and will ask him to have a look
    3. faseelak has added Ankit as a reviewer and will ask him to have a look at both /c/77954/ and c/77953/
  2. Hema
    1. vthapar to review this spec, requested by Hema
  3. vorburger
    1. vorburger to have a closer look, but seems curious to just suppress a ReadFailedException (will may be ask Tom for input as well)
    2. vorburger to reach out to Sridhar to understand if these 3 need a "simu merge" or can go in separately
    3. vorburger to review https://git.opendaylight.org/gerrit/#/c/77956/ and merge
  4. vthapar
    1. vthapar to review this spec, requested by Hema
    2. vthapar to run a multipatch on topic ipv6_mtu_support
    3. vthapar to run make sure CSIT runs on https://git.opendaylight.org/gerrit/#/c/77912/
  5. UNASSIGNED
    1. Chintan, call out in the spec - impact of Yang clean up on CSIT, ODL Tools
    2. edwin to self -1 his https://git.opendaylight.org/gerrit/#/c/76982/ due to WIP
    3. 77912 has just 2 failures, which are known and on going ones


People present (lines said)

  1. vorburger (43)
  2. faseelak (8)
  3. odl_meetbot (4)
  4. vthapar (2)
  5. Hema (1)
  6. edw7n (1)


Generated by MeetBot 0.1.4.