14:01:23 <faseelak> #startmeeting Genius Weekly 10/25/2018
14:01:23 <odl_meetbot> Meeting started Thu Oct 25 14:01:23 2018 UTC.  The chair is faseelak. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:23 <odl_meetbot> The meeting name has been set to 'genius_weekly_10_25_2018'
14:01:30 <faseelak> #chair vthapar
14:01:30 <odl_meetbot> Current chairs: faseelak vthapar
14:01:45 <faseelak> #topic Roll call and agenda bashing (please #info <your-nick>)
14:02:01 <faseelak> #link https://jira.opendaylight.org/browse/GENIUS-217
14:04:11 <vthapar> #info Vishal
14:04:24 <shague> faseelak: I am doublebooked on a different meeting, but will be watching thsi channel so please call out anything for me
14:05:40 <faseelak> shague, sure!
14:06:30 <faseelak> #topic Neon MRI Bump
14:06:59 <faseelak> #info vthapar has pushed patches for genius
14:07:18 <faseelak> #info multi patch for genius looks good
14:07:22 <vthapar> #link https://git.opendaylight.org/gerrit/76414
14:07:35 <faseelak> #topic ITM Direct Tunnels Bug
14:08:03 <faseelak> #info Tarun and Nishchaya debugging the issue and working on a fix
14:08:57 <faseelak> #info Tarun updates the CSIT randomly fails for netvirt, and in such cases default tzone is not created
14:09:26 <faseelak> #info Tarun says the recently merged patch on ITM auto tunnels causing this
14:11:11 <faseelak> #info faseelak asks for the patch link for the merged one
14:12:09 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/76201/
14:12:30 <faseelak> #info faseelak says it is better to revert the patch, so that others are unblocked
14:12:38 <faseelak> #info Edwin has a patch for the revert
14:12:49 <faseelak> #link  https://git.opendaylight.org/gerrit/#/c/77162/
14:13:33 <faseelak> #topic Discussion on EntityOwnershipUtils
14:13:51 <faseelak> #info Tarun says there is an issue the current implementation of EntityOwnershipUtils
14:15:21 <faseelak> #info Tarun says in case of an InterruptedException, EntityOwnershipUtils won't proceed with isEntityOwner check
14:15:47 <faseelak> #info vthapar says such a chance is very unlikely and that cannot be the cause for the ITM Auto tunnels issue
14:17:09 <vthapar> #info more like, why is eos status not available.
14:23:20 <faseelak> #info vthapar gives inputs on how to handle entity ownership registration in a proper way, Tarun to try that out
14:23:43 <faseelak> #action vthapar faseelak to review the initial patch to see what is wrong in the implementation
14:25:19 <faseelak> #topic Updated Genius Dashboard
14:25:25 <faseelak> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10406
14:26:34 <faseelak> #info faseelak has updated the dashboard to include Release checkpoints and Genius meetings
14:26:50 <faseelak> #info thanks to shague for the help :)
14:27:21 <faseelak> #topic Genius HA Tests
14:27:28 <faseelak> #info Karthika working on HA Tests for Genius
14:27:39 <faseelak> #info needs help on triaging one issue seen, faseelak to help
14:30:12 <shague> for genius HA tests, is any of this feeding into the ODL clustering effort? Recall we had taks like checking for valid tests and then making sure the tests are stable
14:31:24 <vthapar> shague, we're seeing failure in single node too. it is more an issue with a patch that recently came in. we've identified the root cause and have told tarun on how to go about fixing it.
14:32:52 <vthapar> shague, never mind, missed the context of your comment. yes, we need to tie it back into clustering effort. currently genius 3 node tests are not really HA tests and that is what karthika is addressing.
14:33:18 <vthapar> shague, since these are new tests so as part of tests review we will check their validity too.
14:33:27 <vthapar> #topic cookies
14:33:30 <vthapar> #endmeeting