15:00:47 <faseelak> #startmeeting Genius Weekly 12/13/18
15:00:47 <odl_meetbot> Meeting started Thu Dec 13 15:00:47 2018 UTC.  The chair is faseelak. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:47 <odl_meetbot> The meeting name has been set to 'genius_weekly_12_13_18'
15:01:16 <faseelak> #topic Roll call and agenda bashing (please #info <your-nick>)
15:01:24 <vorburger> #info vorburger
15:01:28 <faseelak> #link https://jira.opendaylight.org/browse/GENIUS-256
15:01:33 <vthapar> #info Vishal
15:01:39 <vorburger> just got off previous meeting and joining
15:02:01 <faseelak> #chair vthapar vorburger
15:02:01 <odl_meetbot> Current chairs: faseelak vorburger vthapar
15:03:05 <faseelak> #topic networkutils module
15:05:44 <faseelak> #info vni utils need to be moved to a common place
15:06:16 <faseelak> #info currently it is tied to NAT module, hence moving to genius in networkutils module
15:06:31 <faseelak> #info vthapar says it is better to make it genric than tying it to vni
15:06:42 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78319/
15:06:54 <faseelak> #topic ITM AutoTunnels suite
15:07:04 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/77783/
15:08:33 <faseelak> #info vthapar asks whether we can disable BFD by default
15:08:58 <faseelak> #info Hema updates apps are not even reacting to BFD status, so it makes sense to disable this by default
15:09:28 <faseelak> #info vthapar says odltools has check to see if all tunnels are UP, and looks like sometimes it fails as tunnels are taking too long to come up
15:10:15 <faseelak> #info faseelak asks whether we need a weather item for this
15:11:15 <faseelak> #info vthapar says we can disable this in netvirt CSIT, so that sfc is not impacted
15:12:23 <faseelak> #topic ITM JIRAs : GENIUS-245
15:14:11 <faseelak> #action faseelak to reachout to Brady to see if sfc will be impacted if we change the default for tunnel monitoring
15:14:51 <faseelak> #info Karthika has sent an email sometimes VMs are getting IPs which are not falling in /24 causing ITM test cases to fai
15:14:53 <faseelak> fai
15:15:18 <faseelak> #info vthapar says genius CSIT needs to be enhanced to accomodate such changes by moving /8 prefix
15:15:33 <faseelak> #action Karthika to do the required changes in genius CSIT
15:15:51 <faseelak> #topic stale cache entries in IFM
15:18:13 <faseelak> #info proper synchronization is not there in the way the concurrenthashmaps in interfacemanager/itm are populated
15:18:25 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78750/
15:19:51 <faseelak> #topic remove resourcemanager from odl-genius feature
15:20:04 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78746/
15:23:25 <vorburger> #topic Gerrit reviews
15:23:26 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
15:24:11 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/78014/
15:24:28 <faseelak> #action Hema to review the above patch
15:25:01 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78056/
15:25:17 <faseelak> #info Ankit has a +1 and would be good to merge
15:26:26 <vorburger> #action vorburger to react to https://git.opendaylight.org/gerrit/#/c/78055/
15:28:21 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78649/ yangtools bump patch on fluorine
15:29:20 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78371/ Drop null to Empty
15:30:16 <faseelak> #action vorburger to review the above patch
15:30:49 <vorburger> #info build failures on other changes on the yangtools bump patch on fluorine, so we'll wait re. https://git.opendaylight.org/gerrit/#/c/78649
15:31:00 <faseelak> #link https://git.opendaylight.org/gerrit/#/c/78749/
15:31:20 <faseelak> #info follow-up patch for Michael's TestMdsalapiManager patch, michael to review it
15:33:08 <faseelak> #endmeeting