14:03:18 <faseelak> #startmeeting GeniusWeekly-08/02/2018
14:03:18 <odl_meetbot> Meeting started Thu Aug  2 14:03:18 2018 UTC.  The chair is faseelak. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:03:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:18 <odl_meetbot> The meeting name has been set to 'geniusweekly_08_02_2018'
14:03:24 <vorburger> shague: did you want to join the genius weekly ?
14:03:32 <faseelak> #chair vorburger vthapar
14:03:32 <odl_meetbot> Current chairs: faseelak vorburger vthapar
14:04:02 <faseelak> #topic Move ManagedTransactionRunner to MDSAL
14:04:42 <faseelak> #info Stephen working with tom to get this into MDSAL for Neon
14:05:11 <faseelak> #info vorburger says there will be some changes to the API once it is migrated to MDSAL
14:05:39 <faseelak> #info assumption that MDSAL committers wont have major objection to take it to MDSAL
14:06:23 <faseelak> #topic Make Genius CSIT fail on new exceptions introduced
14:06:42 <vorburger> #link https://jira.opendaylight.org/browse/GENIUS-200
14:06:59 <faseelak> #info faseelak asks vthapar on how netvirt CSIT does the exception scanning in karaf log
14:07:12 <faseelak> #info shague says he did that for netvirt CSIT, and it is quite easy to do
14:07:25 <faseelak> #info vthapar says he can see how to get it done for genius CSIT
14:09:20 <faseelak> #topic Convert all of genius to managed transactions
14:09:32 <faseelak> #link https://jira.opendaylight.org/browse/GENIUS-176
14:11:41 <faseelak> #info most of the modules are already converted
14:12:03 <faseelak> #info edwin had question on the mdsalutil api changes when GENIUS-176 is incorporated
14:13:02 <faseelak> #info faseelak comments it is better to do it on Neon, as this introduces API changes
14:13:56 <faseelak> #info vorburger says let us keep working, and then cherry-pick if needed later to Fluorine
14:14:07 <vorburger> #link https://lists.opendaylight.org/pipermail/genius-dev/2018-August/003220.html
14:17:06 <faseelak> #topic BugScrub
14:17:47 <faseelak> #link https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10406
14:21:12 <faseelak> #info shague asks whether there is an easy tool to debug the ping failures in netvirt csit
14:21:32 <faseelak> #info vthapar says this needs to be integrated to odltools, and josh is working on some tool like this
14:27:57 <faseelak> #info faseelak says she can work on adding a wiki explaining the l2 pipeline
14:32:36 <vorburger> #topic Open Gerrits
14:32:38 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:33:11 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/72712/ not going to be merged yet as that a Neon topic; faseelak will -1 it
14:34:08 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/69190/ CSIT is still failing...
14:34:20 <odp-gerritbot> Faseela K proposed a change to genius: Upgrade support for ItmDirectTunnels  https://git.opendaylight.org/gerrit/69190
14:34:27 <vorburger> #action Hema to chase why this is still failing CSIT
14:35:09 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/74760/ for https://jira.opendaylight.org/browse/GENIUS-195
14:35:19 <odp-gerritbot> A change was merged to genius: GENIUS-195: Transport Zone default-transport-zone has no subnets  https://git.opendaylight.org/gerrit/74760
14:35:25 <odp-gerritbot> Faseela K proposed a change to genius: GENIUS-195: Transport Zone default-transport-zone has no subnets  https://git.opendaylight.org/gerrit/74768
14:38:18 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/74602/
14:41:05 <vorburger> #topic JIRA Management
14:41:59 <vorburger> #action vorburger create new Oxygen-SR4 target version, and move 3 unresolved issue on SR3 which missed the boat to SR4 (or close): GENIUS-179, GENIUS-167, GENIUS-161
14:42:49 <faseelak> #endmeeting