14:05:27 <faseelak> #startmeeting Weekly_Meeting_04_12
14:05:27 <odl_meetbot> Meeting started Thu Apr 12 14:05:27 2018 UTC.  The chair is faseelak. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:05:27 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:27 <odl_meetbot> The meeting name has been set to 'weekly_meeting_04_12'
14:05:50 <Hema> #info Hema
14:06:01 <vorburger> #info vorburger
14:07:38 <faseelak> #topic fluorine topics
14:07:51 <faseelak> #info any new features should have a spec uploaded before may 8th
14:08:34 <vorburger> #link https://wiki.opendaylight.org/view/Genius:Main
14:08:43 <vorburger> #link https://git.opendaylight.org/gerrit/#/q/project:genius+status:open+Verified%253E0+is:mergeable+NOT+label:Code-Review%253C0
14:08:43 <faseelak> #topic pending code reviews
14:10:35 <faseelak> #info Tarun's patches for auto-tunnels merged
14:11:26 <faseelak> #info Michael's patch to remove it-parent
14:11:53 <vorburger> #topic SFT time-outs
14:11:57 <faseelak> #topic SFT timeouts
14:12:16 <faseelak> #info vorburger says it is a global issue, not specific to genius
14:12:24 <vorburger> #link https://jira.opendaylight.org/browse/ODLPARENT-148
14:12:56 <faseelak> #info might be an issue due to the inter project dependencies defined as bundles and not using features
14:15:50 <faseelak> #info stable/oxygen builds are broken
14:16:54 <faseelak> #info faseela asked whether this change in odlparent requires a version bump up
14:17:22 <faseelak> #topic genius-tools migration
14:17:51 <faseelak> #info faseelak has migrated sfc, genius and netvirt to the new tools
14:18:03 <faseelak> #info planning to remove the older base classes
14:18:56 <faseelak> #topic itm-scalability patches
14:19:20 <faseelak> #info Hema indicated that they are working on pending patches, addressing review comments
14:20:02 <faseelak> #topic usage of ManagedTransactionRunnerImpl
14:20:31 <faseelak> #info vorburger said it would be great if more people can pitch in for the migration, so that we can get rid of the transaction leaks
14:21:16 <faseelak> #info skitt working on a utility to throw checktyle errors, for the usage of dataBroker.newReadWriteTransaction()
14:22:37 <faseelak> #info skitt, it would be great, if you could send out an email to genius-dev about the new transaction-parent stuff
14:23:11 <skitt> faseelak, noted
14:24:37 <faseelak> #topic internship topic proposals
14:25:05 <faseelak> #info if you have topic proposals, please submit them
14:25:42 <vorburger> #topic new quality-parent for more code checks
14:25:45 <vorburger> #link https://git.opendaylight.org/gerrit/#/c/70457/
14:28:17 <faseelak> #action vorburger to discuss with skitt to consolidate quality-parent and transaction-parent
14:28:44 <faseelak> #endmeeting