18:02:37 <dconde> #startmeeting ARCH
18:02:37 <odl_meetbot> Meeting started Fri May  2 18:02:37 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:02:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:37 <odl_meetbot> The meeting name has been set to 'arch'
18:07:00 <dconde> #chair alagalah
18:07:00 <odl_meetbot> Current chairs: alagalah dconde
18:07:05 <dconde> #chair readams
18:07:05 <odl_meetbot> Current chairs: alagalah dconde readams
18:07:12 <dconde> #chair mickey_spiegel
18:07:12 <odl_meetbot> Current chairs: alagalah dconde mickey_spiegel readams
18:07:13 <lenrow> where's the google hangout link for this?
18:07:39 <raghu67> #link https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.bps9id27mhd0pnqqljgjkckoqk?authuser=1
18:07:52 <raghu67> I got it from the invite
18:09:14 <jmedved> this is not working. tons of echo…
18:09:22 <jmedved> that works
18:09:24 <jmedved> yes
18:09:29 <dconde> we're OK now
18:09:35 <dconde> after 9 minutes!
18:09:49 <readams> sorry about the technical problems
18:09:49 <dconde> #info on arch subgroup page, please expand box to see agenda stuff
18:10:06 <dconde> #info where is subscription? we need more aspects -- w.r.t. model
18:10:19 <dconde> #info impact of model on subscription and renderers
18:10:24 <dconde> #topic agenda
18:10:38 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:ARCH
18:10:47 <alagalah> (expand)
18:10:55 <dconde> #info impact of model on subcr
18:11:08 <dconde> #info parent/child relationships is OK
18:11:22 <dconde> #info if we look at a contract, we get clauses, etc…. all in subtree
18:11:28 <dconde> #info in EPG, we get other stuff too.
18:11:35 <alagalah> #info (that was Mickey)
18:11:58 <dconde> #info we need to think about mult-tenancy, but let's ignore for now (dvorkinista)
18:12:32 <dconde> #info you get the groups, and then look at relators and know who you request information from. send a resolution request and get info back. "You==renderer-common"
18:13:06 <dconde> #info if I am a group and you are a contract, I should know where to go and where to request. Send a query to specify the selector.
18:13:30 <jmedved> is anybody pointing their camera on a whiteboard?
18:13:32 <dconde> #info wokring on names is simple. labels are harder.
18:13:37 <dconde> no whiteboard now.
18:13:44 <alagalah> jmedved: Not on whiteboard
18:13:49 <alagalah> jmedved: just discussion
18:13:56 <jmedved> ok, thx :-
18:14:20 <dconde> #info dvorkinista qualities are used to resolve the contractts
18:14:35 <dconde> #info groups points to contracts.
18:14:48 <dconde> #info send it to the policy repo, it calculates what's in scope and send it back.
18:15:28 <dconde> #info who does that -- does MD-SAL? or something else.
18:15:46 <dconde> #info if not possible, then do at policy server or repository.
18:16:13 <dconde> #info what type of functionalty? we want to select contract based on its properties. like set of labels.
18:17:00 <hemanthravi> dconde: if this call is on hangouts or webex could you post the link here
18:17:20 <dconde> #info mickey_spiegel asking who interprets the expression language.
18:17:23 <dconde> I'll post it.
18:17:29 <alagalah> https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.bps9id27mhd0pnqqljgjkckoqk?authuser=1
18:17:33 <dconde> thanks.
18:17:35 <hemanthravi> thanks
18:17:37 <raghu67> #info we need the notion of indexes defined on model attributes
18:17:57 <dconde> #info we need an indexing mechanism by the qualities.
18:18:22 <dconde> #info is this an extension of YANG model? that is an option, says dvorkinista
18:19:41 <alagalah> #info dvorkinista We want the model to be authoratative and a benefit is its self documenting, so ideally indexing should be part of the YANG model
18:20:04 <dconde> #info this stuff needs to work really fast.
18:20:39 <dconde> #info readams says we can build it bespoke if needed.
18:20:48 <dconde> #info we may need to do datastore discussions.
18:21:39 <dconde> #info joking -- we don'to want to re-invent SQL! says readams.
18:22:13 <dconde> #info this is hard core work -- if we can impl slowly. once you add indices, query plans, it get to be harder to impl.
18:23:55 <dconde> #action we need to handoff to DATASTORE subgroup to have more detailed requirements.  jmedved
18:24:30 <dconde> #info who can define the queries that can be made?
18:24:45 <dconde> #info that is represented in the model, says readams.
18:25:09 <tbachman> #info the selectors are representative of the queries
18:25:40 <lenrow> +1 Examples using model
18:26:20 <dconde> #info let's avoid this rathole
18:26:30 <dconde> #topic subscriptions
18:27:12 <dconde> #info we subscribe to policies and resolve it the node that deals with it. continuously renders
18:27:46 <dconde> #info kinda like triggers in databases
18:28:13 <dconde> #info if you look at any system -- this is always useful -- (says dvorkinista)
18:28:21 <dconde> #info once you mutate you get notified.
18:28:35 <dconde> #info always push, not polling.
18:29:01 <dconde> #info this fits spirit of MD-SAL.
18:29:12 <dconde> #info we are data driven. says alagalah
18:29:45 <dconde> #topic relationships
18:30:15 <dconde> #info mickey_spiegel lists some unidirectional vs. bidirectional. we need to agree on direction.
18:31:12 <dconde> #info picture shown on hangout?
18:31:18 <dconde> #info let mickey drive instead.
18:31:41 <dconde> #info not thought enough -- inheritance.
18:31:47 <dconde> #topic inheritance
18:31:58 <dconde> #info impact on subscription.
18:33:21 <dconde> #info child refs parent
18:33:38 <dconde> #info policy resolution is leaves to parent nodel
18:34:28 <dconde> #info it's no longer CONTAINMENT -- it's chaining of child to parent.
18:34:36 <dconde> #info this is fundamental issue.
18:36:55 <dconde> sorry - diagram on white board
18:37:04 <dconde> but hangout is full for me so cna't show video.
18:37:50 <dconde> #info the model is changing.
18:37:57 <dconde> #info we HAD containment.
18:38:08 <dconde> #info now, we have child with a sym link to parent.
18:38:29 <dconde> #info child specializes parent.
18:38:49 <dconde> #info contract with subjects are?
18:39:28 <dconde> #info we are talking about resolving policiy components. which is parent-child.
18:40:35 <dconde> #topic renderers
18:41:25 <dconde> there is going to be a slot free on hangout now.
18:42:18 <dconde> video coming on
18:42:20 <dconde> in hangout
18:43:14 <hemanthravi> yes
18:43:27 <dconde> #info photo of whiteboard being email'ed
18:43:35 <dconde> #info going to -dev alias
18:43:59 <dconde> #action to modeling group to deal with directionality.
18:44:01 <alagalah> I'll draw this up all proper like in gdraw
18:44:25 <dconde> #action is for readams and dvorkinista
18:44:51 <dconde> #topic renderers
18:45:50 <dconde> #info first stmt.  we don't want these extremes, but let's show them. 1) all state in universe and subscribe to all subtrees 2) other extreme is native renderer side. if stateless and relies on MD-SAL subscription, then we just transorm to whoever is below the renderer. The latter one is more interesting and better performing.
18:46:08 <dconde> #info the latter one needs to track which sub is for whom.
18:46:43 <dconde> #info we can add locational context to the EP Reg?
18:47:06 <dconde> #info dvorkonista says we may need a hint to map real object in renderer to EP reg
18:48:03 <dconde> #info readams if a renderer discovers dev on its own, how to add to the grp?
18:49:04 <dconde> #info it's the configuration of the renderer. this falls into operational aspect of renderer. but this is renderer specific.
18:49:23 <dconde> #info the time is getting near.
18:49:47 <dconde> #info this info is entered into renderer or into policy reposotiry. both are valid. we pick on, says dvorkinista.
18:50:15 <dconde> #info general constraints vs. impl specific.  the latter can go into renderer.
18:50:54 <dconde> #info once in YANG model, readams may write a func spec of GBP.
18:51:30 <raghu67> #info Is there going to be any operational state maintained by the renderers outside of MD-SAL Data store?
18:51:33 <dconde> #topic proactive vs reactive
18:52:16 <dconde> #info if ends points are coming and going, we need to be reactive to map to vswitch.
18:52:56 <dconde> raghu67 - just a moment.
18:54:08 <dconde> #info getting anything off of EP cannot be done reactively
18:55:27 <dconde> #info do we need an arrow from eP to EPG? We can do a query instead.
18:56:20 <dconde> #info arrow from EP to EPG is not necessarily defined intentionally.
18:56:46 <dconde> #info this is an external referene to the group is belong. EP is NOT in the policy repostory.
18:57:56 <dconde> #info we need to separate metadata
18:58:28 <dconde> #info always ask the EP registry (as an index)
18:59:46 <dconde> #info renderers ought to subscribe by context (to be defined -- an enforcement domain)
19:01:24 <dconde> we are about to lose the room
19:01:41 <dconde> raghu67 we may need to answer your question later on.
19:01:52 <raghu67> <dconde> ok
19:04:14 <dconde> #info we are talking on definition of reactive vs. proactive.
19:04:28 <dconde> #endmeeting