14:01:53 <regXboi> #startmeeting datastore
14:01:53 <odl_meetbot> Meeting started Mon May  5 14:01:53 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:53 <odl_meetbot> The meeting name has been set to 'datastore'
14:01:59 <regXboi> #chair alagalah
14:01:59 <odl_meetbot> Current chairs: alagalah regXboi
14:02:19 <regXboi> #info regXoi
14:02:31 <regXboi> #info regXboi
14:03:00 <alagalah> #info via Ghangout: alagalah, regxboi, readams, rexpugh-HP
14:03:14 <alagalah> #info via Ghangout: raghu67
14:04:53 <alagalah> 1. Keith/Rob to MD-SAL team: Can MD-SAL able to handle indexing/queries that we need for the Contract/Policy repository? (this is a followon from the ARCH team meeting 5/2)
14:04:53 <alagalah> [edit]
14:05:06 <alagalah> #topic Keith/Rob to MD-SAL team: Can MD-SAL able to handle indexing/queries that we need for the Contract/Policy repository? (this is a followon from the ARCH team meeting 5/2)
14:05:23 <alagalah> #info regXboi doubts it can (opinion)
14:06:38 <alagalah> #info ... as it stands today but regXboi (IBM), but the OpenDaylight Organisation (via the intern program) has someone assigned for querying/indexing whom regXboi will mentor
14:06:48 <alagalah> #info regXboi mentioned JQuery
14:07:25 <alagalah> #info There were concerns expressed in the ARCH meeting last week that a) this is too complex for an intern b) JQuery maybe the wrong solution for this
14:09:00 <alagalah> #info regXboi can see how a) above maybe valid, b) again regXboi acks this may be possible but doesn't want to create something new and is asking for alternatives to JQuery
14:09:40 <alagalah> #info dvorkinista points out that we first have to drive this from our particular requirements, and we have only a handful of use cases for this topic and JQuery is more general purpose
14:09:57 <alagalah> #info readams feels we may have to write a lightweight indexing query functionality.
14:10:08 <alagalah> #info regXboi points out that this will have to be done via the MD-SAL team
14:10:55 <alagalah> #info raghu67 points out that this will have to be within the MD-SAL (query of index) rather than outside... dvorkinista says thats why readams said we need "hooks" to the MD-SAL, implying we agree that this should be in MD-SAL and we should consume that service.
14:11:13 <alagalah> #info regXboi +1E6 to Mike
14:11:27 <alagalah> #info jmedved just joined channel
14:13:28 <alagalah> #info regXboi says that we will have everything from a tenant to an EPG
14:13:44 <alagalah> #info dvorkinista says we should have some sophisticated tree traversal capability.
14:14:02 <alagalah> #info regXboi: EPG is where the rubber meets the road
14:14:17 <alagalah> #info raghu67: says there are 3 forms of queries.. (missed the 3)
14:14:53 <regXboi> #info class, subtree and relationships (I think)
14:14:55 <alagalah> #info dvorkinista REST doesn't have concept of RPC, it works on data, and works on Trees, and we need to be able to query on class, we need to be able to query on sub-tree, but also need to be able to traverse relationships (gets tricky here)
14:15:05 <alagalah> regXboi: Thanks!
14:15:51 <alagalah> #info dvorkinista when you get a subtree, you should have children and others... current implementation espec. with RESTCONF the things we can do is slightly limited
14:16:11 <alagalah> #info dvorkinista believes that RESTCONF isn't the best way of implementing REST, and if we use RPCs we aren't really REST
14:17:11 <alagalah> #info regXboi asks jmedved if he received email from Phil Robb, re: ODL intern for JQuery project (noted above), and discussion to this point has been if JQuery is too General Purpose, and now regXboi has noodled, thinks dvorkinista may be right
14:17:54 <alagalah> #info jmedved points out that JQuery is quite different from what GBP needs (via dvorkinista) especially as we look at subscription (and continually pushing data)
14:18:48 <alagalah> #info regXboi: Not only will GBP need "hooks" (ala readams comment) but Service chaining project may need it too
14:19:26 <alagalah> #info jmedved: annotate the models with some form of yang extension (GBP model) to facilitate MD-SAL hooks
14:19:37 <alagalah> #info raghu67 Index hooks or RPC hooks?
14:20:36 <alagalah> #info raghu67 Clarifies... MD-SAL index maybe too generic, hence GBP may build our own. Hence perhaps hooks so MD-SAL can build the specialised indexes
14:21:29 <alagalah> #info jmedved says datastore will have to build indexes and MD-SAL will have to pass it through to the datastore. Hence need hooks into MD-SAL.
14:22:04 <alagalah> #info alagalah asks if those hooks are purely RPC. jmedved says no, the MD-SAL won't have any use for the indice (hence no RPCs ??) but would have to pass it thru
14:22:17 <alagalah> #info raghu67 doesn't thinks thats what regXboi dvorkinista has in mind
14:22:28 <alagalah> #info dvorkinista: push mechanism is based on this....
14:23:18 <alagalah> #info jmedved two mechanisms need to be built out but dvorkinista gives example that first query has to be supported (ie there isn't an existing subscription/push mechanism initialised)
14:23:58 <alagalah> #info jmedved discussed the subscription/push of subtree on data change (in line with our desire to be data driven) but dvorkinista says that the semantics are the same
14:25:09 <alagalah> #info jmedved Is delineating between the creation/support of indices in the "MD-SAL" datastore, and database triggers for subscription (push-on-change)
14:27:01 <alagalah> #info regXboi who receives the trigger? dvorkinista says we need to push the change, but the issue is what happens if I didn't get the prior change. regXboi Asks if you push the change, on top of a missed change, it gets ugly. dvorkinista says one solution is policy repo has a "queue" like thing and we don't remove from queue until acknowledged (purely synchronous)
14:27:35 <alagalah> #info regXboi uses "version" to imply "hey I'm missing a couple of updates" (we want to avoid versioning) ... dvorkinista says its more of an accumulator.
14:28:07 <alagalah> #info dvorkinista wants to keep this as simple as simple as simple as possible (but no simpler) :-P
14:29:55 <alagalah> #info Renderer needs to notify when it got the data, if he has #17, and buffer is at #23, then you need another update. regXboi says that once it hits renderer it is it's responsibility.
14:30:40 <alagalah> #action alagalah to ensure that these minutes are linked to Renderer sub-group page and ARCH page and in ARCH agenda
14:30:53 <alagalah> #info jmedved wants to whiteboard use cases
14:33:20 <alagalah> #action alagalah to add whiteboard usecases to ARCH agenda
14:34:00 <raghu67> #info 1PM thursday is the status call. Right?
14:35:12 <alagalah> #endmeeting