14:01:44 <regXboi> #startmeeting DataStore 4/28
14:01:44 <odl_meetbot> Meeting started Mon Apr 28 14:01:44 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:44 <odl_meetbot> The meeting name has been set to 'datastore_4_28'
14:01:57 <regXboi> #chair alagalah
14:01:57 <odl_meetbot> Current chairs: alagalah regXboi
14:02:24 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:DATASTORE
14:04:01 <regXboi> #topic agenda bashing
14:04:50 <regXboi> #topic who is contributing and what time can be devoted?
14:05:10 <regXboi> #info alagalah sent this to the mailing list
14:05:22 <regXboi> #info only regXboi and s3wong have replied so far
14:05:38 <s3wong> regXboi: is there things to contribute in the datastore area outside of policy repo and endpoint mapper (which is a different subgroup)?
14:06:28 <regXboi> s3wong: I'm not 100% sure, but the first thing is to spend some time evaluating MD-SAL and APIC sharding based on a draft yang model
14:07:38 <regXboi> #discussion of where performance considerations should be tracked - here or in MD-SAL
14:07:52 <regXboi> #info discussion of where performance considerations should be tracked - here or in MD-SAL
14:10:53 <regXboi> #action regXboi to update wiki page with the scope of datastore
14:10:59 <alagalah> #info alagalah: Charter of this group is to determine requirements of GBP datastore and it's mapping to MD-SAL and any changes we may need to MD-SAL ala APIs. This meeting will roll into Arch and DATASTORE will actually, once we get to code, we will probably have only 3 groups (EP-mapper/policy, OperationalState, Renderers)
14:15:27 <regXboi> #action (not direct for this) jmedved to start actual model discussion
14:15:39 <alagalah> #action jmedved to produce a YANG model from GBP UML 0.97 with Tony (Pantheon?) and email to the list in next two days.
14:15:43 <regXboi> #info currently jmedved uses cbench to hit the datastore currently
14:15:48 <alagalah> (eek sorry regXboi)
14:15:57 <alagalah> (I thought you were talking)
14:16:38 <regXboi> #link http://www.joedog.org/siege-home/
14:17:32 <alagalah> FYI folks on IRC, we are also on Ghangout for audio
14:17:46 <alagalah> https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.e7ngfp46nqhv5oltibelval6o8
14:18:12 <alagalah> I have a question pertaining to MD-SAL datastore
14:18:55 <alagalah> #info Rob Adams asks if we are putting the "cart before the horse" talking about MD-SAL performance metrics
14:19:03 <alagalah> #info Before we have an actual implementation to measure
14:19:25 <regXboi> #info regXboi claims what we are doing is setting the methodology so it is common when comparing implementations
14:19:40 <alagalah> #info regXboi points out that he wants to settle on a methodology so we can use the same methodology to benchmark existing, and then measure our implementations against it and identify improvements etc
14:19:57 <regXboi> alagalah said it better :)
14:20:15 <alagalah> regXboi: Sometimes I wordify good
14:20:15 <alagalah> yes
14:20:47 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:DOM_DataStore
14:21:20 <regXboi> #info according to jmedved that is the latest documented, but it still needs to be updated with latest infromation
14:22:27 <regXboi> #info new in-memory data store is going to an external customer so we'll have field trial data to work with
14:22:41 <alagalah> regXboi: I have another question
14:23:13 <regXboi> #info jmedved is interest in comparing performance of current tree with mlemay's KV implementation of the in-memory datastore
14:23:34 <regXboi> #info (edit) s/interest/interested/ in last info
14:24:28 <regXboi> #info alagalah want to clarify the separation of md-sal and in-memory datastore and is asking if readams is comfortable with the implementation implications of that
14:24:38 <regXboi> #info readams is still working it
14:34:11 <regXboi> #info a bit of a discussion of APIC vs ODL sharding
14:42:08 <alagalah> #info alagalah asks jmedved about a) does sharding fall under GBP or MD-SAL. jmedved says MD-SAL. b) Does MD-SAL have a Release Plan that I can sync the GBP release plan with so that when a portion of GBP needs to leverage sharding (and the leader + 2x follower concept from APIC for a shard) that MD-SAL has a prototype ready to go. jmedved points out that MD-SAL is not an official project but a sub-pa
14:42:08 <alagalah> rt of the Controller project, and these discussions are still underway.
14:42:55 <alagalah> #action alagalah once he publishes the first cut of the GBP Helium Release Plan will also have a document that gives context to the relationships between subgroups, and other projects, to justify why certain steps are at certain gates in the critical path
14:43:42 <alagalah> hold 1 regXboi typing b ut I want to comment
14:43:59 <alagalah> #info alagalah asks jmedved about a) does sharding fall under GBP or MD-SAL. jmedved says MD-SAL. b) Does MD-SAL have a Release Plan that I can sync the GBP release plan with so that when a portion of GBP needs to leverage sharding (and the leader + 2x follower concept from APIC for a shard) that MD-SAL has a prototype ready to go. jmedved points out that MD-SAL is not an official project but a sub-pa
14:43:59 <alagalah> rt of the Controller project, and these discussions are still underway.
14:44:05 <alagalah> Stupid meetbot
14:44:28 <regXboi> #info rt of the Controller project, and these discussions are still underway.
14:44:34 <regXboi> #info (that finished the previous info)
14:47:20 <regXboi> folks are really breaking up
14:47:55 <s3wong> yes
14:49:01 <s3wong> Dropping out soon, as the train is about to enter tunnels, Internet connection will break for me
14:49:06 <s3wong> Thanks, folks!
14:49:32 <alagalah> s3wong: See you soon and thanks for the reply to my email
14:49:41 <alagalah> #endmeeting