18:22:16 <alagalah> #startmeeting GBP ARCH May9
18:22:16 <odl_meetbot> Meeting started Fri May  9 18:22:16 2014 UTC.  The chair is alagalah. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:22:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:22:16 <odl_meetbot> The meeting name has been set to 'gbp_arch_may9'
18:22:23 <alagalah> #chair dconde regXboi
18:22:23 <odl_meetbot> Current chairs: alagalah dconde regXboi
18:22:37 <alagalah> #topic Mickey to discuss subscription from whiteboard
18:22:41 <regXboi> why are you making me a chair?
18:22:48 <alagalah> regXboi: Pain
18:22:50 <regXboi> I'm not anywhere w.r.t this meeting
18:23:04 <dconde> #info phone 1-866-432-9903
18:23:15 <dconde> #info access code 204 699 499
18:23:24 <regXboi> unfortunately - I'm getting pulled into something else
18:23:33 <alagalah> Remotes, please comment on video quality
18:23:47 <alagalah> This will be whiteboard, so if you can't read its worthless and we should stop and fix camera
18:23:53 <cloudtoad> It's pretty pixelized on this end.
18:24:04 <regXboi> phone only won't help
18:24:28 <alagalah> #info recording webex
18:24:57 <alagalah> #info dvorkini_ drawing on whiteboard re: EP attach/mutation
18:25:23 <dconde> I will try to fix resolution of video.
18:25:30 <alagalah> #info Can attach conditions to EPGs as well as EPs, and EPG can be scoped to enforcement domain
18:25:35 <cloudtoad> Whose buttonf***ing the focus?
18:25:43 <alagalah> #info Can extend this concept to the tenant
18:26:31 <alagalah> #info EPG has conditions and can also belong to an "enforcement domain" which is a renderer or set of renderers who share the domain-ness
18:27:06 <alagalah> #info Can rely on EP attachment and there's context of which EPG is belongs to and domain it belongs to and resolution of EPG and things on EPG depends on and what things it depends on, and we resolve those things
18:27:44 <alagalah> #info Tenant is generalised concept of EPG scope
18:28:13 <alagalah> #info Mickey asks if Enforcement domain comes from EPG and tenant, but dvorkini_ says not necessarily, can be other things
18:28:33 <alagalah> #info So Enforcement Domain can be fully reactive or it can be pre-populated
18:29:10 <alagalah> #info pre-population: we know which policies are in scope, from EPG/tenant, and can apply the same logic to the EPs and anything that is in scope for your EnfDom you bring in scope
18:29:45 <alagalah> #info Need to consume different models, because say we are in an OF controller ... and alagalah lost the train of thought (see recording)
18:30:41 <alagalah> #info raghu67_ asks if a new EPG gets created, how is the scope created. dvorkini_ so either an EP attaches (and rules are applied based on EP) or someone writes the rules for the EPG
18:31:29 <alagalah> #info dvorkini_ says we can a load of contracts that aren't instantiated as they only come into scope at various times of day (ie nightly batch jobs etc)
18:32:50 <alagalah> #info dvorkini_ says that once we get into OpFlex etc, then we need to be reactive, as others are adding things dynamically to the system.
18:33:26 <alagalah> #info Up to the renderer what gets resolved or either you can resolve things that are "within your circle"
18:34:04 <alagalah> #info ie one mode, is you retrieve the group and all its surrounding contracts, and once EPs appear, you already know, and once its peer EP comes online you retrieve its' information
18:34:34 <alagalah> #info mickey says this is where all the questions come about
18:34:58 <alagalah> #info Question was do I grab anything proactively (ie if I have consumer, do I try and proactively get provider information ahead of time)
18:36:02 <alagalah> #info dvorkini_ shows EP->EPG-> contract (single side, say provider), and we have another side that consumes it (and shows selectors within EPG) and shows retrieval of everything from Provider side through to Consumer selector *(which has the consumer requirements) so we can make the match (accord)
18:36:09 <alagalah> #info point is that there are multiple modes
18:36:45 <alagalah> #info dvorkini_ points out that if we don't know something, we can still reactively retrieve information.
18:37:21 <alagalah> #info reactivity vs proactivity again resolves to the renderer, as for instance, OpFlex renderer being reactive may not be as expensive as say an OF renderer
18:37:49 <alagalah> #info dvorkini_ says for ACI, the way we are thinking of this is to subscribe to tenants and policies
18:38:33 <alagalah> #info readams points out that at the initial scales reactive will be fine, but if we want to scale to "ridiculous levels" we may need to look at alternate sharding etc...
18:38:55 <alagalah> #info some comment about who's who in the zoo ie does Jan's MD-SAL team have to own this and dvorkini_ points out that they shouldn't care
18:46:43 <alagalah> #info net of the last 5min. Renderer commons, gets EP, contracts etc, does some work, once we get closer to clauses/subjects/rules, we are using the specific implementation renderer (this is active rendering), passive rendering is where we are pretty much just passing stuff through (think APIC subtended to ODL, and some slight munging of policy semantics might be necessary but its ostensibly passthru)
18:48:10 <alagalah> #not-info-humour: We are going to implement spanning tree
18:54:51 <alagalah> #info alagalah will augment these minutes with mickey's notes
19:00:31 <alagalah> #info Dave Lenrow brings up that we need to model and be cogniscent of the Renderer performance, and readams points out that this is a complex situation, espec. when we have an outage, recovery, and a flood of messaging
19:04:04 <alagalah> #info mickey: Jan maybe interested in how we subscribe to selection relators, but rob points out that we need to actually have the yang model get into the datastore, but its a bit premature
19:04:33 <lenrow> #info We need a better phone/microphone for the conference room where you host. I'll contribute. It's brutal trying to follow the audio in the room
19:04:54 <alagalah> #info need to define exactly what we need to subscribe to.
19:06:31 <alagalah> #action Mickey/Rob by May23 to build up a list of specific parts of the UML model that the MD-SAL has to support subscription services for
19:06:37 <alagalah> #endmeeting