17:04:39 <regXboi> #startmeeting gbp model
17:04:39 <odl_meetbot> Meeting started Fri Jun  6 17:04:39 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:39 <odl_meetbot> The meeting name has been set to 'gbp_model'
17:04:44 <regXboi> #chair dconde
17:04:44 <odl_meetbot> Current chairs: dconde regXboi
17:04:50 <odl_meetbot> dconde: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
17:04:51 <regXboi> #chair tbachman
17:04:51 <odl_meetbot> Current chairs: dconde regXboi tbachman
17:05:09 <regXboi> #topic agenda bashing
17:05:16 <regXboi> #info do we *HAVE* an agenda?
17:05:21 <dconde> regXboi: says meeting may be quick if we do not get more people on
17:06:02 <dconde> we can always talk about on the OpenStack GBP side! But it was aimed at s3wong , says regXboi
17:06:42 <s3wong> The model in current form is so good, that attendance in this meeting is lower
17:07:01 <regXboi> s3wong: are you saying that with a straight face?
17:07:24 <s3wong> you always see my avatar's straight face :-)
17:08:15 <dconde> we will wait until 10 minutes after and regXboi states that we are worried that we will be risk for Helium.
17:08:26 <dconde> and that is coming from a TSC member (regXboi )
17:08:28 <regXboi> #info regXboi translates "risk" as "DOA"
17:08:41 <mickey_spiegel> I know there was some discussion yesterday between Ed Warnicke and Noiro folks about M2 milestones
17:08:46 <mickey_spiegel> Don't know more than that
17:08:54 <regXboi> #info but that is regXboi not speaking as a TSC member but as a committer
17:09:03 <dconde> #info regXboi states concern as a committer on the risk of not meeting helium
17:09:12 <regXboi> mickey_spiegel: did that actually happen?
17:09:21 <regXboi> I know I sic-ced Ed on them
17:09:31 <mickey_spiegel> There were some phone calls, don't know what they talked about
17:09:38 <regXboi> but I've not had a chance to circle back with ed
17:10:11 <dconde> #info there was some dicussion between Noir0 and the edwarnicke but we have not had a chance to check w/ them
17:10:29 * regXboi notes radio slience stinks
17:11:06 <dconde> #info regXboi asks mickey_spiegel whether we are doing ARCH
17:11:06 <mickey_spiegel> Does anyone have any arch topics?
17:11:12 <mickey_spiegel> If not, I will cancel it now
17:11:17 <dconde> #info I am not aware of ARCH topics.
17:11:22 <regXboi> mickey_spiegel: honestly, I think lenrow *might*
17:11:24 <s3wong> mickey_spiegel: not me
17:11:24 <dconde> #info propose to cancel.
17:11:28 <regXboi> but I don't see him either
17:11:52 <dconde> #info readams just joined hangout
17:11:53 <regXboi> #info readams just arrived
17:12:31 <dconde> #info readams says real work needs to be done but have not had chance to do it.
17:12:45 <dconde> #info maybe on topic of model -- key areas to be taken care of, are :
17:13:10 <dconde> #info 1) l2/l3 context and data plane modeling aspects. Not hard, but needs to be done. to associate L2/L3 context with EPG
17:13:43 <dconde> #info 2) additions to represent intra EPG policies as a peer contract notion. and define semantics. this is tricky for several reasons. Contract notions have directoinality which is noe defined.
17:14:04 <dconde> #info INTRA policies need to define multi-cast and broadcast. I.e not src/dest
17:14:39 <dconde> #info  we can get big switches that has no broadcast allowed except certain types of traffic. like what ACI does. and let ARP are handled by special proxies.
17:14:50 <lenrow> coming in late... Is there a hangout link?
17:15:01 <tbachman> https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.6msm68t31c5fdn152g721o09ks
17:15:06 <s3wong> lenrow: #link https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.6msm68t31c5fdn152g721o09ks
17:15:11 <dconde> #info so… some effort needs to go into modeling how the location - identifier mapping
17:15:24 <dconde> #info in context field --we have the mapping for the renderer
17:15:50 <dconde> #info we thought that was a separate repo that was renderer specific, but current thought was to put into the EP registry.
17:15:54 <dconde> #info last area:
17:16:05 <dconde> #info status and exception repo.
17:16:10 <dconde> #info status repo needs design.
17:16:29 <dconde> #info we can derive some prior work -- such as in ACI
17:16:47 <dconde> #info readams needs to define model as he writes the renderer.
17:16:57 <dconde> #info if anyone wants to define those, it's welcome!
17:18:00 <dconde> #info the exception repo is straightfoward. need some error context and results need to be stored. (blocked? What's the constrints were relaxed, error type (fatal, non fatal)
17:18:44 <dconde> #info perhaps an orchestraton system can fix it. (TCAM space ran out?). Orch system can fix by moving. VMs but that's a FUTURE thing.
17:19:24 <dconde> #info it is more than Error log, but it has a active events, not an log of past errors.
17:19:34 <dconde> #info big distinction compared to syslog semantics.
17:19:40 <dconde> #info regXboi now wants to talk about....
17:19:49 <dconde> #info context of dataplane
17:20:12 <dconde> #topic context
17:20:28 <s3wong> that's the exception based on enforcement - is there anything today to report exception back all the way to orchestration layer?
17:20:30 <dconde> #info we think we get concepts of contexts…but there is the In-between
17:20:47 <dconde> #info specifically tunnels.
17:21:33 <dconde> #info readams says tunnels msy not come in. w.r.t. policies can state what can communicate. it's a diff between broadcast domain vs. subnet.
17:21:54 <dconde> #info details of the underlying network may require tunneling, but we do not define a policy on how that is done.
17:22:21 <dconde> #info regXboi sees a use-case.
17:22:30 <dconde> #info only thing that identifies an EPG is a tunnel ID
17:23:10 <dconde> #info readams says -- imagine in context of a bigswitch fabric, or ACI. a link comes into the leaf node
17:23:32 <dconde> #info underneath is some OTHer network you don't control.  It has a tag
17:24:17 <dconde> #info regXboi adding to epg based on policy of CIDR block and address
17:24:40 <dconde> #info based on VXLAN tag for traffic that traverses the mesh
17:25:09 <dconde> #info then we need to learn it and associate with EPG
17:26:22 <dconde> #info regXboi disagress since… L3 context needs to have things that the outer header of a tunnel MIGHT have.
17:27:12 <dconde> #info associates a port to an EPG may be true….
17:27:48 <dconde> #info readams you can MAP a port -- VLAN 5 means Web EPG, VLANX 6 == DB EPG.
17:27:55 <dconde> #info regXboi agrrees on that.
17:28:05 <dconde> #info any mapping semantics is possible.
17:28:23 <dconde> #info that can be done via learning.
17:29:00 <dconde> #info simplest renderer if orchestration system managed all VMs but in raality, we need learning capability for most products
17:29:24 <dconde> #agreed port into EPG by regXboi
17:29:30 <mickey_spiegel> L2/L3 context are not about what the network outside does. It is about whether we bridge or route inside the domain controlled by group-based policy
17:29:37 <dconde> #info but regXboi wonders how it's supposed to work.
17:29:47 <dconde> #info it is similar to what lenrow asked in ML
17:31:20 <dconde> #info readams says mickey_spiegel comment is mostly true. but you can potentially route between devices within same EPG or L2 context.
17:31:20 <lenrow> L2/L3 context are the "virtual network" context for a vnet that might be L2 or L3 internally
17:31:32 <dconde> #info it's an issue of sharing name space.
17:32:24 <dconde> #info if you have a private connectivity group you need something that ties ito to the 5 tuples you see on the wire.
17:32:57 <dconde> #info it's a name space issue.
17:33:18 <dconde> #info but readams needs to work it out, perhaps talks with others on how it can be implemented
17:33:30 <dconde> #info lenrow wants to call it a virtual network context.
17:33:41 <dconde> #info maybe….but L2 != L3 context
17:34:14 <s3wong> FYI: for Neutron GP these "contexts", for mapping driver, maps directly into a Neutron network / subnet
17:35:18 <dconde> #ifo readams will write renderer common doc.
17:35:56 <regXboi> s3wong: has that changed?  I thought it was different originally...
17:36:39 <s3wong> regXboi: the way to do it will change (invoking python client instead of calling internal APIs), but the mapping is the same
17:36:44 <dconde> #info regXboi is happy - he is on PTO last half of next week.
17:36:58 <dconde> #info any topics of ARCH call?
17:37:07 <dconde> #info but now… anyone thing we do?
17:37:29 <dconde> #info readams work needs to happen in ARCh but hard to do in a call, it needs to be written.
17:38:13 <dconde> #info uchau asks did the meeting get started? we're not sure
17:38:38 <regXboi> dconde: I think this is a different meeting being referred to - I didn't catch the name
17:38:48 <regXboi> #undo
17:38:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x281aad0>
17:38:58 <regXboi> #info uchau asks did the renderer meetings get restarted
17:39:30 <regXboi> #info lenrow asks if renderer design is put down on people
17:39:38 <regXboi> #undi
17:39:41 <regXboi> #undo
17:39:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x281aa50>
17:39:50 <regXboi> #info lenrow asks if renderer design is put down on paper
17:40:15 <regXboi> #info readams replies to something that comes out to the scribe as "not yet"
17:40:33 <regXboi> #info lenrow asks about a capability infrastructure
17:40:39 <dconde> #info renderers can complain by raising exception
17:40:51 <dconde> #info that is in the design on Wiki
17:40:52 <regXboi> #info lenrow asks where the code?
17:41:36 <dconde> #info filling in details of design needs to be done, but there is an architecture diagram on wiki. but we need to fill in details.
17:41:57 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture Architecture wiki page
17:42:13 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model Policy architecture page
17:42:28 <dconde> #info concept of subject features - set of actions and classifiers supported will go a long way to address this
17:43:12 <tbachman> #info yang models and code for the policy and endpoint registry are in ODL git
17:43:15 <mickey_spiegel> One thing we could do to start us down the path Dave is talking about is to figure out what is mandatory and what is optional, in detail
17:43:20 <dconde> #ifo important to desribe wht is capable so we can expose in UI
17:43:33 <tbachman> #ifo?
17:43:35 <tbachman> lol
17:43:36 <tbachman> ;)
17:44:11 <tbachman> #info important to desribe wht is capable so we can expose in UI
17:44:37 <dconde> #info go to wiki and please check the arch link in dev doc.
17:45:06 <dconde> #info lenrow will go look at it offline
17:47:13 <dconde> #info we should just get online at top of hours to air concerns in arch meeting
17:47:43 <dconde> #endmeeting