19:59:59 <dconde> #startmeeting gbp-status
19:59:59 <odl_meetbot> Meeting started Thu May  1 19:59:59 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:59:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:59 <odl_meetbot> The meeting name has been set to 'gbp_status'
20:02:18 <dlenrow> What is google hangout link for today please?
20:03:58 <dconde> just a moment
20:04:19 <dconde> #link for hangout is https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.nf43n3np1b0kc48it41dsg4v2o
20:04:37 <dconde> dlenrow - let me know if that works
20:04:55 <dlenrow> At least it's easy to memorize :-)
20:05:12 <dconde> #chair alagalah
20:05:12 <odl_meetbot> Current chairs: alagalah dconde
20:05:44 <dconde> starting in 5 minutes
20:05:51 <dvorkinista> #table dconde
20:06:12 <mickey_spiegel> #info here
20:06:18 <dvorkinista> #info here
20:06:41 * tbachman #info here
20:07:02 <dconde> #table, chair, sofa
20:07:21 <dconde> #info dconde here
20:07:24 <s3wong> #info here
20:07:52 <dconde> #topic start of meeting
20:07:59 <dconde> #info agenda item
20:08:10 <dconde> who will be committing code
20:08:30 <dconde> #info we see the list of people who will be committed
20:08:37 <dconde> #info anyone else should speak up.
20:08:52 <dconde> #agreed that the list if what we have for now.
20:09:27 <dconde> #info liemmn is 20%, right? but may ramp in future?
20:09:50 <dconde> #info liemmn said starting at less than 20 but may ramp to 40%
20:10:03 <dconde> #info uchau may ramp up in similar way
20:10:34 <dconde> #info Hemanth adds 20% to himself and another TBD from oneConvergence.
20:10:53 <dconde> #info A4, a4 in spreadsheet is a reference to tasks in the spreadsheet.
20:11:11 <dconde> #info concept of dummy renderer.
20:11:19 <dconde> #info we see a diagram on the hangout.
20:12:14 <dconde> #info this idagram is going to change since renderers have two components.  we have common store for the 4 boxes. repo, ep reg, enforcement repo, op states.
20:12:45 <dconde> #info benefits in parallel development by creating a dummy renderer that statically responds (like a stub?) same for SB renderer
20:13:12 <dconde> #info it's a stub with a statically defined field.
20:13:34 <dconde> #info if I know the subject,etc. we can stuff the subject into the stub
20:14:14 <dconde> #info we need to work with the scorer for the scalar generation algorithm.  Someone in APIC team has done that. So alagalah will contact them for background.
20:14:28 <dconde> #info same for thresholding and acknowledgement
20:14:39 <dconde> #info the boxes have very little intelligence in them.
20:14:49 <dconde> #info the renderer has all the intelligence in them.
20:15:15 <dconde> #topic parallel implementation
20:15:24 <jmedved> there are folks trying to join the hangout and can’t - google says the video call is full…
20:15:40 <dconde> if you cannot get into hangout, please telephone in.
20:16:08 <jmedved> what’s the bridge #?
20:16:11 <dconde> dvorkinista states that renderer … (lost audio?)
20:16:25 <dconde> US/Canada: +1.866.432.9903 United Kingdom: +44.20.8824.0117
20:17:29 <dconde> #info the DSE talk to the Endpoint registry / mapper
20:17:45 <dconde> #info DSE / Governance / Congress /etc. needs to fit in.
20:18:00 <dconde> #info DSE stands for data services engine
20:18:10 <dconde> #info Plexxi guys contributed that to the Congress project.
20:18:36 <dconde> #info DSE pulls out network metadata from other sources
20:18:56 <dconde> it can influence policies and influence groups of endpoints.
20:19:36 <dconde> #info there is a placeholer in the release plan.
20:19:51 <dconde> #info we start with OpenFlow and OpFlex moved into incubation this morning
20:20:03 <dconde> #info so that's a real project.
20:20:58 <dconde> #info we want to implement REnderer common and migrate OF Strawman
20:21:18 <dconde> mickey_spiegel says that we need to figure out the unknown unknown
20:21:41 <dconde> if the renderer is stateless and transofrmational, then we have more restrictions on subscription,
20:21:54 <dlenrow> What subjects we plan to  render for needs to be defined in more detail for Helium
20:22:11 <dconde> #info we will talk about that in the ARCH meeting tomorrow.
20:22:27 <dconde> #info we think subscription and rendering is intertwined.
20:22:38 <dconde> #info everyting in column A should be a sheet.
20:22:53 <dconde> #info interdependencies are critical.
20:23:13 <dconde> #topic release plan schedule
20:23:24 <dconde> #info we are looking at gates.
20:23:30 <dconde> #info M1 to M3 is easy
20:23:34 <dconde> #info M4 and 5 are harder
20:24:41 <dconde> #info all things are gated on beginning of a week except we have a conflict with Labor day for code freeze
20:25:24 <dconde> #info probability for working on labor day is low
20:25:36 <dconde> #info dvorkinista reviewing release plan.
20:25:49 <dconde> #info this is aggressive.
20:26:08 <dconde> #info if people at 20% then if you are not familiar with ODL it's hard.
20:26:10 <dlenrow> The problem space for which  one can define subjects and associated rendering is nearly infinite. What subset do we foresee delivering?
20:26:50 <dconde> #info we can do stuff like pair work, etc to ramp it up. alagalah says we need to experience first hand if this is sane.
20:27:23 <dconde> #info if the goal is to render everything forever, it's hopeless.
20:27:30 <dconde> #info we need to understand the subset.
20:27:58 <dconde> #info dlenrow is talking about stretch goals, etc. a few subjects to render
20:28:26 <dconde> #info dvorkinista says if we do it well,  it's better than something fast that does not work.
20:29:07 <dconde> #info mickey_spiegal says that contracts and such need to be put in early.
20:29:27 <dconde> #info dvorkinista says it needs to be fast too.
20:29:48 <dconde> #info alagalah says a subset is doable.
20:30:18 <dconde> #info dvorkinista
20:30:43 <dconde> #info most affects are on service chaining, but dvorkinista says we can hold off on that but it needs to be done well, and we can wait for that.
20:31:12 <dconde> #info we need to be very careful and not over commit.
20:31:25 <dconde> #topic service chaining
20:31:29 <dconde> Derick is talking
20:31:50 <dconde> #info looking at diagram
20:32:06 <dconde> #info the diagram will be mailed out.
20:32:15 <dconde> #info dvorkinista we need to make sure it is extensible.
20:32:23 <dconde> #info OK to skip functions to edit without rewrite.
20:32:57 <dconde> #info dvorkiinsta not worried about policy. EPR needs to be fast. Renderer is where all crazy behaviour is.
20:33:18 <dconde> #info it seems to make sense for parallel development.
20:33:37 <dconde> #info alagalah says we need to worry about extensibility in renderer.
20:33:58 <dconde> #info we need to describe a policy that governs that.
20:35:10 <dconde> #info all of these things can be subclassed, says dvorkinista
20:35:20 <dconde> #info OF stuff is down below, says mickey_spiegel
20:36:15 <dconde> #info this is in the OF render, not part of the common renderer.
20:37:00 <dconde> #info dvorkiista says it's another layer of abstraction. OpenFlow based, affinity, etc.
20:37:34 <dconde> #topic renderer
20:37:47 <dconde> #info we are redrawing diagram.
20:38:01 <dconde> #info adding OF renderer below Flow based renderer
20:38:54 <dconde> #info idea to make the dummy object is statically defined and we invoke this into flows.
20:39:22 <dconde> #info flow based rendering is not stateless.
20:39:58 <dconde> #info render common is constantly rendering. Are we worried   about passing vs. storing.
20:41:29 <dconde> #info we talked about schedule.
20:41:35 <dconde> #topic recap
20:41:42 <dconde> #info is this a sane plan?
20:43:16 <dconde> #info keep everything equal. and statically define it.
20:43:47 <dconde> #info readams asks.does the dummy version need to be created first?
20:44:26 <dconde> #info readams says we cannot make progress until model is defined.
20:45:22 <dconde> #info readams what is A5 for renderer?
20:46:09 <dconde> #info alagalah asks which parts do you want to contrib to?
20:46:21 <dconde> #topic call fo volunteers
20:46:31 <dconde> #topic call for volunteers
20:47:34 <dconde> #topic we have a proposal now.
20:47:52 <dconde> #info liemnm how do we do tests?
20:48:40 <dconde> #info we do have dependencies -- says lenrow
20:48:50 <dconde> #info alagalah UI extensions are unknown.
20:49:18 <dconde> #ifo DLUX is horizon port to ODL
20:50:05 <dconde> #info we need to look at QOS, openflow 1.3 metering impl, etc.
20:50:11 <dconde> #info this may limit what labels we can use.
20:50:31 <dconde> #action alagalah to follow on edwarnicke ODL plans
20:51:02 <dvorkinista> dconde: why would it affect labels? This is insane!
20:51:35 <dconde> OK. I think I mis-scribed.
20:52:11 <dconde> dvorkinista the cross talk got me rendering improperly on IRC
20:52:38 <dvorkinista> dconde: it's all good
20:52:51 <dconde> #info test dev platform == mininet. but ideally we need real set-up.
20:53:20 <dconde> #info tbachman to document the ovsdb / openstack / ovs dev environment
20:53:28 <dconde> #info also for openflow on mininet.
20:53:57 <tbachman> lol -- right when alagalah mentions my name, ghangout drops on me!
20:53:58 <dconde> #info for OpFlex, it's nascent, so we need to figure out. probably mininet too,b ut it may be ovs switches directly on Linux. Who knows.
20:54:44 <dconde> #info  spredsheet was emailed out.
20:55:10 <dconde> #info sharing is failing.
20:56:13 <dconde> #info sharing of gDocs done.
20:56:53 <dconde> #topic anything else?
20:57:22 <dconde> #info monday COB has the final commitment.
20:57:48 <dconde> dlenrow says ghangout max was reached.
20:59:07 <dconde> #info if you cannot get on ghangout then go to IRC and say you cannot get on, and then we can fire off a WebEx.
20:59:40 <dconde> #info of use YouTube live to stream video.
20:59:53 <dconde> #endmeeting