19:59:44 <tbachman> #startmeeting gbp_status
19:59:44 <odl_meetbot> Meeting started Thu Sep 18 19:59:44 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:59:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:44 <odl_meetbot> The meeting name has been set to 'gbp_status'
19:59:46 <tbachman> lol
19:59:49 <tbachman> s3wong: will do!
19:59:57 <tbachman> #topic agenda
20:03:26 <alagalah> s3wong: Good to know bro
20:03:32 <tbachman> #chair alagalah
20:03:32 <odl_meetbot> Current chairs: alagalah tbachman
20:03:52 <alagalah> #link Agenda https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting
20:04:07 <alagalah> #topic RC1, Karaf and package update - Bachman
20:04:18 <alagalah> tbachman: Start typing mate :)
20:04:32 <tbachman> #info Group Based Policy is in the RC1 release artifact
20:04:47 <tbachman> #info There was one issue that was project-wide, involving restconf
20:05:22 <tbachman> #info but there’s a workaround
20:05:43 <tbachman> #info TSC voted today to cut final release artifacts on Monday 9/22
20:06:46 <tbachman> #info The TSC will give a go/no-go to the release on the following Thursday’s TSC call
20:07:14 <tbachman> #info There will be release review meetings on Wednesday and Thursday, during the current bug-scrub meetings, for 2 hrs
20:07:58 <tbachman> #info Each project will have ~10 minutes for their release review, and will be allocated a time slot by Phil Robb and George Zhao
20:08:32 <tbachman> #info The autorelease setup that Ed Warnicke created will  handle converting from the SNAPSHOT releases to production, so no action is needed on our part for that
20:09:07 <alagalah> #topic Release Review preso next week
20:09:13 <alagalah> #info Items to be covered:
20:11:05 <alagalah> #info Features , Non-Code Aspects (user docs, examples, tutorials, articles), Architectural Issues, Security Issues, Quality Assurance (test coverage, etc), End-of-life (API/Features EOLed in Release), Bugzilla (summary of bug situation), Standards (summary of standard compliance) ,Schedule (initial schedule and changes over the release cycle)
20:11:25 <alagalah> #action Keith (alagalah) to cover these items in a quick (must be <10min) preso
20:11:41 <alagalah> #topic POC now open for business - Burns/Bachman
20:12:20 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Building_and_Running
20:13:23 <tbachman> #info The POC is now working, thanks to bug fixing over the weekend that alagalah did with Ed Warnicke, Tony Tkacik, and Michal Rehak
20:14:40 <tbachman> #info there was a change to the controller in terms of referencing the right Instance IDs in the Flow Capaable Node
20:15:05 <tbachman> #info there was also a change to yangtools to address a recent change to the codecs that was made
20:15:59 <tbachman> #info there were also two changes made to the GBP code to address another change to yangtools to address codecs (return null pointers instead of empty lists)
20:16:55 <alagalah> #topic Docs - Mickey
20:17:07 <alagalah> #info mickey not available today, thomas?
20:17:44 <tbachman> #info mickey_spiegel is about 1/3 through converting readams’ text
20:17:58 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture and sub-files
20:18:06 <alagalah> mickey_spiegel: You must have heard us talking about you
20:18:07 <alagalah> :)
20:18:20 <alagalah> mickey_spiegel: Perfect timing, topic is Docs
20:18:24 <alagalah> So far:
20:18:36 <alagalah> 13:16 alagalah: #topic Docs - Mickey
20:18:36 <alagalah> 13:16 odl_meetbot has set topic: Docs - Mickey (Meeting topic: gbp_status)
20:18:36 <alagalah> 13:17 alagalah: #info mickey not available today, thomas?
20:18:38 <alagalah> 13:17 tbachman: #info mickey_spiegel is about 1/3 through converting readams’ text
20:18:40 <alagalah> 13:17 mickey_spiegel has joined (~emspiege@64.125.181.92)
20:18:42 <alagalah> 13:17 alagalah: #link https://wiki.opendaylight.org/view/Group_Policy:Architecture and sub-files
20:18:44 <alagalah> 13:18 alagalah: mickey_spiegel: You must have heard us talking about you
20:20:18 <alagalah> #action alagalah to ping mickey_spiegel for update and will update minutes by tomorrow (Fri 9/19) with Docs Status
20:20:21 <mickey_spiegel> Last time I checked yesterday, only LispFlow stuff had docs
20:20:35 <mickey_spiegel> Do they really want to finalize docs by Monday?
20:20:41 <alagalah> #undo
20:20:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x23e55d0>
20:20:58 <alagalah> mickey_spiegel: Not sure when they want them by
20:21:06 <alagalah> mickey_spiegel: I was just going to check in with you on status tomorrow
20:21:10 <alagalah> But since you are here :)
20:21:15 <mickey_spiegel> Are docs coupled with release artifacts?
20:21:22 <tbachman> mickey_spiegel: not clear
20:21:24 <alagalah> mickey_spiegel: Great question
20:21:28 <alagalah> I would say no
20:21:49 <alagalah> mickey_spiegel: By the simple fact that only Lisp has docs and RC2 is next Monday
20:21:57 <mickey_spiegel> I should get Rob's text converted by the end of the weekend.
20:22:10 <mickey_spiegel> If I have trouble pushing code, worst case I can give the files to one of you
20:22:12 <alagalah> mickey_spiegel: Let me check in with edwarnicke
20:22:17 <alagalah> mickey_spiegel: Ping me
20:22:29 <alagalah> mickey_spiegel: My family is in Australia for a week, so I am home alone
20:23:35 <mickey_spiegel> If you know what software I should download to get over tracebacks in git review in OSX, that would help
20:23:48 * edwarnicke spidey sense is tingling
20:24:14 <tbachman> edwarnicke! :)
20:25:30 <tbachman> edwarnicke: it wasn’t clear to us what the timeline was for docs — do you know?
20:25:55 <edwarnicke> LOL
20:26:04 <tbachman> edwarnicke: is the plan to cut those on the same days as the other artifacts (i.e. 9/22)?
20:26:04 <edwarnicke> You are like the third person to ask me ;)
20:26:07 <tbachman> lol
20:26:12 <tbachman> I can find a 4th! ;)
20:26:18 <edwarnicke> So let me start with the factual, and then we can proceed to speculation
20:26:28 <edwarnicke> Fact: Docs project is not built in the autorelease
20:26:53 <edwarnicke> Correlary: Docs project is not built as a release artifact on Monday by the autorelease
20:27:02 * edwarnicke is out of facts on this subject :(
20:27:05 <tbachman> lol
20:27:07 <tbachman> speculation? :)
20:27:09 <edwarnicke> Shall I move onto speculation?
20:27:14 <tbachman> please :)
20:27:21 <edwarnicke> My expecation is that we will cut on Monday
20:27:37 <edwarnicke> Everyone will get up on Tuesday, do their testing again, and hopefully find things to be OK
20:27:44 <edwarnicke> And then turn their gaze towards docs
20:28:39 <tbachman> okay
20:28:46 <tbachman> thx!
20:29:28 <tbachman> #info The documentation is not part of autorelease, so if it’s cut on Monday, it will be done so manually
20:29:45 <tbachman> #info the goal should be to have docs ready for Monday, with speculation that there may be some iterations
20:29:57 <tbachman> edwarnicke: thx!!!!
20:30:32 <tbachman> #topics other items
20:30:38 <tbachman> #topic other items
20:30:47 <alagalah> #info Noiro is no longer at Sunnyvale, moving to B15, Cisco Campus
20:31:22 <tbachman> #info tbachman urges folks to download the RC2 (final) release artifacts and run the demo — the more platforms we get testing on the better
20:32:08 <tbachman> #endmeeting