18:00:18 <tbachman> #startmeeting gbp_status_arch
18:00:18 <odl_meetbot> Meeting started Fri Nov  7 18:00:18 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:18 <odl_meetbot> The meeting name has been set to 'gbp_status_arch'
18:00:26 <tbachman> #chair alagalah
18:00:26 <odl_meetbot> Warning: Nick not in channel: alagalah
18:00:26 <odl_meetbot> Current chairs: alagalah tbachman
18:01:24 <tbachman> #chair alagalah
18:01:24 <odl_meetbot> Current chairs: alagalah tbachman
18:01:46 <tbachman> #topic agenda
18:03:00 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting Agenda for today’s Status/Arch meeting
18:03:13 <tbachman> #topic Review of cleaned up Trello
18:05:49 <tbachman> #info alagalah condensed the number of cards by making checklists
18:06:31 <tbachman> #info The “Super-cala-fragalistic important” category contains items that were deferred from the Helium release
18:07:16 <tbachman> #info Team members are encouraged to pick cards from this Trello category first
18:07:48 <tbachman> #link https://trello.com/b/yc0xHFlv/opendaylight-groupbasedpolicy-lithium Lithium Trello board for GBP
18:08:36 <tbachman> #topic Lithium Release plan
18:09:45 <alagalah> #info shares a template for the Li Release Plan (link below)
18:09:52 <alagalah> #link https://docs.google.com/a/noironetworks.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit#gid=0
18:10:06 <alagalah> #action tbachman to link to GBP wiki and email -dev list
18:13:28 <alagalah> #info alagalah notes that Offset0 and Offset2 are the easiest to grok.. ie Offset0: others depend on you, you don't depend on other Offset2: you depend on others, no one depends on 2. Offset1 is a little more hazy (as in I haven't heard a definitive defn)
18:18:26 <tbachman> #topic WIP
18:19:12 <tbachman> #info alagalah working on design for the PolicyException Handler
18:19:21 <tbachman> #info Similar to the FCAPs model for alarming
18:19:39 <tbachman> #info This represents an alarm that can change over time
18:20:33 <tbachman> #info Alarm Severity Assignment Profile model (ASAP), which is an operational policy
18:21:30 <tbachman> #info The severity of the inability to get that policy can be augmented by the operational policy
18:23:13 <tbachman> #info alagalah invites those with Telcordia/FCAPs experience to help out
18:24:25 <tbachman> #info dbainbri asks how to refer to individual cards on the Trello board
18:24:39 <tbachman> #info alagalah says that each card has a name (e.g. card 37) and a link
18:25:45 <alagalah> #link https://trello.com/c/hjSnav8q - Exception handling trello card
18:26:03 <alagalah> #link https://trello.com/c/V8RqRzlC - Exception handling coding trello card
18:29:07 <tbachman> #link https://tools.ietf.org/html/draft-smith-opflex-00 Original OpFlex RFC
18:29:25 <tbachman> #topic POSTMAN files on wiki
18:29:48 <tbachman> #action alagalah to push POSTMAN files to the wiki
18:30:04 <tbachman> #info POSTMAN files can be used to exercise REST APIs with GBP
18:30:41 <tbachman> #topic Update on OpenStack Paris
18:30:53 <tbachman> #link https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/group-based-policy-extension-for-networking Group Based Policy Extension for Networking video at OpenStack Paris summit
18:30:54 <tbachman> #link https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/opendaylight-and-openstack-developer-panel OpenStack and OpenDaylight developer panel video at OpenStack Paris summit
18:30:55 <tbachman> #link https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/sponsor-demo-theater-one-convergence-policy-driven-network-service-delivery One Convergence: Policy Driven Network Service Delivery video at OpenStack Paris summit
18:30:56 <tbachman> #link https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/neutron-roundtable-overlay-or-full-sdn Neutron Round Table: Overlay or Full SDN? video at OpenStack Paris summit
18:30:57 <tbachman> #link
18:30:58 <tbachman> https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/sponsor-demo-theater-opendaylight-opendaylight-and-the-rise-of-open-source-sdn OpenDaylight and the Rise of OpenSource SDN video at OpenStack Paris summit
18:32:58 <tbachman> #undo
18:32:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x275b250>
18:33:08 <tbachman> #link : https://www.openstack.org/summit/openstack-paris-summit-2014/session-videos/presentation/sponsor-demo-theater-opendaylight-opendaylight-and-the-rise-of-open-source-sdn OpenDaylight and the Rise of OpenSource SDN video at OpenStack Paris summit
18:33:48 <alagalah> #topic HOW TOs
18:34:16 <tbachman> #info alagalah asks what we’re missing in order to make the project more consumable and easier to use?
18:34:39 <tbachman> #info alagalah notes we have wiki pages describing the arch  and the POC
18:35:16 <tbachman> #info alagalah says we’re missing a component map, along the lines of other projects (e.g. MD-SAL)
18:35:26 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture GBP Arch wiki page
18:35:44 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model GBP Policy Model wiki page
18:36:07 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture/OVS_Overlay GBP OVS Overlay wiki page
18:36:51 <tbachman> #info mickey_spiegel says the main thing that’s missing is more examples and use cases of policies and how you would use the model to do different things
18:37:17 <tbachman> #info alagalah says that was one of the goals of the latest iteration of the POC (i.e. dockerization), but notes that we could do morehere
18:38:16 <tbachman> #info alagalah asks what use cases mickey_spiegel would like to see
18:38:29 <tbachman> #info mickey_spiegel says he created a list before the Helium release, and will provide that
18:39:19 <tbachman> #info tbachman says there are use cases that Sanjay provided
18:39:35 <tbachman> #info mickey_spiegel says that those were a bit more complex, and that simpler use cases would probably be more useful
18:40:18 <tbachman> #info alagalah says the current POC is only a “two-tier”, so maybe a 3-tier might be helpful
18:40:29 <tbachman> #link https://wiki.opendaylight.org/images/8/83/Policy_Usecases.pptx Use cases created by Sanjay
18:41:53 <tbachman> #info dbainbri says component maps, API doc, tutorials are all very useful
18:43:17 <tbachman> dbainbri: we need SEO ;)
18:44:50 <alagalah> #action alagalah to document the FLOW of information through GBP and the OFOverlayRenderer in a diagram to help augment or show at a high-level the information that is represented in the Architecture wiki information
18:45:29 <alagalah> #action alagalah also how it interacts with all of ODL ie openflowplugin or indeed how to get it from a RESTcall etc
18:46:06 <alagalah> #action alagalah to make a User level walk thru (5min preso type level)
18:46:59 * tbachman looks for LED demo for GBP
18:48:28 <tbachman> #info Andrew has some ideas for the GUI/UI
18:48:43 <tbachman> #info initial thought for policies and contracts is sort of a google maps concept
18:49:21 <tbachman> #info you could zoom in to endpoints, zoom out to policies between data centers, etc.
18:49:41 <tbachman> #info The other dimension to the UI is specifying policies/contracts
18:54:33 <tbachman> #endmeeting