18:00:51 <tbachman> #startmeeting gbp_status_arch
18:00:51 <odl_meetbot> Meeting started Fri Nov 14 18:00:51 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:51 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:51 <odl_meetbot> The meeting name has been set to 'gbp_status_arch'
18:00:56 <tbachman> #topic agenda
18:01:07 <tbachman> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting Agenda for today’s meeting
18:01:39 <tbachman> we’ll wait 5 mins for folks to join
18:02:24 <tbachman> s3wong: attending today?
18:02:36 <s3wong> tbachman: yes
18:02:53 <s3wong> tbachman: for half an hour :-)
18:02:53 <tbachman> https://cisco.webex.com/cisco/j.php?MTID=m783db2a03dec4c9aab0e22e43db642d6
18:03:43 <tbachman> #topic OpenStack Integration
18:04:19 <tbachman> s3wong: let me know if there’s any links that we should share here
18:05:05 <s3wong> tbachman: here it is #link https://review.openstack.org/#/c/134285/1/specs/juno/gbp-odl-policy-driver.rst,unified
18:05:23 <tbachman> s3wong: thx!
18:05:58 <tbachman> #link https://review.openstack.org/#/c/134285/1/specs/juno/gbp-odl-policy-driver.rst,unified openstack blueprint for group based policy integration with opendaylight
18:09:38 <tbachman> #info s3wong says the groupbasedpolicy for openstack will be released as a separte bundle for Juno (december time frame)
18:09:49 <tbachman> #info default driver maps policy constructs to neutron constructs
18:10:03 <tbachman> #info There are also 2 vendor drivers: OneConvergence and APIC
18:10:11 <tbachman> #info There currently isn’t a driver for opendaylight
18:10:18 <tbachman> #info s3wong will be writing this driver
18:10:48 <tbachman> #info The driver will do a one-to-one mapping of OpenStack GBP constructs to ODL GBP constructs
18:11:17 <tbachman> #info There will be an extension driver created as well
18:11:50 <tbachman> #info s3wong says a gap analysis is needed
18:11:58 <tbachman> #info openstack has support for redirect to a service
18:12:19 <tbachman> #info GBP has such support, but there’s no such concept as services in ODL
18:14:04 <tbachman> #info the assignment of resources to things like a load balancer is done by openstack groupbasedpolicy, but such constructs may not exist in ODL
18:14:34 <tbachman> #info YaPeng Wu from Hauwei plus 2-5 others may be joining the effort
18:14:49 <tbachman> #info YaPeng is also interested in writing the OVSDB renderer
18:16:41 <tbachman> #info There is an effort to create a policy program in openstack, so GBP and Congress may become part of that
18:17:39 <tbachman> #info The repo currently doesn’t have any CI, but as part of the effort, CI needs to be stood up in GBP repo to vote on patches
18:18:27 <tbachman> #info Vendor CI will probably be done as part of Juno
18:18:49 <tbachman> #info The feature-freeze for Juno is in 2 weeks, and ODL driver probably won’t make it
18:19:06 <tbachman> #info This may not be bad, as the Lithium cycle aligns well with the Kilo release
18:19:09 <rgowrishankar> Did Stephen mention that gbp on OpenStack will be moving out of neutron if the policy project gets approved?
18:19:41 <rgowrishankar> Or did I mis-understand what he was saying?
18:19:41 <tbachman> rgowrishankar: he said that they were discussing it
18:19:44 <s3wong> rgowrishankar: it is currently NOT in Neutron anyway --- so technically NOT moving out :-)
18:19:44 <rgowrishankar> ok
18:19:53 <tbachman> s3wong: thx!
18:20:08 <tbachman> #topic HOW-TOs
18:21:02 <rgowrishankar> s3wong: so on OpenStack there are technically 3 ways to control a network: nova-network, neutron and GBP?
18:21:16 <tbachman> #link https://docs.google.com/a/noironetworks.com/document/d/1bZAwLk1EffE3ZU3QfzROZQ5kDdm6yScBcZADIFKFDbo/edit Original Use Cases document on GBP wiki
18:21:22 <s3wong> rgowrishankar: different level of abstraction... but YES
18:21:40 <tbachman> #info alagalah welcomes anyone to add to this
18:22:30 <tbachman> #info By separating infrastructure and policy, it makes it easier to stand up different infrastructures using the same policy
18:22:57 <s3wong> rgowrishankar: one of the goals of Neutron Kilo is to make Neutron the default networking for Nova, and once that is done, nova-networking will be slowly deprecated
18:23:04 <tbachman> #info alagalah would like to set up a 3-tier web app
18:24:05 <rgowrishankar> alagalah: do david and I need to add to that document? I don't have audio today....
18:24:08 <tbachman> #info Daniel asks to see something that’s not a pure consumer/producer relationshipo
18:24:51 <tbachman> #info alagalah says that for peer-to-peer, the model does support intra-group policy, but this is currently stubbed in the code
18:25:12 <tbachman> #info alagalah asks what sorts of things Daniel would like to see
18:25:28 <tbachman> #info Daniel says it’s mostly for access (e.g. ICMP)
18:25:54 <tbachman> #info alagalah says that currently the default behavior within an EPG is to allow connectivity
18:26:10 <tbachman> #action to look into this further and get back to Daniel
18:30:59 <tbachman> #info Daniel says from an orchestration perspective, he doesn’t want to have to track which group is a provider and which is a consumer of a contract
18:31:26 <tbachman> #info alagalah says that we need to work out how we’re going to work the producer/consumer for the UI as well
18:32:15 <s3wong> Dropping off, have fun for the rest of the meeting. Thanks, guys!
18:32:20 <tbachman> s3wong: thank you!
18:35:08 <tbachman> #topic Trello Board
18:36:14 <tbachman> #info alagalah  working on opstate and exception repository design
18:37:24 <tbachman> #info alagalah wants to have fault rules (e.g. threshold crossing), and can assign severity to a fault and have it placed in the data store
18:37:59 <tbachman> #info the heuristics need to be configurable by the operator
18:38:04 <tbachman> #info these would be operational policies
18:39:08 <tbachman> #info alagalah says that there’s also a question of how to apply governance to all of this, but that’s further down the road
18:40:20 <tbachman> #link https://tools.ietf.org/html/draft-smith-opflex-01 Latest OpFlex RFC
18:42:01 <tbachman> #info tbachman working on updating the OpFlex renderer based on these RFC updates
18:42:13 <tbachman> #info alagalah going to work on the 3-tier web app demo as well
18:42:31 <tbachman> #link https://trello.com/b/yc0xHFlv/opendaylight-groupbasedpolicy-lithium Trello board for GBP
18:42:38 <tbachman> #topic Lithium Release Plan
18:42:46 <tbachman> #chair alagalah
18:42:46 <odl_meetbot> Current chairs: alagalah tbachman
18:54:57 <tbachman> #link https://docs.google.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit?usp=sharing
18:55:02 <rgowrishankar> I have a question on the openflow renderee
18:55:03 <tbachman> #undo
18:55:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2509690>
18:55:14 <tbachman> #link https://docs.google.com/spreadsheets/d/15nBWBNxCy3518o3tj808HjKaz2n7qyUgxQWDUKZEmy4/edit?usp=sharing Template for project tracking
18:55:19 <rgowrishankar> why is there a switch manager instead of using the the operational database
18:55:44 <rgowrishankar> i can listen to you
18:55:48 <rgowrishankar> i just cant speak
18:57:05 <rgowrishankar> will do it offline
18:57:58 <tbachman> #endmeeting