20:11:39 <alagalah> #startmeeting group-based-policy 14-05-15 STATUS
20:11:39 <odl_meetbot> Meeting started Thu May 15 20:11:39 2014 UTC.  The chair is alagalah. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:11:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:11:39 <odl_meetbot> The meeting name has been set to 'group_based_policy_14_05_15_status'
20:11:49 <alagalah> #chair regXboi readams mickey_spiegel
20:11:49 <odl_meetbot> Current chairs: alagalah mickey_spiegel readams regXboi
20:11:54 <alagalah> #topic Agenda review
20:11:59 <regXboi> why are you chairing people?
20:12:29 <alagalah> regXboi: force of habit
20:12:30 <regXboi> what's the #link for the agenda?
20:12:33 <alagalah> regXboi: stop taunting me
20:12:39 <alagalah> #topic Agenda: https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting
20:12:48 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting
20:13:31 <regXboi> #info regXboi here
20:13:37 <tbachman> #info tbachman here
20:13:40 <readams> #link https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2014-May/000171.html
20:13:48 <alagalah> #info readams mickey_spiegel alagalah here in Sunnyvale
20:14:25 <regXboi> so, are we taking comments on the architecture wiki page?
20:14:25 <jmedved> #info jmedved here
20:14:27 <alagalah> #info what Rob linked is the current Functional Spec
20:14:47 <regXboi> #info are we taking comments on the architectural wiki page?
20:14:49 <readams> #info it's the current status as of yesterday
20:14:57 <alagalah> #info ie, he is tongue in cheek saying "This is the current status" which is fair, but I have one or two more things to cover
20:15:06 <regXboi> #info I'm concerned about the first figure
20:15:09 <alagalah> So let me ask, who on here as read it ?
20:15:13 <regXboi> #info it's missing something
20:15:34 <readams> which is what?
20:15:36 <alagalah> #info https://wiki.opendaylight.org/view/File:Group-based_policy_architecture.png
20:15:53 <regXboi> shim layer between MD-SAL RESTconf and Orchestration?
20:16:05 <regXboi> not complete shim layer
20:16:08 <regXboi> half shim layer
20:16:09 <alagalah> huh ?
20:16:10 <readams> not sure I understand
20:16:15 <alagalah> Ah.... yeah I am lost too boss
20:16:18 <regXboi> so this figure says
20:16:25 <readams> the orchestration layer talks to restconf
20:16:50 <regXboi> so, you are expected systems (cough openstack cough) to code RESTconf into their plugin?
20:17:24 <regXboi> I think it's much more sensible to have a half horizontal layer so that we can present APIs to orchestration systems that they expect
20:17:44 * tbachman is half horizontal
20:17:48 <tbachman> (jk, btw)
20:18:04 <alagalah> hold 1
20:18:06 <jmedved> regXboi: if the API is different than provided by Resticonf, right
20:18:08 <readams> I don't think this diagram necessarily needs to represent all possible ways of using it
20:18:19 <lenrow> Does a policy client (above REST) need to be aware that we are distributing the (whole) policy across these various silo's? Seems like important for impl/perf, but no need to expose to users of API
20:18:23 * regXboi hopes c2h60 was involved
20:18:28 <readams> If you wanted your shim layer it would actually talk to the data store API
20:18:36 <readams> not restconf
20:18:38 <alagalah> #info regXboi are you thinking back to this: https://wiki.opendaylight.org/view/File:Architecture-tasks.png
20:18:39 <tbachman> regXboi: lol
20:19:04 <regXboi> #info no
20:19:15 <regXboi> #info I'm thinking more like list
20:19:38 <regXboi> ah shoot
20:19:52 <alagalah> regXboi: ?
20:19:57 <regXboi> #info aw shoot, the figure I want isn't where I thought it was
20:20:02 <regXboi> ascii art time
20:20:11 <regXboi> +-----------------------+
20:20:22 <regXboi> +      orchestartion      +
20:20:25 <lenrow> #info can we hide multiple repos from the API exposed? More complexity that has nothing to do with user domain intent
20:20:27 <regXboi> +-------------------------+
20:20:33 <regXboi> |                   |
20:20:39 <regXboi> |              |
20:20:40 <readams> are you aware of the existence of variable-width fonts?
20:20:45 <regXboi> oh never mind
20:20:59 <regXboi> yes, but I always do fixed width in IRC
20:21:00 <alagalah> regXboi: Nice try mate... sorry we don't have any decent comms
20:21:06 <tbachman> pastebin
20:21:06 <regXboi> to allow for ascii art
20:21:12 <regXboi> tbachman
20:21:16 <tbachman> dropbox
20:21:17 <regXboi> tbachman: will do
20:21:24 <regXboi> no dropbox on this machine
20:21:29 <tbachman> k
20:21:40 <alagalah> Ok back to my prior point... who has read the func spec?
20:21:50 <regXboi> I have
20:21:50 <alagalah> (silence means you have not)
20:21:55 <mickey_spiegel> I read the outline, not the model which is most of it
20:22:04 <readams> it's only like 10% done
20:22:14 <alagalah> #info regXboi alagalah have read func spec. mickey_spiegel has read outline
20:22:22 <alagalah> #info readams notes 10% done
20:22:28 <tbachman> #info tbachman has skimmed it
20:22:29 <readams> but it will converge to 100% only as the project gets closer to completion
20:22:56 <alagalah> #info Suggest that people start to review it and comment on the mailer
20:22:59 <readams> #info the thing you should read now is the model
20:23:05 <regXboi> #info http://pastebin.com/DrsWSUAn
20:23:06 * lenrow We are polluting the user experience (API) with details reflecting the implementation/optimization.
20:23:11 <regXboi> that's what I'm talking about
20:24:08 <alagalah> regXboi: Trying to pull up pastebin link
20:24:30 <alagalah> Ummm
20:24:32 <tbachman> lenrow: can you elaborate?
20:24:35 <alagalah> So why do we need a SHIM boss ?
20:24:51 <readams> you can assume that you can talk to the state repositories through any means supported by MD-SAL
20:25:02 <regXboi> the point is that is not the same orchestration system
20:25:06 <regXboi> just the set of orchestation systems
20:25:07 <readams> MD-SAL/carrier pigeon bindings also work
20:25:18 <regXboi> I'm sorry, I'm going to be difficult on this one
20:25:36 <alagalah> regXboi: Not difficult, but ... why do we need a shim, can't that exist in the orch-cloud ?
20:25:37 <regXboi> if you don't have that shim, you are asking openstack to do something unrealistic
20:25:43 * lenrow tbachman:  Maybe jumped the gun. If the user is aware that there are multiple repo's we have failed as designers
20:26:04 * lenrow If these details hidden, me happy
20:26:13 <readams> there actually _aren't_ multiple repos
20:26:14 <regXboi> why should I expect the orch-cloud to talk restconf?
20:26:17 <alagalah> tbachman: lenrow can we just have one topic please
20:26:23 <alagalah> tbachman: lenrow We can get to that in a bit
20:26:25 <tbachman> alagalah: fair enough
20:26:27 <regXboi> (me is following both)
20:26:28 <readams> the separation in the models is for user convenience
20:26:51 <tbachman> Did somone #topic?
20:27:07 <regXboi> the point is that openstack will define a set of APIs and they likely *won't* be restCONF
20:27:08 <tbachman> ah yes :)
20:27:16 <tbachman> (someone topic'd)
20:27:28 <regXboi> or RESTconf
20:27:39 <readams> Anything that can talk to MD-SAL can configure the policy
20:27:46 <regXboi> so I'd rather have the RESTconf kept "in house" and expose the REST API that something like openstack expects
20:28:00 <alagalah> jmedved: Do you have anything to add about MD-SALs ability to generate API ?
20:28:17 <alagalah> regXboi: I like where you are headed but ...
20:28:18 <lenrow> Don't we just say yang tools auto-gen multiple API bindings and keep moving
20:28:22 <jmedved> regXboi: Restconf should be exposed as well, not just in-house
20:28:36 <regXboi> jmedved: it is, that's the right side of the pastebin
20:28:37 <readams> yang tools won't generate the API ryan is proposing
20:28:39 <alagalah> lenrow: Are you 100% positive that it will work? I'd like to hear from jmedved
20:28:41 <tbachman> jmedved: I think that's what regXboi 's model shows
20:28:45 <jmedved> if there is a need for adaptation, we use it
20:28:46 <jmedved> right
20:28:46 <readams> If we want at some point we can implement another REST API
20:28:52 <readams> for now let's start simple
20:28:58 <readams> Note: nothing is written in stone
20:29:07 <readams> this spec will change as we develop
20:29:09 <jmedved> so an orchestration system that wants to talk (or can talk) restconf ,can go directly
20:29:14 <regXboi> if we have the "architectural whitespace" I'm good
20:29:17 <regXboi> jmedved: yes
20:29:27 <alagalah> jmedved: What about those who just want REST ?
20:29:28 <readams> Please don't latch onto small details at this point
20:29:44 <jmedved> now, if OpenStack defines their onw API, it will probably have a different sysntax and semantcis to whatever we define
20:29:57 <jmedved> so there will need to be the shim to adapt between the two
20:30:03 <regXboi> jmedved: +1
20:30:16 <alagalah> jmedved: how does it happen today?
20:30:25 <lenrow> I think point is that restconf is generally foreign to Openstack devs
20:30:28 <readams> so if the 4 characters "conf" were removed from that diagram you'd all be happy?
20:30:30 <jmedved> but OpenStack could just as well adopt restconf, if they really wanted to
20:30:45 <jmedved> the reasons for them not wanting to will probably not be technical
20:31:04 <readams> we are developing the openstack plugin also
20:31:20 <regXboi> readams: wait, what?
20:31:27 <lenrow> Who is the "we"?
20:31:38 <readams> not in this project.  People who sit 10 feet from me
20:31:39 <jmedved> readams: that’s good :-)
20:31:52 <regXboi> well
20:31:54 * tbachman wonders if now is the time for the neutron NB to be broken into it's own "project"
20:32:00 <tbachman> (as mentioned by others)
20:32:18 <regXboi> I'll be 100% honest - I'm not going to be happy about an openstack plugin that is restCONF only
20:32:27 <regXboi> but that's out of scope for this conversation, so I'll stop
20:32:47 <regXboi> anyway, I've said what I want :)
20:33:30 <alagalah> #info Duly noted that regXboi points out that API does not live on restCONF alone, but on every word from the mouth of REST
20:33:41 <jmedved> regXboi, readams: we will need a call so that we can shout at each other :-) or epxlain things in real time
20:33:45 <alagalah> #info alagalah had a bad bible upbrining
20:33:50 <alagalah> Next topic?
20:34:06 <regXboi> alagalah: yes next topic
20:34:13 <alagalah> jmedved: yes, we are screwed at this point for voice... will fix
20:34:25 <lenrow> Can't we at least launch an n-way skype call? voice comms exist for a reason.
20:34:29 <alagalah> #topic Trello/Plan Of Record
20:34:59 <regXboi> lenrow: unfortunately that puts me out - no skype allowed on this work laptop
20:35:02 <alagalah> #link https://docs.google.com/a/noironetworks.com/spreadsheets/d/1Tp2dblnizQ4xi_4xcQgHP8dRPiqxdgC9pqlRdEuP6_I/edit#gid=0
20:35:11 <lenrow> OK. Understand
20:35:20 <tbachman> lenrow: we need UC&C ;)
20:35:23 <tbachman> (jk)
20:35:41 <alagalah> #link https://trello.com/b/edPC5PAe/odl-gbp-helium
20:36:28 <alagalah> #info I'm assuming that those on the PlanOfRecord who are committed to contributing have made their intentions known.
20:36:59 <alagalah> #info as we get to complete the Func Spec, my intention is that a lot of these meetings are going to disappear, and meetings will be between contributors on the project.
20:37:09 <alagalah> #info any questions?
20:37:21 <regXboi> it looks like we are missing the exception/enforcement YANG or is that in the existing model?
20:37:25 <jmedved> alagalah: makes sense
20:37:45 <alagalah> regXboi: its on the POR hold 1
20:38:00 <regXboi> I'm looking at the Helium Release plan
20:38:06 <regXboi> google doc
20:38:06 <alagalah> Oh
20:38:12 <alagalah> Plan of Record?
20:38:18 <regXboi> yes
20:38:29 <regXboi> it's yellow on the overview
20:38:31 <alagalah> Tab Exception/Enforcement
20:38:35 <alagalah> Yes, it hasn't been done yet
20:38:37 <alagalah> It needs to
20:38:50 <regXboi> do I need to cherry pick that?
20:39:01 <alagalah> So far only ones signed up are Keith, Rob, Thomas
20:39:09 <lenrow> #info as discussed my goal is to prototype some end-to-end use cases using GBP. We will likely commit resources to subprojects as required to accomplish this. still TBD (e.g. model, rendering, etc.)
20:39:28 <alagalah> #info As of next week, my intention is to start managing the meetings via Trello
20:39:30 <regXboi> remember, I'm floating... so I can cherry pick the missing model if I need to
20:39:37 <alagalah> regXboi: Ack and appreciated
20:40:22 <regXboi> should I #action that?
20:40:31 <regXboi> and the otherthing missing si the Renderer Commons
20:40:35 <regXboi> did I type that?
20:41:19 <alagalah> regXboi: Yes, we are behind on that too
20:41:42 <regXboi> so I'll make you a deal
20:41:48 <alagalah> #info EPR/PR very close to being done (in terms of Yang).
20:41:52 <alagalah> regXboi: Sure mate
20:42:04 <regXboi> you take Renderer Commons and I'll take Exceptions YANG?
20:42:20 <alagalah> regXboi: Rock on, yes... I also have OpState YANG... Trello up homey
20:42:23 <alagalah> (and thanks)
20:42:52 <regXboi> #action regXboi to catch up Exception/Enforcement YANG
20:43:12 <lenrow> Mike and I discussed renderer arch yesteday F2F. I can probably carry more load if we want to start the meetings on renderer
20:43:17 <regXboi> look for it over the weekend and I may forget to Trello up - meetings through 1am tonight :(
20:43:20 <alagalah> #action alagalah to define Renderer commons
20:43:53 <tbachman> alagalah: shall we action working with lenrow and uchau on end-to-end use cases?
20:44:07 <lenrow> +1
20:44:15 <regXboi> +max_u64_int
20:44:28 <tbachman> lol
20:44:34 <alagalah> tbachman: Go for it, action away, in fact, make a card and own it
20:44:42 <tbachman> can non-chairs action?
20:44:45 <jmedved> :tbachman, lenrow: can you please add me to the end-to-end use cases?
20:44:49 <alagalah> #chair tbachman
20:44:49 <odl_meetbot> Current chairs: alagalah mickey_spiegel readams regXboi tbachman
20:45:00 <regXboi> #action tbachman, jmedved, lenrow uchau to work end-to-end use cases
20:45:10 <regXboi> did I miss anybody?
20:45:20 <lenrow> who elected you guys king? I didn't vote for you (life of brian reference, jk)
20:45:27 <tbachman> lol
20:45:31 <alagalah> #chair lenrow
20:45:31 <odl_meetbot> Current chairs: alagalah lenrow mickey_spiegel readams regXboi tbachman
20:45:35 <tbachman> lol
20:45:37 <regXboi> lenrow: he who starts the meeting is the chair
20:45:39 <tbachman> who's *not* a chair :)
20:45:56 <lenrow> can I put that on my resume?
20:45:58 <regXboi> I consider "chairing" punishment :)
20:46:01 <tbachman> lol
20:46:12 <regXboi> anyway... what's the next topic?
20:46:13 <alagalah> #unchair tbachman
20:46:13 <odl_meetbot> Current chairs: alagalah lenrow mickey_spiegel readams regXboi
20:46:16 <tbachman> lol
20:46:18 <alagalah> not you
20:46:36 <tbachman> help, help, I'm being oppressed!
20:46:41 * regXboi starts to hear the refrain of "dueling chairs"
20:46:49 <alagalah> #action alagalah to start each meeting that has a sub-group that applies with the trello sub-group
20:46:56 <lenrow> He's not the messiah, he's a very naughty boy
20:47:01 <alagalah> #topic Any other business?
20:47:05 <readams> music stops, someone loses their chair
20:47:13 <regXboi> #info move to adjourn?
20:47:19 <alagalah> #info +1
20:47:24 <tbachman> #info +1
20:47:33 <regXboi> ok it looks like we're out
20:47:34 <regXboi> :)
20:47:37 <alagalah> #endmeeting