19:56:55 <readams1> #startmeeting Group Policy Status
19:56:55 <odl_meetbot> Meeting started Thu Apr 24 19:56:55 2014 UTC.  The chair is readams1. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:56:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:56:55 <odl_meetbot> The meeting name has been set to 'group_policy_status'
19:57:28 <readams1> #chair alagalah
19:57:28 <odl_meetbot> Current chairs: alagalah readams1
19:59:27 <alagalah> https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.nf43n3np1b0kc48it41dsg4v2o
20:01:47 <s3wong> Alone on webex
20:02:13 <readams1> https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.nf43n3np1b0kc48it41dsg4v2o
20:02:42 <s3wong> Huh? Are we switching it to Google Hangout now?
20:03:44 <alagalah> jmedved: Are you going to join the ghangout ?
20:05:30 <readams1> #topic Actions from last week
20:06:38 <jmedved> hi guys
20:06:55 <readams1> #info Datastore: they tentatively stated we'd used MD-SAL and figure out how to implement sharding
20:07:15 <readams1> #info Need to benchmark and verify working assumptions
20:07:44 <readams1> #info repository/endpoint: working on defining basic outline, need help with MD-SAL best practices
20:09:23 <readams1> #info Jan will help to build the model
20:12:16 <alagalah> #action alagalah readams1 jmedved to meet Fri Apr25 after ARCH meeting for 90min to build Yang for Endpoint Reg and a subset of the UML Model with potentially a follow up Tue Apr29 with jmedved and Tony
20:13:00 <readams1> #info Jan may invite other people to help with this.
20:13:15 <alagalah> #action Prior commitment to have Endpoint Reg strawman for Mon Apr28 may not be feasible.
20:14:44 <alagalah> #info Renderer meetings on hold until readams1/alagalah get strawman Renderer. May be predicated on YANG/MD-SAL discussions so will have better idea Monday Apr28
20:15:05 <readams1> #topic Operational state
20:16:04 <regXboi> did you go away?
20:16:10 <readams1> #info What does "operational state" mean?
20:17:41 <readams1> #info is it about instrumentation?  Or is it about making sure that the end-user readily consume group-based policy?
20:18:40 <readams1> #info Or is it operational data such as link-state information, etc?
20:19:14 <readams1> #info Does it have to do with the "enforcement/exception database"?
20:20:34 <readams1> #info People will be want to analyze logs and also based on specific policies or objects
20:20:39 <readams1> #info compliance
20:22:21 <readams1> #action alagalah will talk to dvorkinista to clarify
20:22:45 * regXboi moves to replace operalization as o11n
20:23:01 <readams1> operationalization
20:23:24 <regXboi> o16n then
20:23:31 <alagalah> consumption, like locust
20:23:42 <readams1> OpenDaylight consumes the world
20:25:41 * regXboi gets rather nervous
20:26:08 <readams1> #info divorkinsta says it's about: capture of the general state and exceptions associated with it
20:26:49 <readams1> #info counters, measurements, exceptions, overall health, debugging, etc
20:27:35 <alagalah> #action dvorkinista attends and clarifies OPSTATE.
20:28:06 <readams1> #topic Renderer
20:28:39 <readams1> #info We need to settle on what the downstream prototype plugin would work
20:29:46 <readams1> #info we'll assume for now we'll use OpenFlow implementation, but we'll investigate what's the easiest
20:30:14 <readams1> #info Affinity might also provide a reasonable renderer
20:31:43 <readams1> #info Openflow/ovsdb may be the most understandable, but we'll have to see
20:32:54 <readams1> #action alagalah will look at the different projects to figure out what has the most reasonable northbound API
20:33:42 <readams1> #info Another possibility would be netconf/ACL/whatever
20:34:16 <dlenrow_> Probably shouldn't depend on an Affinity renderer being developed in Helium time-frame by Plexxi resources
20:34:17 <readams1> #info options are: opendove, ovsdb, netconf, openflow
20:34:52 <readams1> #info openflow/ovsdb are known quantity, not tied to a vendor
20:35:02 <dlenrow_> fabian would argue that VNT is also something one might render simple connectivity policies to
20:35:13 <readams1> #info Note that this isn't the only rendered: just the first renderer
20:35:21 <readams1> #topic Helium release plan
20:35:57 <alagalah> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan
20:36:25 <dconde> #info I don't see the desktop.
20:36:27 <dconde> #info now I do.
20:37:59 <readams1> #info Do declare intent to participate in simultaneous release, we need to publish our release plan for public comment
20:38:13 <readams1> #info project plan needs to align to the milestone dates
20:38:33 <dconde> #info release plan template is still for Hydrogen
20:38:48 <readams1> #info release plan template needs to be updated
20:39:18 <dconde> #info does it resemble a waterfall project plan?
20:39:23 <dconde> #info regxboi states it is.
20:39:57 <regXboi> #link https://wiki.opendaylight.org/view/Open_DOVE:Release_Plan_2013
20:40:21 <dlenrow_> #info can change the draft release plan until M2
20:40:38 <dconde> #info big milestones are M4 and M5
20:41:19 <dconde> #info plans are not supposed to change after M2.
20:41:48 <readams1> #info most project didn't really hit milestones for Hydrogen
20:43:08 <readams1> #info there's some tolerance for minor misses
20:43:22 <dconde> #info two weeks left to create a plan.
20:44:16 <dconde> #info we cannot put features into patches.
20:44:52 <readams1> #action alagalah will build a sophisticated and complete draft plan
20:44:55 <dconde> #info release plans are an honor system.
20:48:19 <dlenrow_> +1 Agendas
20:48:28 <readams1> #info agendas = good
20:49:42 <readams1> #endmeeting